Charmed Quark Systems, Ltd. - Support Forums and Community
iTunes missing artwork thread - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: Installation/Configuration (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=10)
+--- Thread: iTunes missing artwork thread (/showthread.php?tid=2794)

Pages: 1 2 3 4


iTunes missing artwork thread - 1080iAddict - 09-05-2007

K. Now that I have functionality, I have a new issue / question on a different topic.

I am missing some artwork. But what is interesting is that I do not THINK it is a CQC issue, Well not directly at least, but if I can get Apple iTunes to work correctly on the network, CQC should in theory follow the fix.

My iTunes Reposirory Driver is installed on my THEATER computer. The iTunes Repository Driver is also installed on the THEATER computer and running properly. The same Apple iTunes Application on the THEATER is also missing the same artwork. So it sounds proper that this is not a CQC issue. I need the underlying XML file on the THEATER computer to have links to the artwork.

But, on the OFFICE Apple iTunes Application installed on the OFFICE computer, the missing artwork is present!!!!!!!!! Magic. But why, and how do I get that artwork to the SERVER computer (where the music folder is located), and then how do I get it to the THEATER computer so that the XML file gets properly updated?

One hint: It SEEMS like all of the missing artwork was from music I ripped myself on the OFFICE computer, as opposed to the artwork for songs I purchased from the iTunes store. But one caveot: I deleted the "iTunes" folder containing all the artwork and the XML file during the re-install of iTunes on the OFFICE PC. Yet, somehow the art is still there because i see it in the Apple iTunes Application on the OFFICE computer.

WTF? Those are the only 3 letters that come to mind.

Adam

p.s. I will start a thread on an iTunes chat board if need be cause I think its an iTunes issue.... but figured I would pick your brains because others might have this issue integrating the repository with CQC.


iTunes missing artwork thread - 1080iAddict - 09-05-2007

Well I figured out an inefficient way to do it, barring a more efficient way:

1. Open iTunes on the OFFICE PC, find the art I need, get info on the song, right click on the art and select 'copy', and then open a shared folder on the OFFICE PC, paste the image in, rename it from "image.bmp" to a friendly name

2. Go downstairs to the THEATER PC, open iTunes on the THEATER PC, navigate to the same collection that has the missing art, get info on the song, go to the art tab, add the saved image from the shared folder on the OFFICE PC.

3. Reload the XML file into the iTunes Repository via the Admin Interface.

As i said, not efficient, but a work around.


iTunes missing artwork thread - 1080iAddict - 09-05-2007

Not that I feel like talking to myself.... but that idea above is not working - - - only for selected songs it works. On other songs, there is no 'artwork' tab under 'get info' or there is an 'artwork' tab and it will not let you change the artwork.... or.... the correct artwork is present on the THEATER PC but the art still wont load into the repository. Wierd.


iTunes missing artwork thread - NishanF - 09-05-2007

Adam,

Yet one more reason to stop me from switching to Itunes!

There is quite a bit of info out there on the itunes cover art problem.. Here is one link that might help a bit:
http://www.downloadsquad.com/2006/11/30/how-to-fix-your-itunes-artwork/

I generally could get the cut and paste method to work. Also if there isn't an artwork tab, there is sometime a little square with the artwork, or a blank box. There is a checkbox next to the it which can be cleared to clear the artwork.


iTunes missing artwork thread - Dean Roddey - 09-05-2007

Well I'm glad it wasn't me. I had so much trouble with that, and I just assumed I was missing something and was just too stupid to figure out how it was mapping the ids to the cover art.


iTunes missing artwork thread - wuench - 09-06-2007

I thought the cut/paste method embeds it in the file, but this doesn't seem to always be the case. I found this out by deleting the external artwork directories and then iTunes only displays the files with embedded art.

I use Tunesleeve now to embed my artwork, but it's even a little quirky. Sometimes it takes a couple of passes to find all the files without artwork. Sometimes I just let it overwrite my whole collection, which takes a while...

But I always have artwork in CQC after that...


iTunes missing artwork thread - 1080iAddict - 09-06-2007

wuench Wrote:I thought the cut/paste method embeds it in the file, but this doesn't seem to always be the case. I found this out by deleting the external artwork directories and then iTunes only displays the files with embedded art.

I use Tunesleeve now to embed my artwork, but it's even a little quirky. Sometimes it takes a couple of passes to find all the files without artwork. Sometimes I just let it overwrite my whole collection, which takes a while...

But I always have artwork in CQC after that...

hmmm. I tried everything else so Ill try that next.


iTunes missing artwork thread - 1080iAddict - 09-06-2007

I have tried everything under the sun to no avail. There is some artwork in iTunes that refuses to show up in CQC, period. Dont know why and dont know how. Usually, however, when it happens, iTunes itself will not let me change the artwork. I can clear downloaded artwork, but it will not let me install custom artwork. I can tell it to download the artwork, and it does via the iTunes store, but that artwork will not show in CQC.

For other songs, I can add and delete artwork at will by using the "get info" tab and then artwork, and then select "add". Why that button is available for certain titles and greyed out for others is beyond me. But if the artwork is missing and IF...which is a big IF.... that button is not greyed out for a given selection, I can add the artwork, then reload the CQC repository, and it shows in CQC.

Bottom line is that some songs have that "add" button greyed out and its those songs that will not show the artwork in CQC even though it shows in iTunes. Nothing I can seem to do to figure out that enigma. But if there is an "add" button available, I can get the artwork to show in CQC.

Maybe some art is embedded in the song.... and some art is embedded in a database. I just dont know anymore.


iTunes missing artwork thread - 1080iAddict - 09-06-2007

One other thing. Regarding my post above, all the info under 'get info' is greyed out for certain songs.... and those are the songs for which I cant play around with the artwork. Why I just dont know.


iTunes missing artwork thread - Dean Roddey - 09-06-2007

Yeh, I saw things like that and really had no idea why it worked that way. I could get it happy by just toasting the iTunes files (the .xml and .itl file) and importing all the music again, though I only tried that a couple times and it might have only just happened to have worked for me those times, and you lose any customization of the data you've done.