Charmed Quark Systems, Ltd. - Support Forums and Community
Triggered Event only works every second time - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: CQC Support (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=9)
+--- Thread: Triggered Event only works every second time (/showthread.php?tid=11156)



Triggered Event only works every second time - znelbok - 10-15-2020

I have some triggered events that are using my lighting system (C-Bus) as a trigger, but they only ever work the second time.

The field is changing in CQC from 0 to 100 and 100 to 0 everytime I press the light switch, but CQC will only trigger the actions assigned every second time - very repeatable.

Even if I turn the light on from CQC its the same result.

Any reason why this would be case.

I've rebooted the server and checked the code but the fact that it works as desired indicates there is no issues in the code.

Not sure if other drivers are exhibiting the same result, need to test htat some more

Mick


RE: Triggered Event only works every second time - Dean Roddey - 10-16-2020

What are the filters for the triggered event? Enable logging on the event to see if it's getting invoked but nothing is happening, or if it's not getting invoked at all. Use the event trigger monitor tab in the AI to see if the triggers you expect to be sent are in fact being sent. That should narrow the issue down one way or another.


RE: Triggered Event only works every second time - znelbok - 10-27-2020

I enabled logging and that stopped the issue - go figure!

I have been battling internet issues lately so I have not had any time to devote to troubleshooting this but it appears to be OK at the moment.