Charmed Quark Systems, Ltd. - Support Forums and Community
Elk Version Support Issue - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: CQC Support (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=9)
+--- Thread: Elk Version Support Issue (/showthread.php?tid=11105)

Pages: 1 2 3


Elk Version Support Issue - Ron Haley - 04-26-2020

Dean,
Remember a while back we had the issue of the Elk driver not updating the Counter fields.  You were only doing it if the Elk software version was beyond a specific number.  You fixed that by supporting versions further back.  Well, you didn't carry that patch over to 5.4, so I'm having the issue again.
Ron


RE: Elk Version Support Issue - Dean Roddey - 04-27-2020

Hmmm... OK, I'll check that. I don't think I would have removed it, but anything is possible.


RE: Elk Version Support Issue - Ron Haley - 04-27-2020

You sent me a working driver version 6/19/2019. Not sure you incorporated the changes into the official driver Smile Thread was "Elk Counter Update".


RE: Elk Version Support Issue - Dean Roddey - 04-29-2020

What version did we go back to in the other version?


RE: Elk Version Support Issue - Ron Haley - 04-29-2020

Something prior to 5.2.10


RE: Elk Version Support Issue - Dean Roddey - 04-29-2020

It looks like it's currently checking for either 5.3 or beyond, or a version of 4.x that is 4.1.11 or beyond. What version are you running currently? If it supports counters, then presumably we can take either the 5.x or 4.x version downwards to that.


RE: Elk Version Support Issue - Ron Haley - 04-29-2020

I'm running 5.2.10. So setting a lower limit of 5.2 would work.


RE: Elk Version Support Issue - Ron Haley - 04-30-2020

Any luck yet?


RE: Elk Version Support Issue - Dean Roddey - 04-30-2020

The lower limit is already 5.2.0. So presumably I still do have that fix in place. Are you sure you are loading the shipped one? Right click on it in the browser tree and look the driver info and let's see what it says. Make sure it's pointing into the system are for the server side CML path.


RE: Elk Version Support Issue - Ron Haley - 04-30-2020

Any way to attach a jpg here?