Charmed Quark Systems, Ltd. - Support Forums and Community
5.5 Beta Discussions Thread - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: Beta Discussions (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=12)
+--- Thread: 5.5 Beta Discussions Thread (/showthread.php?tid=10858)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30


RE: 5.5 Beta Discussions Thread - Dean Roddey - 03-18-2021

(03-05-2021, 09:39 PM)kblagron Wrote: One other thing that I just noticed on 917 -> Whenever I pull up a help file from the AI, I get a message that the server connection is not private.  It is trying to access my server named "CQCServer" with a non-standard secure port that I used at installation as a secure connection.  I have only been using that non standard secure port for outside access to my system, not when it is local.

Was this a change from before?  I was assuming that help was accessed on the server from a non-secure connection before since it was local.  Maybe I missed it in the documentation, or somehow my setup has changed.

I did recently have to change my outside WebRIVA security certificate since it had expired, but that was pretty straightforward of just importing a new certificate onto the CQC server, so I don't think that would of caused a change.

I've about got this worked out. You can now select which port to use. Of course if you don't want to use an insecure port at all, and you want to use the secure one for external access, you'll have to come up with some compromise, like installing the web server on a second machine to use for the secure external access, and use an internal, self-signed certificate for local help access.


RE: 5.5 Beta Discussions Thread - George M - 03-22-2021

Problem with 920.
When I updated my MS to windows10, the usb to serial hub was not supported. I replaced it but now trying to set up the driver to use it I am not getting the option to change the settings on any of the serial ports. The "Settings" button is greyed out. And of course the baud rate on the three devices I have are not 9600.


RE: 5.5 Beta Discussions Thread - kblagron - 03-22-2021

(03-22-2021, 05:36 AM)George M Wrote: Problem with 920.
When I updated my MS to windows10, the usb to serial hub was not supported. I replaced it but now trying to set up the driver to use it I am not getting the option to change the settings on any of the serial ports. The "Settings" button is greyed out. And of course the baud rate on the three devices I have are not 9600.

Which drivers?


RE: 5.5 Beta Discussions Thread - George M - 03-22-2021

(03-22-2021, 11:26 AM)kblagron Wrote:
(03-22-2021, 05:36 AM)George M Wrote: Problem with 920.
When I updated my MS to windows10, the usb to serial hub was not supported. I replaced it but now trying to set up the driver to use it I am not getting the option to change the settings on any of the serial ports. The "Settings" button is greyed out. And of course the baud rate on the three devices I have are not 9600.

Which drivers?

Nuvo Concerto
Monoprice MZ6
W80RF


RE: 5.5 Beta Discussions Thread - kblagron - 03-22-2021

I looked at one of my drivers (Samsung) since I don't have any of those drivers, and I do have the option to change the baud rate as it is non-standard, so nothing has changed on that one for me.  I then went through the process of adding both the Nuvo and the MonoPrice driver, and both of mine were greyed out (I didn't have the W80RF on my system, so it must not be a shipped driver).

As I recall, it is a configuration setting within the manifest, but will have to let Dean respond to this one.


RE: 5.5 Beta Discussions Thread - George M - 03-23-2021

Thank you for checking it out.


RE: 5.5 Beta Discussions Thread - George M - 03-23-2021

I just looked at the manifests for these drivers. They are not supposed to be editable. I just need to make sure I have my ports set up to the correct settings they require.


RE: 5.5 Beta Discussions Thread - kblagron - 03-23-2021

(03-23-2021, 06:47 AM)George M Wrote: I just looked at the manifests for these drivers. They are not supposed to be editable. I just need to make sure I have my ports set up to the correct settings they require.

Since they are shipped drivers, you would have to copy those files to a folder where you can edit them (i.e. desktop), edit them, then copy to the User folder.  You would also need to change either the Make or Model as that is the index key for each driver. 

I am not sure whether you could just edit the manifest file on a system driver and still have it pointed  to the System CML Macro Driver folder file, but it might work.

In my Samsung Driver manifest, the section below shows where it is editable:

<CQCCfg:ConnCfg CQCCfg:Editable="True">
        <CQCCfg:SerialConn 
    CQCCfg:Baud="Baud_19200"
                            CQCCfg:Bits="Bits8"
                            CQCCfgTonguearity="None"
                            CQCCfg:StopBits="One"
                            CQCCfgTonguearityCheck="No"/>
    </CQCCfg:ConnCfg>

Since that last driver on your list (W80RF) is not a shipped driver, you could try that one, as it should already be in the User folder.  Just copy it to a folder that is editable, change the "Editable" to True, and you can either leave the configuration the same and edit it when you install the driver, or put those parameters below to default to that.  Once you do that, copy it back to where it came.

Make sure you have a backup of those files before proceeding, and you will have to restart the CQC service as well after you make the change.

This is probably not the official way to do this, but pretty sure it would work.


RE: 5.5 Beta Discussions Thread - George M - 03-24-2021

Not sure it would work to just change the False to True. Don't think the driver would be set up to accept any changes. But since I am not a coder I'm just speculating.
I will just check each manifest to see what is expected and then set up my ports to match.
Thanks for helping with this though.


RE: 5.5 Beta Discussions Thread - Dean Roddey - 03-24-2021

Best to just adjust your settings to match the driver.