Charmed Quark Systems, Ltd. - Support Forums and Community
5.5 Beta Discussions Thread - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: Beta Discussions (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=12)
+--- Thread: 5.5 Beta Discussions Thread (/showthread.php?tid=10858)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30


RE: 5.5 Beta Discussions Thread - Dean Roddey - 12-16-2020

(12-15-2020, 04:59 PM)xlurkr Wrote: Dean:

Are you going to open source the C++ drivers too?  I'm invested in several hardware platforms with native drivers, and I'm especially concerned about the ISY, as it's a moving target and will need updating in the future.  Thanks.

-Tom

The drivers will be part of the source code, definitely. But the Insteon ISY driver is a CML driver. So it's already available to everyone.


RE: 5.5 Beta Discussions Thread - bryanb - 12-16-2020

Yes, as far as I can tell. Is Mark using my homegrown WebCam extension? My extension had always working prior to 917. I had upgraded to 917 and ran for awhile but not trying my cameras template. So when I tried my cameras template and saw the the problem, I went back to (the only thing that was really different was upgrading to 917) 914 and the problem went away. So I upgraded again, to make sure it was 917 related, and the problem came back. I went back to 914 and the problem was gone. Extension worked fine. So it really seems to me to be caused by the upgrade to 917.


RE: 5.5 Beta Discussions Thread - Dean Roddey - 12-18-2020

What Mark saw was the overall size of the templates changed. Are you saying that your overall template size is correct but only the extension bit changed size?


RE: 5.5 Beta Discussions Thread - bryanb - 12-18-2020

I haven't noticed any size differences in any of my templates. The difference between 914 and 917 is that my custom extension is the wrong size and in the wrong place. When I was debugging it awhile back, issues like this was related to getting the parameters correctly. That's why I think the current difference is in the parameter passing in 917 versus 914. Something is clearly different. Did 917 handle the WebRIVA extensions differently in any way? Did it change anything in the folder that holds the custom stuff that's not supposed to be overwritten.


RE: 5.5 Beta Discussions Thread - Dean Roddey - 12-21-2020

I wrote a little program yesterday to update the copyright statement in all of the C++ files to the new open source one (it'll be MIT license as the CIDLib one is.) And I got a reasonable first draft of the reposiitory readme file done. I need to strip out any of the stuff no longer needed next. Then there's not really anything preventing me from posting the code I guess.


RE: 5.5 Beta Discussions Thread - kblagron - 12-21-2020

I updated to .917 tonight, and everything appears to come up fine - drivers, templates. webserver access, so will monitor and let you know if I see anything out of the ordinary.

One thing that confused me a bit was the request during install on a client machine for the Secure Certificate Support.  I ended up not enabling this, and was still was able to access the Web Server via templates.  I did include that info on the Master Server.  I am guessing it is not necessary on the client machines, but would like clarification.


RE: 5.5 Beta Discussions Thread - sic0048 - 12-22-2020

Dean, I haven't tried any of the recent betas yet, but it sounds like things are pretty stable now. I'll try to upgrade my system to the latest beta over the holidays (I'm taking some time off from work). You might find that others are in a similar situation and may be more willing to test out the beta over the next couple of weeks. Hopefully you can get some more feedback during that time.


RE: 5.5 Beta Discussions Thread - Bugman - 12-22-2020

Dean: I went from 5.4.0 to 915, back to 5.40. and now to latest 917.

I installed on the Master Server ok, but tried a client and while it contacted the server it failed at the end with a "The Master Server connection validation failed"

Any idea? I used the IP address of the MS in the setup steps perhaps the computer name?


RE: 5.5 Beta Discussions Thread - Dean Roddey - 12-22-2020

(12-21-2020, 10:35 PM)kblagron Wrote: I updated to .917 tonight, and everything appears to come up fine - drivers, templates. webserver access, so will monitor and let you know if I see anything out of the ordinary.

One thing that confused me a bit was the request during install on a client machine for the Secure Certificate Support.  I ended up not enabling this, and was still was able to access the Web Server via templates.  I did include that info on the Master Server.  I am guessing it is not necessary on the client machines, but would like clarification.

That should only be needed where you are installing the web server or XML GW server. If you weren't and still saw it, that's something that needs to be looked at. It may be temporary in that I'm forcing it visible just for the upgrade, since it's no longer part of the web server stuff. So probably that's it. I should it visible if you are actually installing something that needs it. Next time it probably wouldn't show up since it won't need to be forced anymore.


RE: 5.5 Beta Discussions Thread - Dean Roddey - 12-22-2020

(12-22-2020, 11:06 AM)Bugman Wrote: Dean: I went from 5.4.0 to 915, back to 5.40. and now to latest 917.

I installed on the Master Server ok, but tried a client and while it contacted the server it failed at the end with a "The Master Server connection validation failed"

Any idea? I used the IP address of the MS in the setup steps perhaps the computer name?

The name of the MS is always best to use.