Charmed Quark Systems, Ltd. - Support Forums and Community
WebRIVA password special character issue? - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: CQC Support (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=9)
+--- Thread: WebRIVA password special character issue? (/showthread.php?tid=10688)

Pages: 1 2


WebRIVA password special character issue? - batwater - 09-30-2018

Hi Dean,

I am finding that WebRIVA is rejecting the special character ! (after further testing - any special character) in the password and just eating it.  Is this a bug, deliberate or what?  Documentation says nothing of the format of the password.  Special characters work for regular RIVA clients (like taRIVA)

I am guessing that the Admin Interface is the culprit here.

Special characters used to work, but at some point they stopped.  I finally just got around to debugging why I couldn't connect.  

-Ben


RE: WebRIVA password special character issue? - Dean Roddey - 09-30-2018

The password becomes part of a URL when you use WebRIVA. So any character that would cause problems in the URL will get get URL encoded. Maybe the web server isn't decoding the parameters properly or something, and just using the literal text with encoded characters. I'll have to look at that.


RE: WebRIVA password special character issue? - Dean Roddey - 09-30-2018

OK, yeh, special characters show encoded, so I need to decode them. It may or may not be done, depending on the browser. But if I explicitly encode the URL, it shows up encoded, so any browser that did encode that character in query params would have an issue. I'll fix that for the next drop.


RE: WebRIVA password special character issue? - batwater - 09-30-2018

Thanks Dean!


RE: WebRIVA password special character issue? - batwater - 09-30-2018

(09-30-2018, 12:24 PM)Dean Roddey Wrote: OK, yeh, special characters show encoded, so I need to decode them. It may or may not be done, depending on the browser. But if I explicitly encode the URL, it shows up encoded, so any browser that did encode that character in query params would have an issue. I'll fix that for the next drop.

One question though, if I remove the special character from the string passed to WebRIVA it authenticates without error, did you also check this? The password in the Admin Interface for the web browser contains the special character. Just making sure that there is not more than one issue, it was puzzling that it would work without the character.


RE: WebRIVA password special character issue? - Dean Roddey - 09-30-2018

That doesn't work for me. Can you reproduce that? If so, maybe send me a sample password string that works that way for you, so that I can try it. Was it in some special position, maybe the first or last character or something?


RE: WebRIVA password special character issue? - batwater - 09-30-2018

Try OneGr8PlateOfThis! Also tried the ! in middle position etc and it validates just fine with ! in Admin Interface Web Browser password field. Also have tried $


RE: WebRIVA password special character issue? - Dean Roddey - 09-30-2018

If I remove the ! it doesn't connect for me. You sure the browser URL recall or something isn't actually getting you the version with the character? Ultimately there's no way it will work unless the right password makes it to the server side. So it has to be something going on on the browser side to get you back to the version with the character.


RE: WebRIVA password special character issue? - batwater - 09-30-2018

Hmmm... I think what is happening is that the stored account password is OneGr8PlateOfThis but I'm changing the Web Password through the text field and saving and not through the "reset PW" button.

If I have OneGr8PlateOfThis! in the web field it won't work, but if I delete, it will.

So let's start over, what is the difference between the text field for the Web Password and the reset PW button? I am interpreting that there are 2 stored passwords, LAN and Web. If that is the case what is the authentication process internally?


RE: WebRIVA password special character issue? - Dean Roddey - 09-30-2018

The web password is only used if you are accessing the web server as a web server, not for WebRIVA. So if you write your own CML handler, then the Web Password is used, because you can't really do a standard CQC login in that case. You can ask for the web password in your handler and verify it against what you got.

WebRIVA can do a regular login, so it uses your regular account password.