Charmed Quark Systems, Ltd. - Support Forums and Community
C-Bus driver loading error - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: CQC Support (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=9)
+--- Thread: C-Bus driver loading error (/showthread.php?tid=10317)



C-Bus driver loading error - znelbok - 06-15-2017

I had to do a reboot last night and now my C-bus driver wont connect.

06/16 06:45:42-Zeus01, CQCServer, CQCDrv_lightingThread22
{
    CQCKit, CQCDriver_DriverBase.cpp.3298, Status/App Status
    Driver 'lighting' is beginning initialization
}
06/16 06:45:42-Zeus01, CQCServer, CQCDrv_lightingThread22
{
    CQCKit, MEng.System.CQC.Runtime.CQCLogger.226, Status/App Status
    C-Bus Driver starting
}
06/16 06:45:42-Zeus01, CQCServer, CQCDrv_lightingThread22
{
    CIDMacroEng, CIDMacroEng_Engine.cpp.1808, Status/App Status
    Exception 'StringErrors.BadIndex' was thrown from line 2027
    MEng.String
}
06/16 06:45:42-Zeus01, CQCServer, CQCDrv_lightingThread22
{
    CQCKit, CQCDriver_DriverBase.cpp.3371, Status/App Status
    Driver lighting returned failure status on initialization
}


What does the StringErrors.BadIndex mean?

It just keeps repeating itsel.  Obviously the driver has not been changed - it an encrypted driver.


RE: C-Bus driver loading error - Dean Roddey - 06-15-2017

It means that the driver is creating a string, then accessing a character beyond the end of the string. I would guess the most likely scenario is that the driver is loading some configuration file? That would be a common scenario that would involve a lot of string manipulation on startup of a driver. Maybe you changed that file since the last time you started the driver? If so, maybe check it carefully that it's still correct.


RE: C-Bus driver loading error - znelbok - 06-15-2017

File has not been changed, but I will double check it anyway - strange things do happen around here.


RE: C-Bus driver loading error - Dean Roddey - 06-15-2017

You could always, as a test, replace it with a very simple, dummy one and see if that works. If so, then you could start moving over chunks until the problem comes back, to get a better idea of where it might be. If it still fails to load with a very simple dummy file, then probably it's not the file and we can look elsewhere.


RE: C-Bus driver loading error - znelbok - 06-16-2017

Turns out it was one of the config files. N0t sure what was wrong but I cleaned up a few lines for fields that no longer exist and it loaded up eventually.