Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 1,806
» Latest member: beltmoon8
» Forum threads: 11,172
» Forum posts: 78,644

Full Statistics

Online Users
There are currently 69 online users.
» 0 Member(s) | 67 Guest(s)
Bing, Google

Latest Threads
Apple buys Dark Sky...
Forum: General Automation
Last Post: kblagron
06-14-2022, 09:25 PM
» Replies: 5
» Views: 2,535
Event Server Error
Forum: CQC Support
Last Post: Bugman
06-05-2022, 08:54 AM
» Replies: 4
» Views: 128
RainMachine Sprinkler Irr...
Forum: Driver Development
Last Post: kblagron
06-03-2022, 11:27 PM
» Replies: 58
» Views: 17,547
Help with RIVACmd
Forum: CQC Support
Last Post: kblagron
05-23-2022, 08:54 PM
» Replies: 2
» Views: 168
6.x Beta Release Discussi...
Forum: Beta Discussions
Last Post: Shaky
05-09-2022, 08:25 PM
» Replies: 26
» Views: 3,397
An Idea - CQC as Front En...
Forum: CQC Support
Last Post: kblagron
04-28-2022, 07:58 PM
» Replies: 3
» Views: 235
Admin Interface Help Does...
Forum: CQC Support
Last Post: Dean Roddey
04-28-2022, 01:14 PM
» Replies: 1
» Views: 155
Recurring Errors - Help t...
Forum: CQC Support
Last Post: Bugman
04-02-2022, 07:52 AM
» Replies: 1
» Views: 212
MQTT Verify Configuration...
Forum: CQC Support
Last Post: Dean Roddey
03-17-2022, 01:07 PM
» Replies: 4
» Views: 348
Trigger not Working after...
Forum: CQC Support
Last Post: sic0048
03-02-2022, 05:35 AM
» Replies: 4
» Views: 367

 
  Error writing value to field
Posted by: Spot - 05-26-2021, 05:04 PM - Forum: Installation/Configuration - Replies (6)

This is my first trigger attempting to set a value of a field to a value from another field & I get the error "Cannot convert the passed value to a form legal for field <target field>."

I am attempting to take the value from OpenWeather ( WEATH#curTemp [Type: MEng.Int4]) and write it to the outside temp of my RCS serial thermostats (Main_OutsideTempStat [type: MEng.INT4]).


I am able to type a value in the driver directly & have it write to the thermostat correctly, but I cannot get the action of the trigger to work.  I'm really new to CQC, but is there some form of typecasting that I need to do?

Thanks

Print this item

Video How to Upgrade from 5.X.X to 6.0.X
Posted by: sic0048 - 05-24-2021, 01:50 PM - Forum: Beta Discussions - Replies (8)

Since there isn't really a good walk-though on this yet, I thought I would post my experience.

I've avoided upgrading to the latest "open source" version because I simply didn't need to upgrade and I thought the process was going to be complicated.  But then I had an issue with my parents system and I had to replace their computer and restore their CQC system from a backup (one that was generated during a previous upgrade).  I thought it would be a good time to upgrade because I was going to have to bother Dean for a new license since the install was on a new computer.  EDIT - Let me clarify..... I had restored their system on the new computer to version 5.2.9 and it was in good working order (but I did not activate a license for that version. I was operating under the "trial" time frame). You need to be on a working CQC version (ie not in an uninstalled status) for the upgrade process to work.

First, I started out on version 5.2.9.  If you are on an earlier version and try to install a version like 5.3.2, the installer might tell you to install some other intermediate version. If this happens, install the version that is mentioned and then continue on. The installation system is really good about walking you through the required versions and won't let you skip any required versions. In other words, if the process requires you to install a particular version as a stepping stone before continuing on, the system will tell you which version needs to be installed.

From 5.2.9 I was forced to upgrade to 5.3.2 (https://www.charmedquark.com/Web2/Downlo..._5_3_2.exe) as one of these "stepping stone" versions. If you are on a version that is lower than 5.3.2, you will have to upgrade to 5.3.2 before continuing on. If you are already on a version 5.3.2 or later you can simply go to the next step.

From version 5.3.2 or later, you have to upgrade to 5.4.914 (https://www.charmedquark.com/Web2/Downlo..._4_914.exe)
From version 5.4.914 (or later) you have to upgrade to 5.4.917 (http://www.charmedquark.com/web2/Downloa..._4_917.exe)

Once I was on 5.4.917, I was able to go directly to the latest version which at the time I did the installation was 6.0.2 (https://www.charmedquark.com/Web2/Downlo..._6_0_2.exe)

The process ended up being much simpler than I had expected.  All the updates went though without any issues (and I didn't even reboot between updates).  It must be working properly, because when I start any of the CQC apps, it does not prompt me for a license!

Anyway, I hope this can help some people upgrade without too much trouble.

Print this item

  Old Version pushing CPU usage to 100%
Posted by: sic0048 - 05-19-2021, 06:03 AM - Forum: CQC Support - Replies (7)

I run a CQC system at my house as well as my parent's house.  My parent's computer went down a few months ago and because of COVID, I am just getting around to trying to replace it.  They have been running an older version of CQC (4.3.X I think).  It was running on an old 32bit machine.  

I have a copy of their CQC program folder that I moved to the new system.  When I "install" that version on the new 64bit machine, it seems to install correctly (no errors, etc), but it forces the i7 6700 CPU chip to run at 100% all the time.  There are 4-5 different CQC processes running in the background that combined go to 100%.  This behavior stays the same even after a reboot.  I can stop the CQC service and force close those processes and the CPU goes back to normal, but obviously I can't use CQC then.

I realize this is a pretty open ended question, but is there any places I should look to try to get this working normally?  I tried to search the forum to see if anyone else had a similar experience, but I wasn't able to find anything similar.

PS - I am installing the old version from a old zip download that I also had on the computer. It is the zip file that I would have initially used to install CQC on the old machine, but I guess I could always try to download it again to make sure there isn't anything corrupted.

Print this item

  UPgrading an old CQC
Posted by: znelbok - 05-15-2021, 03:49 AM - Forum: CQC Support - Replies (4)

I need to upgrade an old 3.3.23 version of CQC to the latest.

Owner was a tight arse and never wanted to pay for upgrades and now they have lost access to the system via the old iOS app (iOS update stopped the app from working).

So what are the steps I will need to follow - what versions will I have to step through to get it all up to date.

Mick

Print this item

  setting up CQC
Posted by: tom - 05-09-2021, 10:42 AM - Forum: CQC Support - Replies (12)

05/09 14:33:35-Officecomputer, CQCAdmin, MainThread
{
    CIDOrbUC, CIDOrbUC_ThisFacility.cpp.742, Failed/Not Found, Error: 6003/0/0
    Could not contact the CIDLib Name Server (at CQCserver:13502)
    The server at {{DA7622D8FE9D1744-8BBD12DB0DD8ABF3}C7D1445942EA2EAA-0EE3FF7875548D09,TCIDNameSrvClientProxy,CQCserver.13502} was not available
      <CQCAdmin> CQCAdmin_ThisFacility.cpp - 284
cant find the master server, not sure why its up and running

}Any help would be geat


Thanks Tom

Print this item

  Amazon Echo integration
Posted by: rhosch - 04-25-2021, 06:03 PM - Forum: CQC Support - Replies (8)

Is this still a thing? I was going to try and set up the original (non native) echo integration and see if I could do something simple, like have CQC send a text to voice announcement via Alexa. I was following the Dean's guide in advanced topics documentation, but hit a roadblock when trying to download the code needed to set up the needed Lamba function.

Are the files mentioned at being at this link still available?

http://www.charmedquark.com/Web2/Downloa...QCEcho.Zip

That link doesn't do anything for me. Has Amazon changed something that tanked this integration?

Print this item

  ISY and scenes
Posted by: George M - 04-06-2021, 01:04 PM - Forum: CQC Support - Replies (55)

I just added some scenes to my ISY setup. I was expecting to see them come up in CQC but they didn't.
Can QCQ control scenes in ISY?

Print this item

  6.X Discussions Thread
Posted by: gReatAutomation - 04-01-2021, 09:27 AM - Forum: Beta Discussions - Replies (1)

Posted..........

Print this item

  6.x Beta Release Discussions Thread
Posted by: gReatAutomation - 03-29-2021, 04:49 AM - Forum: Beta Discussions - Replies (26)

The release URL provided is throwing an error.

Download Link: https://www.charmedquark.com/Web2/Downlo..._6_0_1.exe


[Image: Screen-Shot-2021-03-29-at-08-47-24.jpg]

Print this item

  Official 6.x Beta Release Thread
Posted by: Dean Roddey - 03-28-2021, 11:16 AM - Forum: Beta Discussions - Replies (2)

This thread is not for discussion, so please don't post here. It is for official 6.x beta release information. There is a separate sticky thread for discussion.

6.x is now open source. To get to the 6.x version you may have to make a couple intermediate steps. If you are pre-5.9.14 you'll have to go to that first. Then you have to go to 5.4.917. After that you can move forward to 6.x. The intermediate steps are necessary to remove the licensing stuff and then move data around and implement some new security stuff.

On the latter topic, the installer will now show a new page when you install which tells you about thew new security concerns. Don't ignore it.

-------------------

Latest Version: 6.0.1
Confidence Level: 95

Download Link: https://www.charmedquark.com/Web2/Downlo..._6_0_1.exe

The subsequent posts list changes in each beta version...

Print this item