Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: New Amazon Echo Support
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Yes.

I looked at the Log Server Monitor, and it was showing the incoming key that I changed. And I did tell Alexa to "Tell Control to run Load Echo Configuration".

The reason I know it had read the new file was because when I changed it back, some new additions to the config file did as I wanted.
I uploaded to the latest 4.7.8 version and reconfigured the echocfg.txt file as follows:

Code:
QueryMap
    Action=\User\Echo\Query
        Test
        Current Temperature
        Prettiest
        Finest
    EndAction
EndQueryMap

On each try, Alexa says "Sorry I am having trouble accessing your CQC skill right now"

The log monitor shows now that it reloaded the configuration file, but none of the attempts to run Test or Current Temperature is working.

It was working fine on 4.7.5.
That's not your whole file is it? You still have to have all of the same stuff as before, i.e. the main block and all of the three map blocks. And I assume you actually have that indicated global action?
Here is the entire file. I only have actions built for the queries, would that cause a problem if the global action is not there for the set and run? I didn't have them for Ver 4.7.5 either.

PHP Code:
EchoConfig
    MyKey
=ABCDEF
EndEchoConfig

RunMap
    Action
=\User\Echo\Sprinklers
        Sprinklers
                  Lawn Sprinklers
    EndAction
EndRunMap

SetMap
    Action
=\User\Echo\Set
            Volume
Music Volume
                    Scene
            Channel
TV Channel
                    Disco Mode
    EndAction

    Action
=\User\Query\SecureModes
                     NightTime Mode
Night Time Mode
                     LockDown Mode
Lock Down Mode
                     Day Mode
        EndAction
EndSetMap

QueryMap
    Action
=\User\Echo\Query
        Test
        Current Temperature
     EndAction
EndQueryMap 
Just updated to latest Echo (4.7.8) without issue...Everything works as before so likely something wrong with the config or global action call?
I think I figured out the problem, but won't be able to test it until I get home tonight. I didn't update the javascript file that Dean had posted with the new version, so if that had changed with the new update, then it might of been throwing the error.
kblagron Wrote:I think I figured out the problem, but won't be able to test it until I get home tonight. I didn't update the javascript file that Dean had posted with the new version, so if that had changed with the new update, then it might of been throwing the error.

Dean updated the Javascript during the .7 series drop. I updated all of it, just to make sure I didn't miss anything.
kblagron Wrote:Here is the entire file. I only have actions built for the queries, would that cause a problem if the global action is not there for the set and run? I didn't have them for Ver 4.7.5 either.

The other map blocks can be empty if you aren't using them, though as long as you don't actually invoke the unused ones, it shouldn't cause a problem.

If you went from 4.7.5, to 4.7.8, then you do need to update the javascript definitely, as well as the utterances and intent schema.
I reloaded the javascript, the intent schema, and the utterances, and still getting the same message - "Sorry I am having trouble accessing your CQC skill right now"

Here is my Global Action Query:
PHP Code:
System::LogMsg
    P1
=Test  Gact
    P2
=0
    P3
=Intent: %(LVar:CQCActParm_1), Key: %(LVar:CQCActParm_2), Parms: %(LVar:CQCActParm_3)
    
P4=Status

GlobalVars
::SetVariable
    P1
=GVar:EchoReply
    P2
=This is a TestRepeatThis is a Test 

Here is my simplified echocfg.txt file
Code:
EchoConfig
    MyKey=ABCDEF
EndEchoConfig

RunMap
EndRunMap

SetMap
EndSetMap

QueryMap
    Action=\User\Echo\Query
        Test
    EndAction
EndQueryMap

When I reload the configuration file, it shows up in the log monitor, but nothing shows up when I try to execute the simple test above. Any ideas where to look?
I placed some of the global actions into the RunMap section, and got it to work, but I have been unable to get anything to work in the QueryMap section. The Query section was working for me on V 4.7.5, but I can't seem to get it to work now.