Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Kiosk Error: "No CQC System ID was set"
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm trying to get an Interface Viewer working in Kiosk mode on a Windows 8.1 tablet. I had everything working (limited CQC user account, system environmentals, etc), but then I had to restore the operating system for other reasons. Now I get "Could not load environmental info. Reason=No CQC System id was set."

The IV is not on the same machine as the server, and the only components loaded on it are the Administrative Interface, the CQC command prompt, and the IV. I can login remotely using the AI so I know the connection is good, but I can't get it running in Kiosk mode because of the error above.

Any thoughts?
Well, I think I solved it.

I added the System Id to both the user login environment and to the command line parameters but then I got a "waiting on CQC," so I added the master server "/NSAddr=IPaddress" to the command line shortcut as well.

I think that did the trick...though I'm a bit puzzled since I did not seem to need it before.... I suspect I don't need the SystemID in either place if the IV can find the server.
The generated start menu item for the IV has both of those on it, and maybe another one or two. If they weren't there, then something was wrong with the restored version.

Yeah, the start menu tile or app (not sure of the windows 8 nomenclature) worked but I was playing around with a desktop shortcut as I tried things out and I didn't initially realize I needed it. All is now good.