Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Anyone using the Tray Monitor on XP?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Someone was complaining that the app control bit of the Tray Monitor doesn't seem to be working, and in this case it's on XP. I don't have an XP system to test on, so I was wondering if anyone is using the TM on XP to do app control without any problems?
Dean Roddey Wrote:Someone was complaining that the app control bit of the Tray Monitor doesn't seem to be working, and in this case it's on XP. I don't have an XP system to test on, so I was wondering if anyone is using the TM on XP to do app control without any problems?

One of my touchscreen hosts is still running XP and the Tray app is running just fine. I use the control app portion to turn the screen off at late night then back on in the morning.
Could you try, just as a quick experiment, setting up a keymapped action or something simple like that, and using it to send a RemExecApp command, running the little Windows shutdown.exe program, to see if that works?
Sure - I will set it up and let you know in a bit.
Well the words "sure I will help" sent me down a rabbit hole of reloading, checking , testing and now concluding that whoever reported the issue is correct; The Tray app is broken on XP. It loads, but nothing will connect to it and no errors are thrown.

I am simply trying to connect the CQC Interface Viewer driver and it now will not connect. I am running .906
Is there a firewall exception showing up for it? Maybe it's just blocked by the firewall?

I'm not sure what you are meaning about the IV driver?
Firewall is off and there are no exceptions.

The driver is the interface viewer driver, but that worked after a reboot and is unrelated, although sometimes the machine must be rebooted in order for it to work.

After the reboot, I also can now call and run a remote app on the XP machine from the server machine.

System::StartRemApp(TouchScreen1, shutdown.exe, /i, C:\\)

This works just fine on the remote machine.
I discovered some issues with the TM for this command, that it wasn't pushing it's (hidden) launcher window forward to be the front window, which could cause the attempt to launch a program to fail sometimes.

But, other than that, is anyone having any issues with this guy on XP, particluarly with auto-start? Is the auto-start task showing up in the Windows task manager, and also particularly in the later .906 betas?
I would agree that it did not place the window on top. I also had to manually add the shortcut to the startup task bucket. It was not added automatically.
It doesn't use the Startup folder anymore, it uses the task manager. If you add it to the startup folder, that will probably run first and may prevent the other one from starting. Do you see a task for the TM in the Windows task scheduler?
Pages: 1 2