Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Denon driver error with 3.0
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I just upgraded to the latest beta 3.0 from 2.4.x and am getting the following error when trying to execute or edit a fieldwrite command for my denon receiver:

'2309CI.SrcInput' is not a valid field name. It must be in the form 'moniker.fldname'

"2309CI.SrcInput" was selected right from the list so not sure why it is saying it is not in the right form. I am using a modified version of the driver that worked fine in v2.x (the only change i made is removing the reference to Zone3 since the driver is for the 2808 and my 2309 only has 2 zones) - is there something with 3.0 that would break the old drivers or is something else going on?

Thanks!
dman000000 Wrote:I just upgraded to the latest beta 3.0 from 2.4.x and am getting the following error when trying to execute or edit a fieldwrite command for my denon receiver:

'2309CI.SrcInput' is not a valid field name. It must be in the form 'moniker.fldname'

"2309CI.SrcInput" was selected right from the list so not sure why it is saying it is not in the right form. I am using a modified version of the driver that worked fine in v2.x (the only change i made is removing the reference to Zone3 since the driver is for the 2808 and my 2309 only has 2 zones) - is there something with 3.0 that would break the old drivers or is something else going on?

Thanks!

I'm reasonably sure that has been corrected as of 3.0.14. See this post in the official beta thread for more details. I believe the rule is fields can start with a numeric character but driver monikers cannot. Of course someone can correct me if I'm wrong.
Thanks for the reply. I actually just installed the latest beta so i guess it is not fixed yet...but now that i know what the issue is i can always just change the device name.
Yeah, think there is a problem. I have a 2808CI that the driver was designed for and that field doesn't seem to work. At first that field was red then it turned black and TV showed up, which was correct, but the field couldn't be changed. I'm running cqc 3.0.16
Dman00000

Could I get a copy of your denon driver? I have 2308ci and i tried to modify one of the other denon drivers but I couldn't get it to work. You seemed to have better success than I did. I really want to be able to incorporate my denon into the system.

Thanks
Update: I changed the name of the driver to start with an alpha character and all seems to be good now...
so what did you end up naming it to get it to work?
I reinstalled the stock driver, and that field is still not working for me. The rest of the driver seems to be working.
I uninstalled the driver and reinstalled it with the moniker "AVR2309CI".

I am on 3.0.17 in case that matters...
And the SrcInput field fully works?