Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: HTML help, please...
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
The following is the HTML is get when I look at an Escient FP1's web GUI. I want to display the GUI in a smaller screen on a Samsung Q1. Before I waste too much time with this, am I correct that I would put in the width and height that I desire where zero's are currently listed, save it in Notepad, place that in my HTML root file and then point the interface to HASERVER/HTMLROOT/NewFile?

<html>
<head id='head'>
<script type='text/javascript' src='js/debug.js'></script>
<script type='text/javascript' src='js/class.js'></script>
<script type='text/javascript' src='js/callback.js'></script>
<script type='text/javascript' src='js/data_loader.js'></script>
<script type='text/javascript' src='js/data_queue.js'></script>
<script type='text/javascript' src='js/data_cache.js'></script>
<script type='text/javascript' src='js/event_map.js'></script>
<script type='text/javascript' src='js/global_event_handlers.js'></script>
<script type='text/javascript' src='js/state.js'></script>
<script type='text/javascript' src='js/index.js'></script>
<script type='text/javascript' src='js/index_item.js'></script>
<script type='text/javascript' src='js/album.js'></script>
<script type='text/javascript' src='js/radio.js'></script>
<script type='text/javascript' src='js/movie.js'></script>
<script type='text/javascript' src='js/setup_utilities_volumecontrol_rooms.js'></script>
<script type='text/javascript' src='js/uievents.js'></script>
<script type='text/javascript' src='js/top.js'></script>
<script type="text/javascript">
function handleResponse() {
alert('this function is called from server.html')
}
</script>
<link rel="stylesheet" href="stylesheets/common.php"
type="text/css"></link>
</head>
<body onload="init();" onunload="cleanup();"
id="body" bgcolor="000000" text="#FFFFFF" topmargin="0"
leftmargin="0"
style="background-color:BLACK;background-repeat: no-repeat; overflow:hidden;">
<iframe id='hidden' name='hidden' frameborder=0 width='0' height='0'></iframe>
<div id="main_area" >
</div>
</body>
</html>
If you are wanting to do an indirect reference via your own HTML, then you'd access it through our web server. So you'd put it somewhere under the HTMLRoot directory, on a machine where the web server is running.

You'd then access it as "http://hostname/whatever.html", where hostname is the name of that machine where the web server is running, and whatever.html is the name of the file.
Umm, I have saved the the Notepad file (.txt) in the HTMLRoot but, if I try to access it in IE with .html appended to the address, I get an error (Windows cannot find blah blah blah). If I append with .txt, it opens fine. How do I save a .txt as HTML if it isn't a file type option when doing the Save As?
AnthonyZ Wrote:Umm, I have saved the the Notepad file (.txt) in the HTMLRoot but, if I try to access it in IE with .html appended to the address, I get an error (Windows cannot find blah blah blah). If I append with .txt, it opens fine. How do I save a .txt as HTML if it isn't a file type option when doing the Save As?

Go into My Computer, Tools, Folder Options, View tab and uncheck 'Hide extensions for known file types'.

You should now be able to rename the file so it has a .html extension directly in the Explorer.
Thanks, jkish. Easy cheesy.
OK, not so easy. I have changed the file to .html and that's great. The problem is that if I try to access from another machine ( http;//HASERVER/FP1.html ), I get an error message of the 404 type stating that it can't access the file. The same is true, if I try outside the IV and just try to open it in a browser on another machine. I've also pinged the machine named HASERVER and the connection is fine. Any ideas?
AnthonyZ Wrote:OK, not so easy. I have changed the file to .html and that's great. The problem is that if I try to access from another machine ( http;//HASERVER/FP1.html ), I get an error message of the 404 type stating that it can't access the file. The same is true, if I try outside the IV and just try to open it in a browser on another machine. I've also pinged the machine named HASERVER and the connection is fine. Any ideas?

Is the semicolon above in the URL a typo? That should be http://...

CQC webserver installed? On port 80?
It's a typo. Umm, I don't know about the webserver. I just don't remember and I haven't documented the install. Is there a way to check or am I better off uninstalling and then reinstalling CQC?
AnthonyZ Wrote:It's a typo. Umm, I don't know about the webserver. I just don't remember and I haven't documented the install. Is there a way to check or am I better off uninstalling and then reinstalling CQC?

Not sure if there is an easy way to check or not.
The only sure way I know of to tell is to reinstall the latest version on the server running the web server and select custom install rather than using the previous parameters. When you get to the web server, it'll have the server port and the web port.

Russ...
Pages: 1 2 3