Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Official RIVA thread
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
Does the NewTemplate message indicate the size of the maximum rectangle which might ever contain useful content for that template? And is a NewTemplate sent every time the template changes?
Well, it indicates the size of the base template. Nothing in that template can be drawn outside of it, so effectively that's true. However, a popup can go beyond the bounds of the base template. But, it wouldn't really matter in the case where the base template fits the screen. The extra stuff wouldn't be visible anyway and it would represent a fairly pathological case that I don't think anyone would worry too much about. I think that if you make the assumption that you never actually need to draw anything outside of the area of the base template, then you will be fine. I don't think it's much of a limitation to require folks to keep their popups within the bounds of the parent template if they want paging to work correctly.
So how did Sam design his set of templates? Did he create a 320x480 set, then duplicated everything in a 480x320 set, and coded a button to switch between both sets (or maybe he uses a RIVA action...)?
The iRIVA application sends hotkey messages on orientation changes that the user can respond to however. In my case I load the alternate set of templates.
OK, that's what I meant with my "RIVA action" guess. Wink
I'm having troubles with my RIVA clients now. None of them will connect. I use the iPaq, Windows, and Android clients and all were working and now are not.

I get this error in the CQC Log:
An exception occurred in the image download thread
An exception occurred in worker thread X (a number from 1 to 8)
The connection was reset
An exception occurred in the image download thread
etc
etc
etc

I haven't change my setup regarding the RIVA clients or server. I recently upgraded to 3.3.16 but I cannot remember if this is the start of my problems or not.

Any suggestions?
sic0048 Wrote:I'm having troubles with my RIVA clients now. None of them will connect.
Have you double checked that the RIVA account still tries to use a valid template, and that you hadn't renamed/deleted it?
Fonceur Wrote:Have you double checked that the RIVA account still tries to use a valid template, and that you hadn't renamed/deleted it?

Yup - I've tried multiple users and multiple default templates.

My iPaq RIVA clients seemed to be working fine until I disconnected them and tried to log back in. Now they won't connect either and cycle through getting that error listed in my above post.

It is rather strange, but something is clearly broken. I just don't know if it is on my end or with CQC.

I'd be curious to know if other RIVA users have updated to the latest beta and if their RIVA clients will connect OK.
sic0048 Wrote:Now they won't connect either and cycle through getting that error listed in my above post.
Have you tried rebooting or at least restarting the CQC service?
I have seen the RIVA server get into a bad state and restarting the CQC Service was the fix. Although this was during the early betas, hasn't happened to me lately.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39