Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Extron Crosspoint
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
do to conditions beyond my control, I needed to ditch my little 3x2 MMX VGA extron, and replace it with my 8x4 RGBs Crosspoint...
what driver should I use? the Crosspoint driver just keeps cycling the com port, all the others just sit at waiting to connect, the only one that semi-works is my cheesy one way MMX driver I wrote, but he doesn't really work as such, something switches when you ask it to, but I am not sure what, or where it is switching too?
I had a similar problem. Some of the older crosspoints use a non-standard protocol. If you can open your extron in hyperterm, we could work through the commands to see if your problem is the same as mine. I don't have the information in front of me but I'll get it tonight. My recollection is that the device used mixed case in some key responses in the older version and the newer (the one supported by the shipping driver) uses all caps.

Russ...
well, both 'i' and 'I' return V8X4 A0X0 SYS1
seems pretty case insensitive, but anythings worth a shot...
I was looking though the crosspoint driver to see what I could see, and I am pretty much lost... I think I have officially forgotten what little I knew of CML...
ok, so I have been doing a bit more digging... the reason the com port is cycling is because of this error message:
Quote:The value at offset 2 is not an ASCII decimal digit
the line that is causing this message is:
m_RGB_MaxInputs := Message.ExtractDecValAt(cRGBInputOffset,2);
is there any way to view whats actually in RGBInputOffset? (or is Message the variable/container/whatever and the cRGBInput thing is just a starting point?? this whole software thing is so confusing... Dean should re-write it to use english...)
this is what the driver should be looking at: V8X4 A0X0 SYS1
how can I tell if that is the data that is really there?
Yes, that's a problem w/ versions. I'm not having that problem because I have a 12x8. You need to change that to Offset,1). You have a single digit for sources. I believe the newer response is V08X04.

Russ...
I believe I had to make 1 or 2 similar changes for mine. I honestly don't recall what they were though. I'll gladly work through it with you though.

Russ...
well, I can now see the status of each output... cant change it, but hey at least I can see it, that's something at least...
Put the driver on high verbose and let me know what it says.

Russ...
well I think I am done messing with WHS, so back to this...
reads work fine, the only problem is trying to set a value to an output
nothing shows up in the logs, but CQC does through an error...
Code:
The value written to field test.RGBOutput3 was rejected by the driver
the value is limited to 0-8 (the number of inputs)
so it must be unhappy about something... odd thing is while running in the test hardness thingy, it doesn't through an error... it doesn't actually work, but at least it doesn't throw an error...
Ok, download the free serial port monitor, install and run it again. I'm curious what you're sending and we'll go from there.

Russ...
Pages: 1 2 3