Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: .net interface and PPC
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Iam trying to understand how to use my Cingular 8125 PPC to access CQC at my home pc via .net interface viewer.

I followed the instruction in the release notes of CQC .net interface viewer and successfully able to bring up .netviewer in my home pc and access the PPC_HOME template (Thanks Vivek!). I did have problems while connecting and accessing the .net viewer in desktop and i resolved it by some of the recomendation provided in the forum.

Now Iam trying to connect my 8125 PPC to access the CQC template, this where iam really confused. Iam very novice to networking. I have wireless router at home and i can connect 8125 to internet via WIFI. Here is my questions.

1. I did install MS mobile .net and CQC .net interface cab. When I click the .net interface viewer, nothing happens. I did modify the config file with the valid values. What am i doing wrong here ???

2. Is it necessary that my home pc should be a network pc, it is connected to the router via ethernet. Do i need to change any IP settings??

3. As per the recommendation in the forum, I did install vxUtil. When i try to ping the host name of my desktop, nothing retrieves. Seems like the PPC cannot see my home pc.

Please help me to overcome this newbie issue. Direct me to any link/tutorial, if there is any.

TIA,
-Suresh.
Iam not able to figure this out yet...help help help.....
Mark should see this thread in the morning and should be able to help you out, though it sounds like you have some issues that are outside of the scope of CQC itself.
hey man, i can help out, I have an 8125 also and it's working just fine.

Post your config file here, let me see what that has in it. Also, not entirely sure what you mean with your 2nd & 3rd questions. Can you explain that again? What do you mean by "home pc"?
home pc= Desktop where CQCServer is installed.

After connecting 8125 via WIFI I can ping my router ,but not the host running cqcserver. But from the host I cannot ping 8125. Looks like my router is restricting the wireless network access.
here is the config from the PPC

InterfaceViewerCF>

<Configuration>

<GatewayHost>Nishi</GatewayHost>
<GatewayPort>13509</GatewayPort>
<GatewayEncrypted>false</GatewayEncrypted>

<StartupFullScreen>true</StartupFullScreen>
<StartupKiosk>true</StartupKiosk>
<StartupInitialTemplate>PPC_Home</StartupInitialTemplate>

<SecurityUserID>Admin</SecurityUserID>
<SecurityPassword>iforgot</SecurityPassword>
<EventLogEnabled>true</EventLogEnabled>
<EventLogLevel>1</EventLogLevel>

</Configuration>

</InterfaceViewerCF>
-------------------------------------------------------------------------

From the CQSServer...

<?xml version="1.0" encoding="utf-8"?>

<configuration>

<configSections>
<section name="CQCConfiguration" type="CQC.SystemFramework.ApplicationConfiguration, SystemFramework" />
</configSections>

<CQCConfiguration>

<!-- Gateway settings -->
<!-- -->
<!-- Host - IP address or name of the system hosting the XML gateway -->
<!-- Port - Port number of the XML gateway -->
<!-- Encrypted - True causes encrypted session support -->
<!-- -->
<add key="SystemFramework.Gateway.Host" value="Nishi" />
<add key="SystemFramework.Gateway.Port" value="13509" />
<add key="SystemFramework.Gateway.Encrypted" value="false" />

<!-- Startup settings -->
<!-- -->
<!-- Fullscreen - Normal or maximized window -->
<!-- FrameSize - If not starting fullscreen, this is screen size -->
<!-- Kiosk - Security level for double click -->
<!-- InitialTemplate - Template to load at startup -->
<!-- -->
<add key="SystemFramework.Startup.Fullscreen" value="false" />
<add key="SystemFramework.Startup.FrameSize" value="1024 768" />
<add key="SystemFramework.Startup.Kiosk" value="false" />
<add key="SystemFramework.Startup.InitialTemplate" value="PPC_Home" />

<!-- Security settings -->
<!-- -->
<!-- User ID - text -->
<!-- User password - text -->
<!-- -->
<add key="SystemFramework.Security.UserID" value="Admin" />
<add key="SystemFramework.Security.UserPassword" value="iforgot" />

<!-- Event log settings -->
<!-- -->
<!-- Note: The default CQC event source name is created in the local -->
<!-- machine during setup. If you wish to log events to a different -->
<!-- event source that event source must exist. -->
<!-- -->
<!-- Enabled - true/false -->
<!-- UseFile - true/false -->
<!-- Log - log name -->
<!-- Machine - system for logging -->
<!-- SourceName - source name -->
<!-- LogLevel - 1 to 16 -->
<!-- 1 = Error -->
<!-- 2 = Warning -->
<!-- 4 = Info -->
<!-- 8 = Success audit -->
<!-- 16 = Failure audit -->
<!-- -->
<add key="SystemFramework.EventLog.Enabled" value="True" />
<add key="SystemFramework.EventLog.UseFile" value="True" />
<add key="SystemFramework.EventLog.Log" value="CQC" />
<add key="SystemFramework.EventLog.Machine" value="" />
<add key="SystemFramework.EventLog.SourceName" value=".Net Viewer" />
<add key="SystemFramework.EventLog.LogLevel" value="16" />

<!-- Trace settings -->
<!-- -->
<!-- The settings control groups of trace options. Normally they are -->
<!-- all set to false, however, if a problem is being diagnosed -->
<!-- we might request that certain sections be changed to true to -->
<!-- aid in debugging. -->
<!-- -->
<add key="SystemFramework.Trace.PaintRegions" value="False" />
<add key="SystemFramework.Trace.WidgetStates" value="False" />
<add key="SystemFramework.Trace.XMLReceive" value="True" />
<add key="SystemFramework.Trace.XMLSend" value="True" />
<add key="SystemFramework.Trace.XMLTables" value="True" />

</CQCConfiguration>

</configuration>


Hope it helps
The issue is that when you are using the phone you are no longer in the local network namespace. So having " <add key="SystemFramework.Gateway.Host" value="Nishi" />" can't possibly work as the name 'Nishi' is certainly not known to the internet name servers.

You have three steps that you have to do:

1) You need to establish a name with a service provider that can be resolved to the address of your cable or DSL modem (presumabaly connected to your router). There are a number of providers that are free. I can't get to my e-mail right now so perhaps someone else will jump in with suggestions. You will create a unique name with something like http://www.nishi-surdev.org which will resolve to the router.

2) You have to open up port 13509 on the router.

3) The Gateway.Host name has to change to the name obtained in step #1.

IVB (Vivek) went through these same steps so he might even have a document of the process. He is west coast, so give some time this morning for a response.
Are you looking to use the 8125 from inside your house or outside?

If inside the house, then yes, I wonder if your network is restricting wireless access. Check that out on your router setup screen.

If you're looking to hit the home network from the Cingular network [ie, not over wifi], then Mark is dead-on: you need a way to locate your house network. In addition, your ISP [ie, cable or DSL] doesn't assign you a static IP address, rather they usually give you a dynamic one that changes. So, it's not as simple as just pulling up your router page and seeing what your WAN address is.

I don't have that documentation readily available, but here's what I recall the steps being.

Step 1) Get a named DNS service.
I went with dyndns.com, registered something like yourmommaisugly.gotdns.com [see this page for details].

Step 2) Tell your router you've got a Dynamic DNS
In my router setup screen [usually 192.168.x.1, where x is 0, 1, 2], there's a screen called Dynamic DNS. I had to give it the URL I selected, the username, and the password I created in the above step.

Step 3) Forward your CQC server's XML port to the outside world
Also on your router admin screen, there should be a page called Virtual Server, Port Forwading, or something like that. Find out the IP address of your CQC server, and setup port 13509 to forward to the outside world. This is what will allow your 8125 to see your CQC server from outside your network.

Step 4) Update your config screen above
You'll change GatewayHost to be surdev.gotdns.org, or whatever you selected above.
IVB Wrote:Are you looking to use the 8125 from inside your house or outside?

If inside the house, then yes, I wonder if your network is restricting wireless access. Check that out on your router setup screen.

Iam trying to use 8125 from inside my house. I can access interenet with out any problem thru my 8125. I can ping the router ip from the 8125 without any problem, but not the host running CQC Server. Can you point me where should i look for in the router settings ???.

I'll try to use the DNS service and see whether iam able to connect.

Thanks,
Suresh.
This is far from my area of expertise and may be way off base here but this sounds vitually exactly the same as the problem I had we Mark and I tried to remotely connect to my machine to test a driver.

We could each ping the machine and I could even open the routers web page up remotely but I couldn't get connected. I was even able to test the specific port to see if it was open.

It wasn't until I set up a DNS service that we were able to connect remotely. For some reason my ISP wouldn't allow the connection. Setting up the DNS solved the problem.

Like I said, it's a different situation I understand, but listening to the symptoms and the requirements, I'd bet that's the problem.
Pages: 1 2 3