Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Elk and Lighting...
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have my lights setup X10 (Icon Switches) via ELK and they work fine. I never tried the dimming feature through ELK or CQC before and was surprised that it does not seem to work. I have a PSC05 that is directly connected through ELK so don't have to go through the serial expansion port.

Through ELKRP I set up the light as a "Standard" "Dimmer"...I also tried the Preset and the Extended dimmer....and used the ethernet module and the dimming does not work at all....so it is doe snot seem to be a CQC issue.

I used a slider in CQC to see how it works also bu it jumps straight from 0 to 100 and vice versa...I checked thoroughly and in ELKRP and CQC the PLC devices is setup as Dimmer.

Any ideas or thougths.

Thanks
It may be an issue with x10 emulation/setup on an Insteon device? I don't know too much about that but for sure it will not work right in CQC until you have it working right in Elk. If you go to the keypad and go to menu Automation > Lighting and bring up your switch you can press # to turn it on/off or I think right arrow to access dimmer settings which are intervals of 10% I believe. If you can't dim it properly at least like that it ain't gonna work from anywhere else. It sounds like you set it up right in RP or tried all the settings anyway, which leads me to my guess that it is a problem with the switch setup itself.
What do you mean the switch setup. All I did was assign an x10 code. The switch can be made to dim or brighten by using the switch itself. Is there anything else that I need to do.

regards,
So, you are saying that the switch dims properly locally, but not via Elk, but you can turn it on and off via Elk, but just not dim it?

Did you try to dim it via the keypad as I mentioned above?
In ElkRP, under Automation - Lighting, is the type set to 'Dimmer' or 'On/off switch' ? 'on/off' is the default.

Later-
Thanks folks...sorry was away...yes the lights are setup correctly...and no there is no way from the keypad to go to the dim part. It just says change status and a # to be used to dim.

thanks
Bottom line is if you can not dim from the keypad, there is something misconfigured somewhere. When you go into Lighting from the keypad and scroll to your device, you can either press # to turn on/off or you can press the right arrow and then press 0-9 to dim to 0,10,20%, etc. If you can't dim from there, something is wrong either in the elk config or switch.
I think you need firmware 4.4.2 on the Elk to support dimming from the alarm keypad. That might be it.

-