Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Integra Driver Question
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I am working on my ability to play movies from my hard drive. At this point I have a simple set of templates which drive TheaterTek to start and play the appropriate movie. This works properly.

The way I have things currently hooked up, I am using the PC to drive an S-video output to my Integra 8.4 receiver (yeah I need a different video card to upgrade the signal but one step at a time). The signal comes in on "Video 1".

I added some additional actions under the "Play" button on my DVD_Detail template to control the Integra. They are:

1. Devices::Field Write(Integra2.Z1Power, True) On Click
2. Devices::Wait Driver Ready(Integra2, xxxx ) On Click <--I have used from 0 to 10000 for a value
3. Devices::Field Write(Integra2.Z1SourceAdjust, Video2) On Click
4. Devices::Field Write(Integra2.Z1ListenModeAdjust, Neo6Cinema) On Click
5. Devices::Field Write(Integra2.Z1Volume, 120) On Click

So here's the deal...when I click "Play" TT starts the proper movie and the receiver lights up. After that nothing else happens with the receiver. UNLESS I hit play again, then it switches to Video2 and Neo6Cinema. The volume never changes no matter what I do.

So I believe I'm not doing something right when I wait for the driver to connect. The Integra receiver does start up almost immediately (less than 1 second).

Secondly, I don't think the Z1Volume field isn't acting properly. When I use the Browser in the Admin Interface I cannot adjust the volume unless I use the "up"/"down" fields. Entering a volume directly using the slider never changes the volume.

I appreciate any advice.
You don't need #2. The reason you needed that with the TheaterTek driver is that you needed to start the program up and then wait for the driver to find it. That's not the case with a driver tha talks to a real device. So you can remove that.
Update -

I took the Wait Driver Ready out.

Clicking play will start the movie properly and power up the receiver. Nothing else.

Clicking play again will cause the receiver to switch to Video2 and adjust the ListenMode properly. Nothing else.

The volume never adjusts with the driver.

[Image: IntegraActions.jpg]
In some devices, after a power on it will ignore commands for a little bit. Try putting a System:Tongueause() command after the Z1Power field write, to give it a little bit to power on. First just try a long one like 8 seconds or something to see if that's it. If so, then you can experiment with how short it can be.
A pause of 500millsec was enough.

Still no action out of the volume adjustment. I think it's perhaps a problem with the driver (or I am not writing to the field properly).

I will try to add some volume buttons and see if I can at least get it to adjust properly.

Thanks for your help Dean!
Keith,

It certainly could be either a driver problem or something with your particular receiver that is different than the protocol document. As the driver docs state, the driver was written for all Integra receivers, but only tested extensively with the 5.4 receiver.

If you have a 5.2 or a 6.2, the maximum volume level is 128, for all other receivers it is 256. So if you have one of those two receivers. the issue is that the value is out of range.

If you don't have a 5.2 or a 6.2, go ahead and set up the remote port service, PM me with the info, let's get a time set up where the receiver driver can be unloaded from CQC on your side, and then I can run the driver in the development harness to see what is going on.
Can do Mark.

I'll have to read up on how to set up the remote service so you have access.

The Integra model I have (actually two of them) is the DTR-8.4.

When you were developing the driver I did run though the fields with the field browser and Volume was one which I never got to work as I would have expected. AudioMode was another.

I'll PM you with the remote port service info.
today i got the chance to hook my DTR7.4 up and install the driver with the latest release of CQ (today) on a clean install of XP

testing only from the admin interface i not able to effect the volume in any way. up or down. on zone 1

well, mute worked.

and oddly, Zone 2 volume seemed to work as well (i didn't have speakers attached to test accurately, but the driver indicated a change in volume, which it did not do for Zone 1).
bwally,

There was a problem identified with the volume of Zone 1 (never tried Z2 so I can't tell you if that worked properly or not). Mark sent me another version of the driver to test but I have been too busy to give testing it any justice.

That said, I could not adjust the volume by entering a number but I was able to adjust the volume by using the VolumeAdjust field and up/down arrows.
bwally,

There is a fix for the volume issue, PM me an e-mail address and I will send you an update, but first,

Keith,

Are you saying the fix did not work for the new version? If so, I'd like to connect to your system and test (again), because I thought it was OK i nthe new version, I may have messed something up (like not saving the source before creating the driver pack)
Pages: 1 2