Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Trigger not Working after Move to new Server & V6.0.7
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a simple trigger that worked fine prior to moving to new hardware and a 6.0.7 upgrade.   

The trigger looks for "Is a Field Change For"  on ZonePlayer.CurTrack (which is the Sonos ZonePlayer driver).

Once the field changes, it should copy the name into a CQC Variable Driver file, but it doesn't anymore.  I changed the Triggered Event to log invocations, but it never logs the event, even though I can see it changing in the driver on the AI while watching it.

Any thoughts why a trigger wouldn't work anymore?  I know I had to delete and recreate a few driver setups to get them to work, so maybe that is what is needed here, but would like some input first.  

After reading this, I said what about the other triggered events, and low and behold they don't work either.  My scheduled events seem to work fine.  Anyway, any thoughts on what to do next would be grateful.

Blake
As a follow up to this - the 2nd triggered event I mentioned above, did work but failed, here is the log:

Code:
03/01 12:29:23-CQCServer, CQCEventSrv, EvSrvWorkerThread4
{
    CQCEventSrv, CQCEventSrv_ThisFacility.cpp.529, Info/App Status
    Started processing triggered event '/User/Alarm Set-Unset Email'
}
03/01 12:29:28-CQCServer, CQCEventSrv, EvSrvWorkerThread4
{
    CIDSock, CIDSock_StreamSocket.cpp.779, Failed/Timeout, Error: 5008/0/0
    Connect operation failed. Tried to connect to: 192.168.1.51:5000
      <CQCEventSrv> CIDSock_StreamSocket.cpp - 1069
      <CQCEventSrv> CQCEventSrv_ThisFacility.cpp - 574
      <CQCEventSrv> CQCEventSrv_ThisFacility.cpp - 349

}
03/01 12:29:28-CQCServer, CQCEventSrv, EvSrvWorkerThread4
{
    CQCEventSrv, CQCEventSrv_ThisFacility.cpp.355, Status/App Status
    Scheduled/Triggered event '/User/Alarm Set-Unset Email' failed
}
I am not sure what port 5000 is, it was listening on the old server, but not on the new one.   I created a new triggered event trying to get it to trigger on the Sonos driver, but it will not trigger, so the same problem.

Could any of this be related to the new version, or is it more likely it is related to the new server?
Well I figured out what was going on with port 5000.  I had setup Stunnel some time back and forgot about it, and was using it for gmail access within CQC.  With Windows Server 2016 not sure how I need to proceed, but will keep digging.  I have tried port 587 and 443, but neither of those work with Server 2016 in its default configuration.  Looks like some ports will have to be opened up or possibly install stunnel if possible on it.

Note to Self:  Windows Server 2016 sucks!  Big Grin
Well I got everything working - I was able to fix the email port 5000 by using IP port 587 and SMTP Secure.

On the ZonePlayer - I had deleted the driver and reinstalled it because it wasn't working correctly on the new server, but I had forgot to set the triggers.  So anyway, all somewhat back to normal with the triggers set.
Forgetting to reset the trigger is a common issue. I know that has bitten me before when I've had to reinstall drivers.