Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Old Version pushing CPU usage to 100%
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I run a CQC system at my house as well as my parent's house.  My parent's computer went down a few months ago and because of COVID, I am just getting around to trying to replace it.  They have been running an older version of CQC (4.3.X I think).  It was running on an old 32bit machine.  

I have a copy of their CQC program folder that I moved to the new system.  When I "install" that version on the new 64bit machine, it seems to install correctly (no errors, etc), but it forces the i7 6700 CPU chip to run at 100% all the time.  There are 4-5 different CQC processes running in the background that combined go to 100%.  This behavior stays the same even after a reboot.  I can stop the CQC service and force close those processes and the CPU goes back to normal, but obviously I can't use CQC then.

I realize this is a pretty open ended question, but is there any places I should look to try to get this working normally?  I tried to search the forum to see if anyone else had a similar experience, but I wasn't able to find anything similar.

PS - I am installing the old version from a old zip download that I also had on the computer. It is the zip file that I would have initially used to install CQC on the old machine, but I guess I could always try to download it again to make sure there isn't anything corrupted.
(05-19-2021, 06:03 AM)sic0048 Wrote: [ -> ]  There are 4-5 different CQC processes running in the background that combined go to 100%.  This behavior stays the same even after a reboot. 

Any chance you can post a screenshot of your Performance tab from the Task Manager when this is happening? May be helpful to see the big picture of what is going on.
One thing I noticed on my setup - which I initially installed in 2007, is that it was installed in the C:\Program Files folder since at the time I was running a 32 bit version of Windows (Probably XP). Through numerous CQC and Windows upgrades, I have the latest version running on the same computer, but it is now running a 64bit version of Windows, but it is still in that folder, which technically is incorrect. I always assumed that Windows didn't know about CQC when I went from a 32bit OS to 64 bit.

Did you do the installation into the same folder it was originally in? If not, I could see CQC getting confused on where it should be looking.
Thanks for the reply's. I haven't really had time to look at this further yet. I'll try to look at it tonight and get the list of CQC processes that are running that cause the issue.

Since the installation is on a new machine, I copied to old folder (that was in "C:\Program Files") to the new computer and placed it in the "c:\Program Files (x86)" location. I then ran the applicable installer for the CQC version that I moved over. I'll try from scratch, but this time move the CQC folder to the "Program Files" folder which like you said is technically incorrect, but might be the issue.
There was an issue at one point where a Windows upgrade brought out a previously innocuous issue that would cause a run away thread. We put out a fix for it once it was found. That was back quite a while, but if it's an old version it may be prior to that fix. Installing it on a new system that has the change in Windows would then bring it out. So it cuold be that.
I'm not sure what the issue was. I tried installing 4.2.908 by itself (a clean install) and even that caused a 100% CPU issue.

The good news is that by looking through the old backups, I was able to find a later version (even though the backup itself as labeled an earlier version number). That got me up to 5.2.11 which installed as a "update" and I don't have any CPU issues.

So while I have no idea what was causing my issue, I've been able to get past it.
Did you put CQC in the "\Program Files" folder?  I am guessing my server is long in the tooth and will fail soon as it has been running for 14 years.  Just wanted to know whether you kept it there or let it go to the "c:\Program Files (x86)" folder.
I tried both ways and had the same results so I don't think that really matters one way or another. One the new system I ended up with it in the Windows (84) Program File location.