Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Log Error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am getting this error in my logs every 5 secs.
Can you tell me what it means?

12/11 08:14:28-Security, CQCClService, ClSrvMasterThread
{
    CIDLib, CIDLib_Vector.hpp.1233, Failed/Out Of Resource, Error: 772/0/0
    The maximum collection node count has been exceeded. Max=0
      <CQCClService> CIDOrbUC_NameSrvClientProxy.cpp - 334
      <CQCClService> CQCKit_ThisFacility.cpp - 1230

}
12/11 08:14:33-Security, CQCClService, ClSrvMasterThread
{
    CIDLib, CIDLib_Vector.hpp.1233, Failed/Out Of Resource, Error: 772/0/0
    The maximum collection node count has been exceeded. Max=0
      <CQCClService> CIDOrbUC_NameSrvClientProxy.cpp - 334
      <CQCClService> CQCKit_ThisFacility.cpp - 1230

}
12/11 08:14:38-Security, CQCClService, ClSrvMasterThread
{
    CIDLib, CIDLib_Vector.hpp.1233, Failed/Out Of Resource, Error: 772/0/0
    The maximum collection node count has been exceeded. Max=0
      <CQCClService> CIDOrbUC_NameSrvClientProxy.cpp - 334
      <CQCClService> CQCKit_ThisFacility.cpp - 1230

}
12/11 08:14:43-Security, CQCClService, ClSrvMasterThread
{
    CIDLib, CIDLib_Vector.hpp.1233, Failed/Out Of Resource, Error: 772/0/0
    The maximum collection node count has been exceeded. Max=0
      <CQCClService> CIDOrbUC_NameSrvClientProxy.cpp - 334
      <CQCClService> CQCKit_ThisFacility.cpp - 1230

}
12/11 08:14:48-Security, CQCClService, ClSrvMasterThread
{
    CIDLib, CIDLib_Vector.hpp.1233, Failed/Out Of Resource, Error: 772/0/0
    The maximum collection node count has been exceeded. Max=0
      <CQCClService> CIDOrbUC_NameSrvClientProxy.cpp - 334
      <CQCClService> CQCKit_ThisFacility.cpp - 1230
It looks like the client service is trying to find the available drivers (it looks for media repo drivers to pull down media info from), but the ORB has somehow gotten backed up and is rejecting the request because it nowhere to put the outgoing request info. It has to be on the client side in this case since it's just the client service and no one else having the issue apparently. So it's not the on the name server side. It's on the client side trying to talk to the name server.

This is something I'm already looking at, though the other person who reported it is seeing slightly different stuff reported. It's got to pretty much be the same thing. He's seen it on a couple of servers (which are also clients to other servers), so it's got to be in the ORB stuff. I've taken some measures for the next drop, and added some extra stats and logging to help if it continues.

In the meantime, use the task list and kill CQCClService.exe. It'll automatically restart and pick up again.