Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: HAI Driver Issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I upgraded to 5.2.11 and my HAI driver is not working.
The Driver Status is: Wait to Connect

I know the IP is working on the HAI panel because I can see and control it form my phone app just fine.

I have an old V1 driver that connects fine.

I tried to reconfig the driver
I also tried to delete and start from Joy

I got it going.

I had a couple of zones that were bypassed.
I brought them back online and then reconfig the driver and it connected.

Hopefully that fixed it for good!
Hmm.... Maybe there's something about bypassed zones that is confusing it. I'll put that on the list to look at.
Could you flush the logs, then bypass a zone and see if that makes it go off line? If so, put the driver into high verbosity, let it run for ten or fifteen seconds, then turn verbose logging off and get me a log dump?
As a data point, I ran into the same issue recently and it was a bypassed zone. I meant to post but forgot.
OK, I'll be taking a look at that in the next day or so.
OK, I've got that fixed for the next drop. Actually this error was introduced a long time ago but not caught because it was using the wrong enumeration to text translation, but both them returned the same value for the first two values (Disarmed and Armed.) They only returned different values for the bypassed modes. So it wouldn't fail until you bypassed one.