Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Official 5.3 Beta Discussion Thread
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I tried with the latest version and smartthings and got the Replication failed message.
(04-01-2018, 07:05 AM)Dean Roddey Wrote: [ -> ]For HC2, it never sent the security scheme inherit message which is necessary to complete the inclusion. Maybe it sent it considerably later or something, but that wouldn't do the driver any good. Everything was good up until then. Try it again and let it run a minute or so, so we can see if it ultimately ever sent the message or not.

What do you mean by let it run a minute or so?  I'm not stopping anything - at the HC2 end the process terminates after about 15s, once the USB device is added.  See HC2 log below: 

[16:32:19] Home Center in learning mode
[16:32:28] Device added
[16:32:29] Controller added
[16:32:29] Add node status protocol done
[16:32:29] Adding devices complete
[16:32:29] Adding devices complete
[16:32:34] ID 75: Device configuration finished

And at the CQC side, the notification message says 'replication failed' and just displays DONE as the option to dismiss the dialogue box.  Nothing seems to be happening at either end at this point.  I've left the CQC dialogue up without pressing DONE, but that seems to make no difference.

The strange thing is that yesterday, when I tried this fo rthe first time (I think with 903), it was saying replication successful.
I just meant wait a while longer before flushing the trace, to see if the master ever got around to sending the scheme inherit message.
(04-01-2018, 07:23 AM)potts.mike Wrote: [ -> ]I tried with the latest version and smartthings and got the Replication failed message.

1. Delete the driver config file, just in case since there were some issues initially
2. Exclude the driver from STs
3. Reset the trace file
4. Do the include
4. Close the trace file
5. Post the trace file
I've gotta go do a family thing. I'll be back over the late afternoon.
OK, so I've just completely reset :

 - exluded Aeotec USB from HC2 (CQC confirms this and says Replication successful)
 - restarted HC2 (just to be sure)
 - Delete the CQC zwave driver
 - Delete Trace & Z-Wave.cfg from Data directory
 - Delete ZWaveUSB3S*.* from Drivers directory
 - Rebooted CQC (just to be sure :-) )
 - Reloaded zwave driver
 - Set trace to high
 - Excecuted Include
 - Left all well alone for 10 mins :-)

Attached is the trace file.
Same as before. It just never sends the security scheme inherit message. I have no idea what to do about that since it's not an error or anything, it just doesn't continue the process. It's all going fine to that point. There's nothing failing, and we are exchanging info just hunky dory, but then it stops. So the secure inclusion never completes. Without some idea on his side as to why he's not happy I'm not sure what to do. This process is working fine for Vizia and Smart Things so presumably I'm not doing anything obviously wrong.

Oh, wait, I think the HC2 is trying to make us a SUC (static update controller) but we don't support that. So I probably need to disable any attempt to set that on us. So let me try that.
That could make sense. I seem to remember I had to configure OpenHAB as a SUC when I was playing around with it over Xmas (waiting for the CQC Zwave driver to be complete) to make it work as a secondary controller with the HC2.
If it's required, then this may not work. The driver has no support for that, and probably won't since I don't have any good docs about what that requires.

I just tried to set the "don't make me a SUC" flag on the Z-Stick but I'm not getting a response, so I'm not sure if I can reject it or not.
(04-01-2018, 07:07 AM)Dean Roddey Wrote: [ -> ]
(03-31-2018, 09:25 PM)bobskie708 Wrote: [ -> ]On .904b

About half of the devices were still showing GetName. A re-include to replicate did not seem to help. I completely removed the driver, removed the folder, restarted all CQC services, and started again from square1. Excluded and joined the zwave network, and the whole enchilada. Still same result, about half are now in WaitDevInfo and the other half are get name or something similar.

Can you get me another trace of the startup process?

I cleared everything out and did a trace starting from square1. I didnt realize I did that bad of a job collecting device dumps. Attached is the trace and device dumps for the 3 device models that make it to WaitDevInfo.