Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Echo Config file issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I've been playing around with Alexa today, and thanks to the excellent documentation have been able to set up the Amazon side of things without issue.  However, I seem to be having trouble with the CQC side of things.  I made a sample starter configuration file as suggested in the pdf but when I run it Alexa says "The CQC configuration file could not be loaded. Please contact your CQC administrator."

I thought maybe I had not put the file in the correct location, but I double-checked by running the command prompt as an administrator and it's in the right place.  I've attached a screen shot showing the location.  I'm not sure what I should try next.

Thanks,

Rich
Check the logs. That could mean that there are syntax issues in the file.
Its the sample config file from your pdf:

EchoConfig
MyKey=ABCDEF
EndEchoConfig
RunMap
EndRunMap
SetMap
Action=\User\Echo\SetMedia
Volume, Music Volume, Theater Volume
EndAction
EndSetMap
QueryMap
EndQueryMap
Still check the logs, to see if any errors show up, else we are just guessing.
Looks like it isn't finding the file.
When you can clearly see that the file is there, but it's not found, and it's down in the program files areas, a relatively common scenario is that the system has redirected your file to a per-user directory. You may have to start the editor (or command line) as an admin. Then go to the place where it should be and see if it's still there. If not, then it probably got redirected and you'll have to create it again as admin and that should do it.

If you still see it there, let me know.
I deleted and recreated the directory for the echocfg file running notepad as an admin.  Everything appears to be in the correct spot but its still not finding the file.  I've attached a screenshot of the command prompt which appears to indicate the file is in the right place.
You already cleared one possible cause I was going to suggest, using notepad and not another text program.

One of your above posts I think states you used the sample config from the .pdf, did you copy that in or type it out? I recall someone copy and pasted and it did not work until they typed it out. If you typed it out, check spelling. I mucked around for a while and left off a letter and didn't notice.
I copy/pasted it from the pdf.  I'll try typing it out and see what happens, thanks for the suggestion.

Unfortunately that didn't fix the problem.
Did you check the logs again after typing it out? Just again making sure it wasn't a syntax error. If it still is staying it didn't find it, it has to be something silly at this point.

Is this a single machine system? Are you creating the file on the same machine where the CQC web server is running?
Pages: 1 2