Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: VRCOP Problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
My zwave system recently stopped working. I updated my VRCOP from my VRUSB, that all seemed to work correctly. After checking everything else, I switched to the V1 driver and it came back online. I have gone back and forth a few times and onnly the V1 driver will work. With the V2 driver, under "driver status" I get "wait for connect". Any Idea why this happened? I just updated to 5.0 and still the same thing....

Corey
Oh, you mean you went from the V1 to the V2 driver? If so, that won't work. The V2 configuration is very different and works on a completely different principle, so it can't make us of the V1 configuration. If you named the V2 version the same as the V1, it might be trying to load the old V1 configuration, so you may need to remove that, or at least name it away to something else for now, and let the V2 driver come up fresh. Then you can configure it using the new V2 scheme.

Also, keep in mind that the V2 driver doesn't poll. So if you have any modules that don't send out notifications, you can only use those as write only modules under the V2 driver. The polling never really worked because the Z-Wave network doesn't deal well with the constant traffic. So we just got rid of it for the V2 driver.

The V2 driver has files that describe the modules and so it knows how to set them up and how to use a lot more of the capabilities of the modules. If the module supports async notifications of changes, the configuration will set that up. There's an 'auto-config' button on the V2 client side interface that will do the setup based on the module type you selected.
No, I originally had set it up with the V2 driver which worked for a year, last week it stopped working and the only way to get it to work was to use V1. I did delete and rename with no luck until last night, after resetting to V2 and walking away for a while, I came back and it had connected again, so it is fixed, but I'm still not sure what the problem was.

Thanks for the help. It's been fun learning the software, and has been working well.

Corey