Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sonos - PlayFovorite command
#1
Devices::FieldWrite
    P1=Sonos.InvokeCmd
    P2=PlayFavorite : Example
    P3=True

This command started failing causing the driver to disconnect and reconnect with the Sonos device.

I'm guessing do to a Sonos update.

Anyone else experiencing or can replicate?

Anything I can do to help? everything else continues to work as expected. This command still works.

Devices::FieldWrite
    P1=Sonos.InvokeCmd
    P2=SetPLToQ : ByName, %(GVar:Selection)
    P3=True
Reply
#2
(04-17-2019, 05:29 PM)NightLight Wrote: Devices::FieldWrite
    P1=Sonos.InvokeCmd
    P2=PlayFavorite : Example
    P3=True

This command started failing causing the driver to disconnect and reconnect with the Sonos device.

I'm guessing do to a Sonos update.

Anyone else experiencing or can replicate?

Anything I can do to help? everything else continues to work as expected. This command still works.

Devices::FieldWrite
    P1=Sonos.InvokeCmd
    P2=SetPLToQ : ByName, %(GVar:Selection)
    P3=True

I have had this happen when the favorite is not available anymore.  Amazon Music seems to be really good at changing their canned playlists that I programmed in.  It has also happened on an IHeartRadio station that only broadcasts during sports events.
Reply
#3
No, all the Favorites are there. Nothing has changed except Sonos software updates.

I haven't really dug into the problem yet. I was hoping someone would could confirm it for me. It has been working for over a year.

The log only shows the device is not connected and then subsequent commands fail

CQCKit, CQCDriver_DriverBase.cpp.4853, Failed/Not Ready, Error: 906/0/0
Driver 'Sonos' is not currently connected to its device

Watching the "Driver Status" nothing changes and I can send volume or transport commands no problem. I don't think its really disconnecting. Can't get it to load any of the Favorites though. All my playlists live there. It allows me to queue live Spotify playlists and radio stations.

Any ideas?
Reply
#4
It's probably recycling quickly. If you put it into verbose mode you'd see the loss of connection error and reconnection errors most likely.
Dean Roddey
Explorans limites defectum
Reply
#5
I tried that. Nothing showed up. As far as I can tell.
Reply
#6
(04-20-2019, 04:09 PM)NightLight Wrote: I tried that. Nothing showed up. As far as I can tell.

I am on this: Version: 10.0 (build 48261220), and no problems.  My comments above related to the Sonos Favorites that were saved in the Favorites list.  I was having trouble getting the station/playlist to play on the Sonos App on my phone, and when that happened, It would lose connection on the driver when I selected it.  Apparently you can have non-working playlists/favorites in your Sonos playlists/favorites list that are non-functional.

Lastly, I am not sure what version you were on, but one of the upgrades in the recent past, in October or so, really improved Sonos for me.   I think it was around 5.3.910 or maybe a few versions above that.
Reply
#7
In 919, some significant work was done in the UPnP stuff that would probably explain that. Though also there were some others, like removing the initial Stop command when the driver comes up and a couple other things. And of course we had to remove the device properties service because Sonos broke that wrt to the Windows UPnP stack.
Dean Roddey
Explorans limites defectum
Reply
#8
(04-21-2019, 08:30 AM)Dean Roddey Wrote: In 919, some significant work was done in the UPnP stuff that would probably explain that. Though also there were some others, like removing the initial Stop command when the driver comes up and a couple other things. And of course we had to remove the device properties service because Sonos broke that wrt to the Windows UPnP stack.

I'm on 5.3.947

Sonos 10.1 Build 49263270

I poked it a little tonight. No change. I think is might be broken again. Sorry Dean, you must get tired of hearing that.

Anything I can do to help?
Reply
#9
I'll try to get my Sonos upgraded and try it in the next day or so.
Dean Roddey
Explorans limites defectum
Reply
#10
Any luck with this? I tried to revert back to old Sonos 10.0 but there seems to be no way (apart from contacting Sonos) to do that.

Thoughts?
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  SONOS Driver Question gReatAutomation 9 191 08-13-2019, 04:05 PM
Last Post: gReatAutomation
  template timeouts and LoadOverlay command Shaky 9 924 04-29-2019, 07:46 PM
Last Post: kblagron
  Sonos batwater 4 744 01-24-2019, 05:20 AM
Last Post: batwater
  Hiding Command Buttons on template kfly 5 819 12-14-2018, 06:52 PM
Last Post: Dean Roddey
  Sonos Update Error (Again) karenlee 39 4,718 12-04-2018, 10:15 PM
Last Post: Dean Roddey
  Pause Command Seems to be Short kblagron 1 486 12-01-2018, 09:04 AM
Last Post: Dean Roddey
  Sonos PlayFavorites kblagron 8 1,404 10-22-2018, 08:46 PM
Last Post: Dean Roddey
  Sonos Driver zra 3 1,178 09-01-2018, 03:09 PM
Last Post: Dean Roddey
  Need some help with DynamicOverLoad command adamalli 14 2,337 08-30-2018, 04:49 PM
Last Post: Dean Roddey
  With Echo integration is it possible to have a set and a query with the same command? ghurty 9 2,187 07-12-2018, 08:43 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)