Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Admin interface and CML IDE interface issue
#1
I have been using the administrative interface and the CML driver harness now sufficiently long for this issue to reach the annoyance level for me to post here...

Say I have a driver opened for development in the CML Driver IDE, with the cursors in the main code window. The cursor is on the name of a method. I can use the keyboard to select text, by holding down the Shift key and moving the cursor, and I can then cut/copy the selected text to the clipboard using standard key combination, such as CTRL+X or CTRL+C. Then move the cursor away, to dismiss the selected text...

If then I was to search for the copied text, I can press CTRL+F which will bring up, activate the search/replace tab on the bottom of the IDE, and place the cursor into the "search criteria" drop-down field.

And this is where, I think there is a bug: if I press CTRL+V to paste the text from my keyboard where the cursor is active and blinking, it does not do it, it is pasted into the main code window, where the cursors is not even active. The only way to paste text into the search field is by grabbing the mouse, right click there, and few more clicks later, find and click the paste command.

This behavior is not standard, at least by my account, and despite of best effort to remember, I keep pasting bogus text where is not needed, and than chasing tale to find out why something is not working...
Similar behavior is seen in the administrative interface, im the "Customize/Macros/User/CQC/Drivers" section

Dean can you please check?
Reply
#2
It's probably to do with hot key processing. Scintilla (the code editor window) doesn't implement those standard keys so I'm doing it via hot keys and imposing it on Scintilla from the outside. It's probably incorrectly routing those to the Scintilla window. I'll check it.

You can probably still use the Ctrl-Ins/Shift-Ins keys in the search window entry fields in the meantime, if that helps.
Dean Roddey
Explorans limites defectum
Reply
#3
OK, I removed those accelerator keys and bit the bullet and intercepted those keys down in the editor itself via subclass. It all works correctly now, so that will be fixed in the next drop.
Dean Roddey
Explorans limites defectum
Reply
#4
(01-11-2019, 10:18 AM)Dean Roddey Wrote: OK, I removed those accelerator keys and bit the bullet and intercepted those keys down in the editor itself via subclass. It all works correctly now, so that will be fixed in the next drop.

Does that include CTRL+Z for undo as well?  as most of the time when I realized that yet again when I pasted something somewhere, simply could not even undo?
But thanks a lot anyway...
Reply
#5
I'll check that one also... It's probably the same issue.
Dean Roddey
Explorans limites defectum
Reply
#6
Give 5.3.929 a shot.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  SOLVED: VLC dll Issues with CQC Interface Template Viewer gReatAutomation 3 208 06-17-2019, 06:17 AM
Last Post: gReatAutomation
  ELK M1 Client Interface question lleo 1 115 06-12-2019, 08:15 AM
Last Post: Dean Roddey
  Elk Client Interface Gremlins IVB 9 896 12-23-2018, 08:58 PM
Last Post: IVB
  Copy and Paste into Global Cache Client Interface kblagron 3 870 11-01-2018, 02:23 PM
Last Post: kblagron
  WebRIVA password special character issue? batwater 10 1,513 09-30-2018, 02:07 PM
Last Post: batwater
  Admin Client over VPN batwater 1 847 08-18-2018, 04:31 PM
Last Post: Dean Roddey
  A big issue with use the Elk M1 and CQC, cant use the IP dialer ghurty 1 708 08-05-2018, 08:56 AM
Last Post: Dean Roddey
  WebRiva, Android, scaling issue IVB 2 923 07-15-2018, 01:47 PM
Last Post: IVB
  HTML5 and Webriva and the Interface Veiwer ghurty 1 877 07-11-2018, 10:50 PM
Last Post: Dean Roddey
  Does anyone have a nice interface set up using the new webRiva system? ghurty 0 753 05-15-2018, 03:13 PM
Last Post: ghurty

Forum Jump:


Users browsing this thread: 1 Guest(s)