Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
zWave, how I hate thee. need to redo network
#11
looks like the malwarebytes program asks for a program.What program should I list?
------------------------------------
Some of my devices: Sonos, Aeotec zWave, Nest, Rain8Net, Various H/T
What's next: CQC-Voice, Brultech GEM
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
Reply
#12
Yeh, it's the 13520 one that you see the net test trying to connect to. It's connecting via IPV6 as you can see in the test. The program is CQCClService.exe.
Dean Roddey
Explorans limites defectum
Reply
#13
ok. Malwarebytes exclusion didn't help. So basically try random stuff until I can make this thing go away:

Code:
Testing Client Service...
        Server is registered at MINI-PC.13520
Test failed! Error=
01/01 00:00:00-MINI-PC, CQCNetTest, CQCNetTest
{
    CIDOrb, CIDOrb_ClientBase.cpp.456, Failed/Not Found, Error: 1006/0/0
    The server at fe80::a85a:71d3:ba43:fca5%12:13520 was not available
}
------------------------------------
Some of my devices: Sonos, Aeotec zWave, Nest, Rain8Net, Various H/T
What's next: CQC-Voice, Brultech GEM
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
Reply
#14
Basically yeh. The error clearly indicates that the program cannot get to the address/port combination. But, the program is clearly running as you observed. So the only options are:

1. Something is blocking it
2. Something else is using that port.

The second thing you can do by running netstat like this:

netstat -abn > whatever.txt

What will dump to the file all the open ports and who has them open. You can open that file in notepad or whatever and search for the port number and see what program has it open and what its state is.
Dean Roddey
Explorans limites defectum
Reply
#15
I assume you actually have IPV6 enabled on that machine? You are getting an IPV6 address when the local host name is looked up, but that doesn't necessarily mean you haven't disabled ipV6. If you have, then it wouldn't work.
Dean Roddey
Explorans limites defectum
Reply
#16
I don't know if this will help - I was suddenly locked out of my Amazon Echo Hue Simulator Driver setup some months ago. I suspected a Windows update at the time, but couldn't be sure as I had some other flaky stuff going on. Anyway, I did the whole reboot all hubs blah blah boring stuff that makes you want to slit your wrists blah blah, including turning off Windows Firewall (both Private and Guest) but no luck. After a few hundred more fruitless attempts, I eventually gave up.

A few months later, doing the same routine, I discovered something which I think is new, or at least works in a new way because I've never had to fiddle with it before when ports have been blocked... a Domain profile under the firewall settings. This does not get affected when you turn the firewall off from the main Firewall window (which only shows Private and Guest options). So I turned it off to test, and viola, my Hue Simulator started working again, oh happy days!!

So - check:

Open Windows Firewall
You will see Private Networks
Guest Networks
Click Advanced Settings on the left

You will then see:
domain profile
private profile
public profile

Try turning the Domain firewall off, and see if it changes anything.
Reply
#17
Finally had a window to try all these things, no love.

Here's the netstat. CQC is the only thing on 13520. Any other ideas?


Attached Files
.txt   netst.txt (Size: 15.13 KB / Downloads: 4)
------------------------------------
Some of my devices: Sonos, Aeotec zWave, Nest, Rain8Net, Various H/T
What's next: CQC-Voice, Brultech GEM
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
Reply
#18
It would seem like here:

TCP [fe80::a85a:71d3:ba43:fca5%15]:51637 [fe80::a85a:71d3:ba43:fca5%15]:13520 ESTABLISHED
[CQCAdmin.exe]

that CQCAdmin has an established connection to the client service. Of course if somewhat was blocking it, that might not make any difference. It might allow the connection but not allow any communications or some such, I dunno. That's a local IPV6 connection.

Have you tried CQCNetTest again since making changes?
Dean Roddey
Explorans limites defectum
Reply
#19
Yep. Get this:
Code:
CQC Connection Tests
--------------------------------
    Trying to connect to CQC name server
    Connected to name server successfully at: ha-vm.13502
       [192.168.3.70:13502]

    Testing Log Server...
        Server is registered at HA-VM.13503
        Log Server tests completed successfully.

    Testing MS Cfg Server...
        Server is registered at HA-VM.13504
        MS Cfg Server tests completed successfully.

    Testing Client Service...
        Server is registered at MINI-PC.13520
Test failed! Error=
01/01 00:00:00-MINI-PC, CQCNetTest, CQCNetTest
{
    CIDOrb, CIDOrb_ClientBase.cpp.456, Failed/Not Found, Error: 1006/0/0
    The server at fe80::a85a:71d3:ba43:fca5%15:13520 was not available
}
------------------------------------
Some of my devices: Sonos, Aeotec zWave, Nest, Rain8Net, Various H/T
What's next: CQC-Voice, Brultech GEM
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
Reply
#20
I'm at a bit of a loss on that one. Though you didn't include the first bit of the dump, so I can't be sure what that machine's local IPv6 address is, it looks ok. Actually, in the netstat I can see that that is the local machine's address assuming netstat was run on the same machine as the nettest.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  ZWave integration frustrations kjaerligkatt 166 8,778 01-03-2019, 05:29 AM
Last Post: kjaerligkatt
  USB ZWave Controller Configuration bobskie708 6 3,466 11-30-2017, 04:07 PM
Last Post: Dean Roddey
  delete zwave devices? jkmonroe 8 2,717 05-23-2016, 08:46 AM
Last Post: Dean Roddey
  connecting a zWave relay IVB 3 1,985 02-20-2016, 03:13 PM
Last Post: IVB
  Why I hate upgrading znelbok 13 2,320 01-03-2016, 02:22 PM
Last Post: Dean Roddey
  zwave device configuration jkmonroe 75 12,614 12-31-2015, 05:21 PM
Last Post: Deane Johnson
  Marantz Network Audio Players cavalier240 7 2,837 11-10-2015, 07:15 PM
Last Post: jkmonroe
  Eventghost able to Ping device out of network EST 10 3,282 09-24-2015, 05:18 PM
Last Post: EST
  ISY zWave controller IVB 4 2,617 06-21-2015, 09:21 AM
Last Post: Dean Roddey
  User Action on ZWave Keypad jkmonroe 18 4,809 04-04-2015, 05:46 AM
Last Post: jkmonroe

Forum Jump:


Users browsing this thread: 1 Guest(s)