Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Official 5.3 Beta Discussion Thread
oh btw in case it's relevant, and I can do this again with a different driver name: The ISY driver was called Lighting. I have templates and actions with that name.

My plan was to make the zStick driver also named Lighting, use the same field names, then I don't have to change any templates.
------------------------------------
Some of my devices: Sonos, Aeotec zWave, Nest, Rain8Net, Various H/T
What's next: CQC-Voice, Brultech GEM
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
Ran it again, deleting the driver as named "Lighting" in case other issues exist, created it called zStickForTesting, ran include again. Replication failed according to CQC, but passed according to RFIT.

This is the entirety of the logs.

Quote:07/02 12:21:30-MINI-PC, CQCServer, ZWRepThreadzStickForTesting
{
ZWaveUSB3S, ZWaveUSB3S_DriverImpl.cpp.314, Failed/Timeout, Error: 4003/0/0
Timed out on reply. Unit=0, msg=4, class=Security, ccmd=Scheme Get
<CQCServer> ZWaveUSB3S_DriverImpl2.cpp - 522

}
07/02 12:21:30-MINI-PC, CQCServer, ZWRepThreadzStickForTesting
{
ZWaveUSB3S, ZWaveUSB3S_DriverImpl2.cpp.532, Failed/Cannot Do
An exception occurred in the post-replication processing
}
------------------------------------
Some of my devices: Sonos, Aeotec zWave, Nest, Rain8Net, Various H/T
What's next: CQC-Voice, Brultech GEM
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
You can't just change the moniker of the driver. The reason being that the security key is stored as part of the driver's configuration data. The master knows we are already included securely, so he won't do the secure inclusion again. But the driver now doesn't have the security key because you changed the moniker. The driver can't fix this itself, so it's kind of stuck. This will only prevent locks from working currently, but you probably have some locks so you either have to keep the moniker, or exclude the driver and re-include it again. If you do that, it will likely get a new id and any existing associations set on the units will be bad.

It's all sort of a mess, but that's Z-Wave.

On the repeating popup, that's pretty strange. Did you get the error with the client service fixed so that you aren't seeing that when you start the AI? Otherwise, you could be running a previous version of the client interface which could make a real mess of things.

If you aren't getting that error, then something else strange is going on and we'll have to dig into it.
Dean Roddey
Explorans limites defectum
This is the weird thing. I'd be happy to delete it from my network if I could figure out how to do that without actually going to the unit to do an exclude, it's only used during the winter for xmas lights and is deep in the crawlspace.

https://www.amazon.com/Aeon-Labs-DSC0610...ge_o00_s00
------------------------------------
Some of my devices: Sonos, Aeotec zWave, Nest, Rain8Net, Various H/T
What's next: CQC-Voice, Brultech GEM
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
The trace file is in [cqc]\CQCData\Server\Data\ZWaveUSB3 on the machine where the driver is running. Be sure to stop or flush the trace file before sending it, else it could be missing some of the activity.
Dean Roddey
Explorans limites defectum
(07-02-2018, 11:28 AM)IVB Wrote: This is the weird thing. I'd be happy to delete it from my network if I could figure out how to do that without actually going to the unit to do an exclude, it's only used during the winter for xmas lights and is deep in the crawlspace.

https://www.amazon.com/Aeon-Labs-DSC0610...ge_o00_s00

I'm not sure what we mean here? Do you suspect this unit is an issue or something?
Dean Roddey
Explorans limites defectum
(07-02-2018, 11:27 AM)Dean Roddey Wrote: You can't just change the moniker of the driver. The reason being that the security key is stored as part of the driver's configuration data. The master knows we are already included securely, so he won't do the secure inclusion again. But the driver now doesn't have the security key because you changed the moniker. The driver can't fix this itself, so it's kind of stuck. This will only prevent locks from working currently, but you probably have some locks so you either have to keep the moniker, or exclude the driver and re-include it again. If you do that, it will likely get a new id and any existing associations set on the units will be bad.
Sorry not following. Stored within RFIT, or stored within CQC? I deleted the driver and started again, got a new node # assigned by RFIT. Which is fine, I haven't done any associations yet.

Quote:On the repeating popup, that's pretty strange. Did you get the error with the client service fixed so that you aren't seeing that when you start the AI? Otherwise, you could be running a previous version of the client interface which could make a real mess of things.

If you aren't getting that error, then something else strange is going on and we'll have to dig into it.

Yes getting the error but only occasionally.

Right now it's a blank slate, so happy to do whatever I need to do.
------------------------------------
Some of my devices: Sonos, Aeotec zWave, Nest, Rain8Net, Various H/T
What's next: CQC-Voice, Brultech GEM
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
(07-02-2018, 11:29 AM)Dean Roddey Wrote: The trace file is in [cqc]\CQCData\Server\Data\ZWaveUSB3 on the machine where the driver is running. Be sure to stop or flush the trace file before sending it, else it could be missing some of the activity.

ah ok. This is that:

Quote:Z-Wave USB3 Trace
, Time: 12:20:48 PM
----------------------------------------------------

12:21:07 - [TRACE]- Driver transitioned to state: Replicating from the master
12:21:07 - [TRACE]- Starting bgn replication thread
12:21:07 - [TRACE]- Entering receive mode... Config says we are not in the network
12:21:07 - Sending a new msg:
{
[DR->ZW] - (REQ,Msg: SetLearnMode/0x50,AckId=58)
{
Bytes: 05 00 50 01 FF
}
}
12:21:07 - [TRACE]- Sending msg, AckId=58, Attempt #1
12:21:07 - [TRACE]- Transitioned from Idle to WaitAck state
12:21:07 - [ZW->DR] - ACK
12:21:07 - [TRACE]- Transitioned from WaitAck to Idle state
12:21:10 - [ZW->DR] - REQ,Msg:SetLearnMode/0x50,Recvd: 12:21:10) 2960MSs
{
Bytes: FF 01 01 00
}
12:21:10 - [TRACE]- Entered controller learn mode
12:21:14 - [ZW->DR] - REQ,Msg:AppUpdate/0x49,Recvd: 12:21:14) 4241MSs
{
Type: SUC Id
Bytes: 10 00 00
}
12:21:14 - [TRACE]- App controller update
12:21:14 - [ZW->DR] - REQ,Msg:SetLearnMode/0x50,Recvd: 12:21:14) 63MSs
{
Bytes: FF 06 23 00
}
12:21:14 - [TRACE]- Learn mode completed successfully
12:21:14 - [TRACE]- Exiting learn mode
12:21:14 - [TRACE]- Starting post-replication work... getting controller info
12:21:14 - Sending a new msg:
{
[DR->ZW] - (REQ,Msg: SetLearnMode/0x50,AckId=59) 62MSs
{
Bytes: 05 00 50 00 00
}
}
12:21:14 - [TRACE]- Sending msg, AckId=59, Attempt #1
12:21:14 - [TRACE]- Transitioned from Idle to WaitAck state
12:21:14 - [ZW->DR] - ACK
12:21:14 - [TRACE]- Transitioned from WaitAck to Idle state
12:21:14 - [TRACE]- Waiting for unit=0, msg=15, class=None, ccmd=Unknown
12:21:14 - Sending a new msg:
{
[DR->ZW] - (REQ,Msg: GetVersion/0x15,AckId=60) 31MSs
}
12:21:14 - [TRACE]- Sending msg, AckId=60, Attempt #1
12:21:14 - [TRACE]- Transitioned from Idle to WaitAck state
12:21:14 - [ZW->DR] - ACK
12:21:14 - [TRACE]- Transitioned from WaitAck to Idle state
12:21:14 - [ZW->DR] - RES,Msg:GetVersion/0x15,Recvd: 12:21:14) 0MSs
{
Bytes: 5A 2D 57 61 76 65 20 33 2E 39 35 00 01
}
12:21:14 - [TRACE]- Got expected reply
12:21:14 - Sending a new msg:
{
[DR->ZW] - (REQ,Msg: ???/0x5,AckId=61) 47MSs
}
12:21:14 - [TRACE]- Sending msg, AckId=61, Attempt #1
12:21:14 - [TRACE]- Transitioned from Idle to WaitAck state
12:21:14 - [ZW->DR] - ACK
12:21:14 - [TRACE]- Transitioned from WaitAck to Idle state
12:21:14 - [TRACE]- Waiting for unit=0, msg=5, class=None, ccmd=Unknown
12:21:14 - [ZW->DR] - RES,Msg:???/0x5,Recvd: 12:21:14) 0MSs
{
Bytes: 03
}
12:21:14 - [TRACE]- Got expected reply
12:21:14 - Sending a new msg:
{
[DR->ZW] - (REQ,Msg: GetInitData/0x2,AckId=62) 47MSs
}
12:21:14 - [TRACE]- Sending msg, AckId=62, Attempt #1
12:21:14 - [TRACE]- Transitioned from Idle to WaitAck state
12:21:14 - [ZW->DR] - ACK
12:21:14 - [TRACE]- Transitioned from WaitAck to Idle state
12:21:14 - [TRACE]- Waiting for unit=0, msg=2, class=None, ccmd=Unknown
12:21:14 - [ZW->DR] - RES,Msg:GetInitData/0x2,Recvd: 12:21:14) 94MSs
{
Bytes: 05 04 1D 5F FF FF DF 05 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 05 00
}
12:21:14 - [TRACE]- Got expected reply
12:21:14 - Sending a new msg:
{
[DR->ZW] - (REQ,Msg: MemGetId/0x20,AckId=63) 47MSs
}
12:21:14 - [TRACE]- Sending msg, AckId=63, Attempt #1
12:21:14 - [TRACE]- Transitioned from Idle to WaitAck state
12:21:14 - [ZW->DR] - ACK
12:21:14 - [TRACE]- Transitioned from WaitAck to Idle state
12:21:14 - [TRACE]- Waiting for unit=0, msg=20, class=None, ccmd=Unknown
12:21:14 - [ZW->DR] - RES,Msg:MemGetId/0x20,Recvd: 12:21:14) 0MSs
{
Bytes: CD 56 AA 4F 23
}
12:21:14 - [TRACE]- Got expected reply
12:21:14 - [TRACE]- Serial ver=5, CtrlId=35, HomeId=1336563405
12:21:14 - Sending a new msg:
{
[DR->ZW] - (REQ,Msg: GetCaps/0x7,AckId=64) 47MSs
}
12:21:14 - [TRACE]- Sending msg, AckId=64, Attempt #1
12:21:14 - [TRACE]- Transitioned from Idle to WaitAck state
12:21:14 - [ZW->DR] - ACK
12:21:14 - [TRACE]- Transitioned from WaitAck to Idle state
12:21:14 - [TRACE]- Waiting for unit=0, msg=7, class=None, ccmd=Unknown
12:21:15 - [ZW->DR] - RES,Msg:GetCaps/0x7,Recvd: 12:21:14) 15MSs
{
ManId: 86
TypeId: 101
ProdId: 5A
Bytes: 01 00 00 86 01 01 00 5A FE 81 FF 88 4F 1F 00 00 FB 9F 7D A0 67 00 00 80 00 80 86 00 00 00 E8 73 00 00 0E 00 00 60 00 00
}
12:21:15 - [TRACE]- Got expected reply
12:21:15 - [TRACE]- Controller reports we are in the network. Our id is 35
12:21:15 - [TRACE]- Driver transitioned to state: Waiting to join secure Z-Wave network
12:21:15 - [TRACE]- No security scheme get yet, waiting...
12:21:15 - [TRACE]- Waiting for unit=0, msg=4, class=Security, ccmd=Scheme Get
12:21:17 - [ZW->DR] - REQ,Msg:AppCmd/0x4,Recvd: 12:21:17) 2049MSs
{
Flags:
Type: Single
SrcId: 1
Class: Security
Cmd: Nonce Get
Bytes: 00 01 02 98 40
}
12:21:17 - [TRACE]- SEC: Idle, sending nonce EA to node 1 immediately
12:21:17 - [TRACE]- Sending msg, AckId=65, Attempt #1
12:21:17 - [TRACE]- Transitioned from Idle to WaitAck state
12:21:17 - [ZW->DR] - ACK
12:21:17 - [TRACE]- Transitioned from WaitAck to WaitCallback state
12:21:17 - [ZW->DR] - RES,Msg:SendData/0x13,Recvd: 12:21:17) 0MSs
{
Bytes: 01
}
12:21:17 - [ZW->DR] - TRANSACK,Msg:SendData/0x13,Recvd: 12:21:17) 16MSs
{
Callback Id: 7
Status: Success
Bytes: 07 00 00 02
}
12:21:17 - [TRACE]- Transitioned from WaitCallback to Idle state
12:21:17 - [TRACE]- Using stored in nonce for unit 1. 0 in nonces left in list
12:21:17 - [TRACE]- Decrypting with nonce 234/0xEA
12:21:17 - [ERROR]- Decryption Failed
12:21:30 - [ERROR]- Never got response. Unit=0, msg=4, class=Security, ccmd=Scheme Get
12:21:30 - [TRACE]- Exception occurred during post-replication updates
------------------------------------
Some of my devices: Sonos, Aeotec zWave, Nest, Rain8Net, Various H/T
What's next: CQC-Voice, Brultech GEM
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
BTW, if you want to completely remove the Z-Wave driver under its current name, then get rid of the ISY, then re-add the Z-Wave driver under the Lighting name, that could be done. You just have to go about it correctly. You will need to do an exclude on the driver to remove it from the Z-Wave network. Then unload the driver from CQC. Then go to the same directory as the trace file above and delete the configuration file that should be there. Then re-add the driver under the new moniker. It will be starting again from scratch and should do the full secure inclusion and re-id all of the units. You will have to make sure any battery powered ones get woken up so that they can get id'd if possible and any setup for the id'd ones gets sent.
Dean Roddey
Explorans limites defectum
(07-02-2018, 11:30 AM)Dean Roddey Wrote:
(07-02-2018, 11:28 AM)IVB Wrote: This is the weird thing. I'd be happy to delete it from my network if I could figure out how to do that without actually going to the unit to do an exclude, it's only used during the winter for xmas lights and is deep in the crawlspace.

https://www.amazon.com/Aeon-Labs-DSC0610...ge_o00_s00

I'm not sure what we mean here? Do you suspect this unit is an issue or something?

This is something 99% of people don't have, so if the problem is something not seen before, this could be the device. RFIT even says "unknown device"
------------------------------------
Some of my devices: Sonos, Aeotec zWave, Nest, Rain8Net, Various H/T
What's next: CQC-Voice, Brultech GEM
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation


Possibly Related Threads...
Thread Author Replies Views Last Post
  Official 5.4 Beta Discussion Thread Dean Roddey 441 40,371 06-15-2019, 02:33 AM
Last Post: Bugman
  Official 5.4 Beta Release Thread Dean Roddey 55 7,292 06-07-2019, 07:02 PM
Last Post: Dean Roddey
  Official 5.3 Release Thread Dean Roddey 27 7,896 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.2 Beta Discussion Thread Dean Roddey 244 87,576 10-14-2017, 07:57 PM
Last Post: Dean Roddey
  Official 5.2 Beta Release Thread Dean Roddey 13 8,793 10-09-2017, 06:49 PM
Last Post: Dean Roddey
  Official 5.1 Beta Discussion Thread Dean Roddey 453 196,333 05-16-2017, 03:45 PM
Last Post: Dean Roddey
  Official 5.1 Beta Release Thread Dean Roddey 28 19,443 05-12-2017, 05:44 PM
Last Post: Dean Roddey
  Official 5.0 Beta Discussions Dean Roddey 2,019 488,128 11-09-2016, 04:34 PM
Last Post: Dean Roddey
  Official 5.0 Beta Release Thread Dean Roddey 15 13,265 11-01-2016, 10:32 AM
Last Post: Dean Roddey
  How to obtain Beta versions? willsauter 3 3,557 07-15-2016, 04:57 PM
Last Post: willsauter

Forum Jump:


Users browsing this thread: 1 Guest(s)