Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Official 5.3 Beta Discussion Thread
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Anybody tried the updated WebRIVA scaling stuff?
(06-24-2018, 11:28 AM)Dean Roddey Wrote: [ -> ]Anybody tried the updated WebRIVA scaling stuff?

Looks good and just deleted my home screen icon and tried to re-create.  I now am back to my old issue with not being able to add to homescreen on android.
http://www.charmedquark.com/vb_forum/sho...#pid149594

I think I had to edit the android link file by hand to get it to work but I cannot remember... arrggg..

Any chance you can change your WebRiva port to 8181 and see if you can create a homescreen icon that works on android?(Chrome)?
Thanks
Kevin
It just uses whatever you installed the web server to use. You can change it to whatever you want. I ran into the same situation. I think it's changes the URL in some way. It may be lower casing it which breaks the password. You could always try setting up an account with an all lower case password and see if that works. If so, then that's probably it. But it may be removing stuff from the URL for some reason, not sure.
(06-24-2018, 06:34 PM)Dean Roddey Wrote: [ -> ]It just uses whatever you installed the web server to use. You can change it to whatever you want. I ran into the same situation. I think it's changes the URL in some way. It may be lower casing it which breaks the password. You could always try setting up an account with an all lower case password and see if that works. If so, then that's probably it. But it may be removing stuff from the URL for some reason, not sure.

Ok sorted it out, again. (hate troubleshooting the same issue twice)
Just tested. Not an upper case/lowercase password conversion issue. Has to be an alternate web port issue(I use 8181)

I remembered the work around and will write it down this time:
Turn your Android phone on Airplane mode, reload the page and then add Homescreen icon while it’s trying to load. Then of course turn off airplane and the shortcut loads with no issues.

Scaling works great. Have to zoom/move screen by touching outside the template area. Any chance to add pinch zoom/move to the template itself?
(06-13-2018, 04:31 PM)kfly Wrote: [ -> ]
(06-13-2018, 03:48 PM)Dean Roddey Wrote: [ -> ]OK, I've posted 5.2.919. This one is an experiment for WebRIVA to see if we can do better on the scaling thing. In this one nopixelscale is gone. Instead there is a vpscale=x. If you don't set it it's just 1.0 which is basically don't scale. You can set it to whatever scaling factor you want, in theory.

I also removed the viewport values that can prevent you from being able to zoom it yourself, so in theory now you should be able to zoom on the fly if you want.

So give that a try and see if it works better.

I can confirm the Schlage lock status reporting is now good. Will do more testing over the next few days.

Just installed back door lock. the new Zwave driver picked up the Schlage BE469 model  automatically.(not sure why have to manual set front door lock model since it is identical but not a big deal)
Thanks again
Kevin
I put 5.2.922 which is just to take care of an issue in the client side interface of the legacy Lutron HWs driver. It was rejecting zeros in the item addresses, but apparently a zero is valid in the third slot of a dimmer, so that has to be allowed for. Also update the server side to be tolerant of old configuration which was made before a lot of error checking was added to the client UI to prevent bad data from being stored. Otherwise, it can fail to load the config and you are stuck since you can't edit it.
I got away from Z-Wave videos tonight and did a new spot topic video, trying now to get caught up with what used to exist in terms of video content in the old 4.8 world, at least. That brought up a couple bugs I need to get fixed. They are small ones, just things that slow you down due to lack of interactive editing when there could be such. I also realized that I'd never really understood how to properly set search criteria on the videos so I'm going back through them and getting that right, which is kind of tedious.

Of course you should subscribe to our Youtube channel if you want to know when new videos are posted.

And I went through the Z-Wave driver and made sure my comments are all up to date with the final, blood smeared state that it has ended up in, so that I don't forget things later when I come back to it. And did some more documentation updates as well. I also need to get the release notes updated before I forget.
Whew... I finally got a new programming table to replace the way too small one I was using before. Since I was ripping it all apart to rearrange, I went ahead and just really do a full reworking to improve the setup a lot. I'm getting too old for the Computer Room Rearrangement Workout. That just about did me in. But it's a much nicer setup. The old desk is now the work bench so I can keep this one nice and uncluttered.
Super. Now you have a nice, large, uncluttered work space to rewrite the interface viewer. Yea.