Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Official 5.3 Beta Discussion Thread
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
OK, I *think* I see what is going on. I think it thinks it worked and starts sending secure messages, but the driver isn't processing them because it doesn't think it worked. So the driver has some queued up nonces. It's apparently not flushing the nonce list when it starts a new replication, so if a nonce arrived just before that it still has it stored away and tries to use it instead of asking for a new one. So the first secure msg STs sends after the replication, as it's bootstrapping up the security stuff, fails to decrypt. I see the driver using a nonce it has stored, but never see one having been sent.

But, the only way that could happen is if STs is not using a rotating nonce id, which it really should. Else every nonce looks like it would be valid for the incoming message. But I'll have to see some more secure messages to tell that.

Anyway, I need to add a flush of my nonce queues upon starting a new replication. Then we can give that a try. I'll get a new drop up tomorrow with that fix.
Dean, now that z-wave is out in testing, do you think you can take a look at adding Hue Dimmer support?   Big Grin
Let’s get a little further into zwave first?.
Yeh, I can't get distracted from this stuff until it's solid. I've put in so much time to get fully spun on it, so I need to make use of those brain cells before they die.
OK, give, 5.2.901 a shot. FIRST THOUGH, delete the configuration file if it got created, so:

1. Unload the driver
2. Delete the config file where xxx is the monker you gave the driver.
3. To be extra sure, delete:
4. Load up the driver again to get the new stuff

Normally these extra steps wouldn't ever be required, but I changed the format and don't want to start building up evolutionary baggage already.

If it doesn't come up right, get me another trace like before:

1. Exclude the driver from STs
2. Open (or Reset) the trace file
3. Do one inclusion from STs
4. Close the trace file
5. Post the generated trace file
Alas i'm on travel until *NEXT* Sunday (4/8) and only in town for 24 hours, so will look at this on 4/14.
does this work on all zstick, or does it have to be the newest?
It probably needs to be the Aeon Gen 5, just to be safe. Even if it not now, at any point I might use some feature that only would be supported on the new ones.
Unfortunately, no joy on 5.2.901.
I followed the instructions in the release to delete the config and ZWaveUSB3S folder. Inclusion shows in ST but CQC looks like nothing happened. InZWNetwork shows false after the attempt. 

I am also getting an error when turning on tracing on the driver. Error and trace files are attached.

If you get to the point where you want a system to dig into with ST, let me know and I can get you remoted in. We might have to schedule it tho, my work hours have been crazy or I have been stuck trying to finish up work at home.
I had a similar experience but didn't get a trace. Has anyone tried the process posted above? Has anyone walked through the steps I linked to above? I seem to remember that there was a special device type needed to associate with the vrcop.