Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Amazon Echo Hue Simulator Driver
I don't know if I am the only one still using the Alexa simulator driver, but it stopped working a month or so ago. The problem seems to be related to a windows update. I am currently on version 1803 build 17134.228 date 05/06/2018 The CQCEchoRelay (ncat) has disappeared from the task list and I cannot seem to re-install it. I have tried several times running the install command script in administrator mode on two different machines, but with no luck. It just does not get installed in C:\Windows\System32 I have even turned off my AVG virus protection software, but it makes no difference. Is this some deep windows thing that is stopping ncat from being installed.

PJG
Reply
OK Now.  I thought you just clicked on the install script to run it.  When I opened a Dos Command Window and ran it from there, it worked correctly and installed ncat.exe.  I then found a second problem.  I had replaced one of my Echo Dots with an Echo Show, but forgot to reconfigure the drive with the new IP address for the Show.  All OK now

PJG
Reply
(08-26-2018, 04:06 AM)pjgregory Wrote: OK Now.  I thought you just clicked on the install script to run it.  When I opened a Dos Command Window and ran it from there, it worked correctly and installed ncat.exe.  I then found a second problem.  I had replaced one of my Echo Dots with an Echo Show, but forgot to reconfigure the drive with the new IP address for the Show.  All OK now

PJG

That's interesting, because mine also stopping working and I haven't been able to get it back up.  My ncat etc are all ok, and there doesn't appear to be any errors from the CQC side (I can reconfig the driver and it all takes up perfectly well).  When I set it to discover, and then run Alexa discover devices, the True flicks to False a few seconds after Alexa starts, which indicates that there was some sort of comms between the two.  But Alexa stubbornly says that no new devices were found....  I have tried two different Alexa IP address, but no joy...
Reply
I was (am?) having the same problem that pjg was having. 

I don't think it is a Windows Update issue as much as a Windows Defender Virus Update issue.  It first hit me when I updated to the 1803 build, but I got it working.  Then with a Virus update last night, it reappeared.

As far as I can tell, Windows Defender sees ncat as a hack tool and deletes it wherever found.  I tried turning off Windows Defender, but that didn't work so I finally went to another computer that has BitDefender protection (instead of Windows Defender), downloaded wuench's EchoRelay zip file again, and extracted it.  

The KEY, as wuench notes in his original post, is to use 7ZIP to unpack it.  If you use Windows or Windows Explorer to extract or even view the compressed file, Windows will suck ncat right out of your system.  Once I had ncat on the second computer, I used a flash drive to put the EchoRelay files on my CQC master server.

I did not have 7ZIP on the master computer so I did not try using it to extract the file on the master computer while Windows Defender was running.  I was pretty sure I had told Windows Defender that ncat was "safe" when the problem originally appeared with the 1803 Windows update, but as noted, the virus definition update seemed to undo whatever I had done. 

My next stop is to see if there is some way to permanently protect ncat so I don't have to go through the whole process again.
Reply
So, just to update.

My Echo Hue Simulator is working again.

Bizarrely, it started working after I switched my Amazon account from USA to UK (which I needed to do to get my Somfy blinds into Alexa).  I had originally had a USA account, switched to UK to use Prime, then switched back as the USA echo devices have more functionality. Finally, I have switched back to UK as Somfy Tahoma is not supported on the USA account. (Still with me?)
 
I had noticed one day that one of my Hue colour bulbs had lost a lot of colours - deep green, for example, could not be reached anymore, I only got a wishy-washy pale green.  When I switched to Amazon USA, my Hue devices went from Dimmable Light to Royal Phillips (or something like that), and suddenly I had deep green again.  But no Hue Simulator Alexa control.

On switching back to Amazon UK, back we went from Royal Phillips to Dimmable Lights, back from deep green to pale ick, and back to Hue Simulator working.

So clearly, big differences the way the different Amazon Alexa accounts are handled.
Reply
Once again, this is - out of the blue - not working for me again.

Unlike previous times, the echo device is finding any new devices, but when I ask for that device to be turned on or off, I'm getting a 'device not responding' response from Alexa. If I delete the driver from CQC and reinstall it, then the very first command (turn the sofa lights on) will work, but immediately after that, everything (including sofa lights) results in the 'device not responding' message.

I wonder if someone who using this driver can test theirs and let me know if theirs is still working?

Thanks
Karen
(All firewalls and antivirus have been disabled, and have rebooted twice, but still not working)

ETA: I've just read that it is no longer possible to use the Hue Emulator with the newer Echo devices
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  RunTimer2 driver rbroders 14 3,828 10-15-2018, 11:45 AM
Last Post: rbroders
  Generic Modbus Driver - Serial & IP znelbok 25 11,921 10-09-2018, 08:59 AM
Last Post: Ron Haley
  Issues debugging IP based driver jnolting 5 377 09-24-2018, 11:52 AM
Last Post: Dean Roddey
  Enhance Driver Test Harness Field Monitor rbroders 1 209 09-24-2018, 10:49 AM
Last Post: Dean Roddey
  Koyo Click PLC Driver rbroders 75 27,943 09-23-2018, 01:18 PM
Last Post: rbroders
  Carrier Infinity HVAC Driver beelzerob 34 13,154 09-07-2018, 01:15 PM
Last Post: lleo
  Sony TV IP driver dogman 10 1,110 08-01-2018, 03:53 PM
Last Post: znelbok
  Sony Bravia TV Driver znelbok 12 2,033 06-11-2018, 09:19 AM
Last Post: Dean Roddey
  XBMC Driver wuench 427 160,471 05-29-2018, 03:02 AM
Last Post: znelbok
  OpenHAB Driver whozeawhat 5 985 05-28-2018, 08:50 AM
Last Post: whozeawhat

Forum Jump:


Users browsing this thread: 1 Guest(s)