Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CQC Remote didn't pick up new ISY V2 instance
#1
Hi:

I just upgraded to 4.7.1. I added a new ISY V2 driver instance to my existing setup, which has the original ISY driver, so both are operating at once. When I launch CQC remote only the older instance shows up under "Devices".

If it matters, the moniker for the new one is "ISY_V2". Any problem with underscores in monikers?

The new driver appears to work OK in every other way. I added a button that controls a light through the new driver to older template, and that works fine in CQC Client.

-Tom
Reply
#2
Is there any sort of 'rescan' type of option on the program? Or has it in the past always picked up new drivers on the fly?
Dean Roddey
Software Geek Extraordinaire
Reply
#3
On the fly, I think. I created a new server entry that duplicated the current one and connected to it, and it picked up the V1 driver, but not the V2.

-Tom
Reply
#4
Is that your only V2 driver? If so, maybe it has an issue with the format of V2 fields and thinks they aren't valid? Anybody else using it with V2 drivers?
Dean Roddey
Software Geek Extraordinaire
Reply
#5
Sorry for the delay. I've been away from home.

The ISY is my only V2 driver.

I already answered one question - it's not the underscore. I renamed the moniker from ISY_V2 to Insteontoo, and it still behaves the same.

I'll try to add another V2 driver when I get a chance. Are any of the dummy drivers V2?

Could it have anything to do with the earlier V1 driver still being loaded? I hope not. I don't want to remove it to test that hypothesis.

-Tom
Reply
#6
I added a V2 thermostat devsim, and CQC Remote didn't pick that up, either.

I already IM'd brianmount. No reply yet. If you have a Batphone, Dean, please use it.

-Tom
Reply
#7
I don't have any other contact beyond the PM mechanism either. He checks in periodically.
Dean Roddey
Software Geek Extraordinaire
Reply
#8
OK. I'll see if I can reach him through the Apple app store.

-Tom
Reply
#9
Hi there. I can try to take a look, if anyone has a system to which I can connect in order to debug. Right now I don't have any XML Gateways to connect to. Thanks.

Brian
Reply
#10
But first, I remember that there's a logging function in CQC Remote. You press the Menu button on the main server list window and select Start Logging, then connect and attempt to show the drivers you aren't seeing, disconnect, go back to the menu, stop logging, and mail the log to yourself. What information do you see being passed back and forth?
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  CQC Remote now available for iPad brianmount 8 4,405 06-17-2014, 12:49 PM
Last Post: Dean Roddey
  CQC Remote now available for iPhone brianmount 68 12,310 07-22-2013, 10:32 AM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)