Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cover Art Browser
#21
The 'no scrolling' option is on the Base tab. It's the "No Inertia" option. You have to be on .905 for it to work, since that's one of the things I fixed in 905 that I just posted.

If you turn that on, then it should only enable Flick type gestures, which should move it a page at a time (non-scrolling.) But you have to insure that your layout (plus spacing) is exactly is an even division of the width of the CAB for that to work. It's not going to try to align things for you, because it just doesn't work that way anymore. It'll just move, when non-inertial, by one width of the CAB.
Dean Roddey
Explorans limites defectum
Reply
#22
Did .905 fix the JRiver issues with the crazy image file name?
Dean Roddey
Explorans limites defectum
Reply
#23
Dean Roddey Wrote:On the JRiver cover art thing, if you go to:

[cqc]\CQCData\Client\Data\MediaCache\

There should be a directory for your Jriver driver in there. If you look in there are there any bmp files? Or just the metadata file? If there are files there, then they got downloaded but aren't loading for some reason. If they aren't there, then I may have gotten something wrong in the JRiver driver wrt to returning cover art to the client service.

Can you flush the logs, force reload of the JR driver, and get me a log dump?


Well I updated to 4_4_905 and things have improved a little. There are still no bitmap files in the folder, just the metadata file. The first time I flushed the logs and reinistalled the JRiver driver, I found a number of other tracks giving problems, this time with a line number in the *.XML file. I deleted all the tracks with a text editor and now I have a clean load, but still no art. As far as I can tell, there are now the correct number of albums in the repository.

02/05 09:49:01-WINTERMUTE, CQCServer, CQCDrv_MyHDAudioThread12
{
CQCKit, CQCDriver_DriverBase.cpp.3357, Status/App Status
Driver 'MyHDAudio' is beginning initialization
}
02/05 09:49:01-WINTERMUTE, CQCServer, CQCDrv_MyHDAudioThread12
{
CQCKit, CQCDriver_DriverBase.cpp.3448, Status/App Status
Driver 'MyHDAudio' is trying to load its configuration
}
02/05 09:49:01-WINTERMUTE, CQCServer, CQCDrv_MyHDAudioThread12
{
CQCMedia, JRDiskRepoS_DriverImpl.cpp.201, Status/App Status
Starting load of media repository from D:\JRivers\MyHDAudio.xml
}
02/05 09:49:01-WINTERMUTE, CQCServer, CIDOrbSrvWorkThread_3
{
CQCServer, CQCServer_DriverCtrl.cpp.164, Status/App Status
Reconfigure of driver MyHDAudio is completed
}
02/05 09:49:06-WINTERMUTE, CQCServer, CQCDrv_MyHDAudioThread12
{
CQCKit, CQCDriver_DriverBase.cpp.3448, Status/App Status
Driver 'MyHDAudio' is trying to load its configuration
}
02/05 09:49:06-WINTERMUTE, CQCServer, CQCDrv_MyHDAudioThread12
{
CQCKit, CQCDriver_DriverBase.cpp.3486, Status/App Status
Driver 'MyHDAudio' has loaded its configuration
}
02/05 09:49:06-WINTERMUTE, CQCServer, CQCDrv_MyHDAudioThread12
{
CQCKit, CQCDriver_DriverBase.cpp.3504, Status/App Status
Driver 'MyHDAudio' is trying to get its comm resource
}
02/05 09:49:06-WINTERMUTE, CQCServer, CQCDrv_MyHDAudioThread12
{
CQCKit, CQCDriver_DriverBase.cpp.3543, Status/App Status
Driver 'MyHDAudio' has its comm resource
}
02/05 09:49:06-WINTERMUTE, CQCServer, CQCDrv_MyHDAudioThread12
{
CQCKit, CQCDriver_DriverBase.cpp.3561, Status/App Status
Driver 'MyHDAudio' is trying to connect to its device
}
02/05 09:49:06-WINTERMUTE, CQCServer, CQCDrv_MyHDAudioThread12
{
CQCKit, CQCDriver_DriverBase.cpp.3603, Status/App Status
Driver 'MyHDAudio' has connected to its device
}
Reply
#24
I have now deleted all the tracks from the two albums with very long file names. The album count has gone down by 2, it is still a clean load, but there are no bitmaps and no album art so I guess this is a separate problem.

By the way, the "No Inertia" flag worked, so I now have a single column list which pages correctly with a flick or drag. Thanks.

PJG
Reply
#25
Dean, Im also noticing that my search queries are not working any more.

Did something change wrt that?
Reply
#26
They should still be working. I'll re-verify that.
Dean Roddey
Explorans limites defectum
Reply
#27
dean,

I just upgraded to .06 and still the search isn't working. FYI.
Reply
#28
They seem to be working fine for me. What exact search are you doing? I'm just using the auto-generated stuff for testing and they seem to be working.
Dean Roddey
Explorans limites defectum
Reply
#29
I did find a bug where the regular expression based title search was actually searching against the artist name instead of the title name.
Dean Roddey
Explorans limites defectum
Reply
#30
Mark discovered something that could be 'splaining a number of possible wierdnesses. The post-init pass on widgets in popups got moved up above the point where the popup was pushed onto the layer stack. So any commands that got invoked during that would actually stick to the underlying layer and be run after the popup exits.

I've got a new 907 build going and will post it in a bit. It includes this fix plus some others. Probably best to get this in place before we dig too deeply into any more strangeness, to see how much strangeness goes away when this probably is fixed.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Cover Art Browser - Init Sort Order kfly 3 2,310 08-02-2017, 08:56 AM
Last Post: Dean Roddey
  Cover Art Browser - No Images zra 33 11,888 07-04-2014, 09:18 AM
Last Post: Dean Roddey
  Cover Art Quality? rbroders 26 10,757 06-11-2014, 06:00 PM
Last Post: rbroders
  Media Repo Item Browser error pinballmark 10 6,215 09-03-2013, 05:00 PM
Last Post: pinballmark
  enable esc to close field browser bbrendon 1 1,698 03-08-2013, 10:36 PM
Last Post: Dean Roddey
  File Tag Browser not working now znelbok 5 2,653 04-20-2009, 09:05 PM
Last Post: Dean Roddey
  Feature Request - Unified Media Browser indygreg 5 3,269 01-06-2009, 04:00 AM
Last Post: jrlewis
  My media playlist browser broke! froop 67 18,058 12-27-2008, 11:38 PM
Last Post: Dean Roddey
  File Tag browser problem simon 3 2,929 07-30-2007, 10:03 AM
Last Post: Dean Roddey
  Media Repo Item Browser MikeW 1 2,325 01-14-2007, 08:30 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)