Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
4.5 Official Beta Discussions Thread
Dean,

Finally found some time to get you the log file. This is what occurs when I try and load the main file from an autogen.

07/06 00:48:46-habeyserver, CQCIntfView, MainThread
{
CIDImage, CIDImage_PixelArray.cpp.1857, Failed/Data Format, Error: 6003/0/0
The source pixel array must be in format true alpha
<CQCIntfView> CQCIntfEng_Template.cpp - 912
<CQCIntfView> CIDCtrls_ErrorDlgs.cpp - 68

}

1 events matched
Flamin' Noobie...
Warp speed now and don't give me any of that dilythium crystal crap!
That just doesn't seem possible. Everyone would be seeing the same problem. Unless, do you maybe have that machine setup for 24 bit color instead of 32 bit color?
Dean Roddey
Explorans limites defectum
I got one more driver conversion done today, the Yamaha A3000, which was one that was fairly straightforward and the device was available. And I did some more work on the web site.

I think we are ready to go. I'm going to probably do the formal release tomorrow or Tuesday.
Dean Roddey
Explorans limites defectum
Hi Dean,

I'm using 4.4.934 on win 8.1 pro, elk fw 5.5.2. I have the Elk v2 driver loaded and have some lights set up as follows:
Loads=
1=light-A1,Switch
2=light-A2,Switch
3=light-A3,Dim
4=light-A4,Dim
5=light-A5,Dim
6=light-A6,Dim
186=light-L10,Dim
187=light-L11,Dim
188=light-L12,Dim
189=light-L13,Dim
EndLoads
Lights A1 thru A6 work as expected using the field browser to turn them on and off, however L10 thru L13 do not. It looks like on and off for A7 are sent instead of for L10, etc. Shouldn't the elk be getting 09pnL1000 instead of 09pnA0700?

Thanks,
Dave

Log entries:

07/07 00:53:28-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.3224, Status/App Status
Bool field written to. FldId=31, Val=True
}
07/07 00:53:28-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.598, Status/App Status
->Elk: 09pnA0600
}
07/07 00:53:28-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.3252, Status/App Status
Binary PLC Write: A.6 State=True
}
07/07 00:53:28-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.2334, Status/App Status
Got command pc
}
07/07 00:53:31-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.3224, Status/App Status
Bool field written to. FldId=31, Val=False
}
07/07 00:53:31-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.598, Status/App Status
->Elk: 09pfA0600
}
07/07 00:53:31-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.3252, Status/App Status
Binary PLC Write: A.6 State=False
}
07/07 00:53:31-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.2334, Status/App Status
Got command pc
}
07/07 00:53:43-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.2334, Status/App Status
Got command xk
}
07/07 00:53:43-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.3224, Status/App Status
Bool field written to. FldId=33, Val=True
}
07/07 00:53:43-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.598, Status/App Status
->Elk: 09pnA0700
}
07/07 00:53:43-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.3252, Status/App Status
Binary PLC Write: A.7 State=True
}
07/07 00:53:43-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.2334, Status/App Status
Got command pc
}
07/07 00:53:44-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.2334, Status/App Status
Got command pc
}
07/07 00:53:47-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.3224, Status/App Status
Bool field written to. FldId=33, Val=False
}
07/07 00:53:47-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.598, Status/App Status
->Elk: 09pfA0700
}
07/07 00:53:47-win81-01, CQCServer, CQCDrv_elkm1Thread7
{
CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1V2.DriverImpl.3252, Status/App Status
Binary PLC Write: A.7 State=False
}
I'll take a look at it.
Dean Roddey
Explorans limites defectum
OK, I did indeed make a hash of the Elk id to X-10 code translation. Not only was the translation wrong but I was using the index of the load into the list of configured loads, not the Elk id of that load. Sorry about that. Not sure how that got past me.

Import the attached driver pack, then reconfigure the driver to get the new code and see if that doesn't do better.


Attached Files
.cqcdrvpack   ElkV2_V2_3_X10CodeFix.CQCDrvPack (Size: 51.56 KB / Downloads: 1)
Dean Roddey
Explorans limites defectum
Oops, that was wrong as well. try this one. It should actually work. Sorry for the stupidity there. Hard to believe that big an issue got through.


Attached Files
.cqcdrvpack   ElkV2_V2_4_X10ActualRealFix.CQCDrvPack (Size: 51.52 KB / Downloads: 0)
Dean Roddey
Explorans limites defectum
rtarver Wrote:Dean,

Finally found some time to get you the log file. This is what occurs when I try and load the main file from an autogen.

07/06 00:48:46-habeyserver, CQCIntfView, MainThread
{
CIDImage, CIDImage_PixelArray.cpp.1857, Failed/Data Format, Error: 6003/0/0
The source pixel array must be in format true alpha
<CQCIntfView> CQCIntfEng_Template.cpp - 912
<CQCIntfView> CIDCtrls_ErrorDlgs.cpp - 68

}

1 events matched


The thread was already closed by the time he found the answer to this, so just throwing this in here for future reference. He was using RDP which was sometimes falling back into 16 bit color mode.

I could work around that, but it's just not worth it in this day and age I think.
Dean Roddey
Explorans limites defectum


Possibly Related Threads...
Thread Author Replies Views Last Post
  Official 5.4 Beta Discussion Thread Dean Roddey 441 41,755 06-15-2019, 02:33 AM
Last Post: Bugman
  Official 5.4 Beta Release Thread Dean Roddey 55 7,323 06-07-2019, 07:02 PM
Last Post: Dean Roddey
  Official 5.3 Beta Discussion Thread Dean Roddey 815 151,300 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.3 Release Thread Dean Roddey 27 7,910 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.2 Beta Discussion Thread Dean Roddey 244 87,644 10-14-2017, 07:57 PM
Last Post: Dean Roddey
  Official 5.2 Beta Release Thread Dean Roddey 13 8,804 10-09-2017, 06:49 PM
Last Post: Dean Roddey
  Official 5.1 Beta Discussion Thread Dean Roddey 453 197,130 05-16-2017, 03:45 PM
Last Post: Dean Roddey
  Official 5.1 Beta Release Thread Dean Roddey 28 19,502 05-12-2017, 05:44 PM
Last Post: Dean Roddey
  Official 5.0 Beta Discussions Dean Roddey 2,019 489,144 11-09-2016, 04:34 PM
Last Post: Dean Roddey
  Official 5.0 Beta Release Thread Dean Roddey 15 13,314 11-01-2016, 10:32 AM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)