Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Media Repo Item Browser error
#1
I have the CAB populating this Browser for jukebox playback.

When selecting items toward the end of the Item Browser I get an error "xx is not a valid index for the collect named "Album name" "

Selected items toward the top of the item browser enqueue fine.

I'm on the latest 4.3.922 and using a new ELO touchscreen/Win7 on the client. (XP is the MS).
Reply
#2
You mean in a preview, where you are selecting items to queue up from a repo item browser, right? Is it maybe only the first page that works, and once you go to a second page it fails? I'll look into it.
Dean Roddey
Explorans limites defectum
Reply
#3
It's not related to the ELO as I remoted in to the server.

For example, Locomotive Breath (track 10) on Aqualung throws error "15 is not a valid index".

index 16 (track 11) for Wind-Up

Tracks 1 to 9 play fine.

The number of tracks in the browser is based on how I size the widget in the editor. Is that the correct way? I have it sized for 16. I can scroll if there are more than that.
Reply
#4
So, it's not even having to be scrolled past an initial page in order for this to happen? That's pretty weird.
Dean Roddey
Explorans limites defectum
Reply
#5
yes, even without browsing a list with more than enough lines. The file J River spits out has the correct numbering.
Reply
#6
Dean, AlbumTracks is the item browser. I have this in the CAB action:

PreviewArt::SetCollectCookie
P1=%(MediaRTV:ColCookie)

AlbumTracks::SetCollectCookie
P1=%(MediaRTV:ColCookie)
Reply
#7
Yeh, I'm seeing it as well. It's obviously some confusion about the calculation of the number of lines visible. I'll get it fixed.
Dean Roddey
Explorans limites defectum
Reply
#8
cool, thanks.

Is there an alternative/possibly better way to pick an album cover and get a list of songs for a jukebox? I'm not locked into the method I used; it just seemed to make sense after watching the videos.

I'm not the first guy doing a jukebox; how are other folks doing it?
Reply
#9
A lot of folks do a popup, but if you are doing a jukebox type thing, then something like what you are doing is probably appropriate.
Dean Roddey
Explorans limites defectum
Reply
#10
OK, that was subtle. During some recent changes, in some code that builds up an item cookie, I wasn't formatting the item id into using hex radix as I should. So it was being formatted into the cookie as decimal, but later being interpreted as hex. This could cause it to refer to a higher item id than it really did.

And, strangely, it was the source of the same error I was trying to figure out (related to getting the cover art for items within a playlist) and couldn't figure out.

So, anyhoo, this should be fixed in the next drop. Since this is obviously related to beta stuff, I'm going to move this thread.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Cover Art Browser - Init Sort Order kfly 3 2,301 08-02-2017, 08:56 AM
Last Post: Dean Roddey
  client driver error after upgrade to 4.8.1 batwater 1 2,161 12-31-2015, 11:39 AM
Last Post: Dean Roddey
  Media Art Issues - 4.5.1 daddyd 64 20,513 07-21-2014, 02:12 PM
Last Post: daddyd
  Cover Art Browser - No Images zra 33 11,862 07-04-2014, 09:18 AM
Last Post: Dean Roddey
  Auto generation Error dpass 6 3,409 06-15-2014, 01:22 PM
Last Post: pbohannon
  Auto-gen error finish.06 6 3,139 06-10-2014, 02:32 AM
Last Post: finish.06
  Unknown Error pjgregory 2 2,220 05-16-2014, 06:08 AM
Last Post: Dean Roddey
  Cover Art Browser zra 45 14,398 03-05-2014, 05:55 PM
Last Post: Dean Roddey
  Media Renderer Changes for 4.4 Dean Roddey 2 2,998 08-21-2013, 03:04 PM
Last Post: Dean Roddey
  Getting Error when working with Templates lymlyt22 7 3,776 07-15-2013, 10:50 AM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)