Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Continual Write Error on RIVA Clients
I have a friend with a CQC system and a few months ago I added iPad control. It worked great for a few weeks, and then suddenly a "Write Error" started appearing as soon as you try to connect. The system is on the latest 2.20 version of the iOS app, and I have tried multiple releases of CQC (currently on the 4.2.922 beta). The Windows RIVA client has the same problem connecting.

My friend's clients can connect fine to my system, and my clients error out on hers, so the problem definitely appears to be with her server. It seems that this error is just sort of a generic "I can't reach the server" error. I suspect that it was an automatic Windows update (now disasbled) that originally broke it, but numerous reinstalls and disabling of the firewall and anything else I can think of have not resolved it.

This is a standalone HA server so there are no other virus or security tools on it. Is there any way to verify that the RIVA server is running properly? When I run a netstat -an |find /i "listening" command (which shows all listening ports), 13515 - 13517 are missing from the list.

Is it possible that the RIVA install is corrupt and that the upgrades are carrying that corruption forward? Is there a way to just remove the RIVA component and force a reinstall without having to rebuild the server install from scratch?

Is the RIVA server running at all? If so, there should be a CQCRemVSrv.exe in the task list on the server. If it is, and you don't see the two ports showing up, then that would be pretty wierd since if nothing is listening on them, the RIVA server should be able to open them. If it can't open them, it should be periodically logging a message to that effect.
Dean Roddey
Explorans limites defectum
It looks like the server isn't running, I don't see that process in the task list. Should I be able to just launch it manually, or does it require some parameters? I tried to launch it and a command box flashes for a second and disappears, but I never see the process startup.

Is there anything else that needs to be enabled to make it startup? I don't remember doing anything special on my system after installing it.
Make sure it's enabled in the installer, by doing a fully custom install pass and seeing if it's configured and using the right ports. Also, check the licensing info and make sure it's enable there. It's possible, though unlikely, that it somehow got disabled.
Dean Roddey
Explorans limites defectum
Yeah, it's definitely enabled in the installer, but I don't see any reference to it in the license info. That's probably why it initiall worked for a while and then stopped.

This is an Unobtainium system, so I assume it should be enabled. I'll PM you the info.
I sent an updated license.
Dean Roddey
Explorans limites defectum
Got it, thanks!

Possibly Related Threads...
Thread Author Replies Views Last Post
  Basic RIVA Questions TurboSam 15 13,035 01-08-2015, 08:29 PM
Last Post: Dean Roddey
  CQC Riva App Iphone 6 zra 14 11,681 11-28-2014, 07:29 PM
Last Post: Dean Roddey
  Riva Client login credentials fail finish.06 2 5,589 08-21-2014, 06:39 AM
Last Post: finish.06
  CQC Riva App Speed finish.06 2 3,795 06-09-2014, 05:01 AM
Last Post: finish.06
  Riva port/protocol rtarver 4 3,537 12-06-2013, 07:54 PM
Last Post: rtarver
  Write Error after CQC server reboots kfly 5 3,886 04-25-2013, 07:31 AM
Last Post: kfly
  RIVA iPad string rendering bug? rbroders 5 4,570 07-30-2012, 08:56 PM
Last Post: rbroders
  Volume Knobs and Riva dogman 6 5,191 02-28-2012, 06:40 PM
Last Post: dogman
  iPhone, iPod Touch, and iPad RIVA Client 1.6 Submitted to app store SamVimes2 123 48,720 12-20-2011, 08:47 AM
Last Post: brianmount
  getting started with riva/ipad indygreg 7 8,829 08-06-2011, 10:04 AM
Last Post: indygreg

Forum Jump:

Users browsing this thread: 1 Guest(s)