Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error when trying to use Room Config - Auto Gen
#1
Error thrown immediately on clicking configure.
Version installed is 4.2.921

Title: Edit Room Configuration
Title2:
Line #: 2/0/0
Msg: An unhandled CIDLib exception was thrown by GUI code
Msg2: 0 is not a valid index for the TListWndBase object. Count=0

Not sure where to start. Any guidance would be appreciated.
Reply
#2
You must have found some way to confuse it. If you can first go to:

[cqc]\CQCData\SysCfg

and send me the RoomCfg.CQCRmCfg file I can try it here to see what is going on. But, in the meantime, just make sure that you have entries for everything that you have configured. I may not be enforcing something.

Given the type of error, it's likely something like enabling media but not selecting the devices, enabling security but not selecting a panel or area, something like that.
Dean Roddey
Explorans limites defectum
Reply
#3
This is the first time I have used the room config tool. When navigating to that directory it is empty.
Reply
#4
Oh, OK. That probably means something is awry that's only happening when there's no current configuration data. I try to test it from scratch periodically but probably didn't the last couple drops. I'll try it and see if I can reproduce it.
Dean Roddey
Explorans limites defectum
Reply
#5
OK, 4.2.922 fixes this issue.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  System Config Interface need DaveB 5 3,735 04-12-2017, 02:29 AM
Last Post: DaveB
  New room config based HTML client Dean Roddey 71 36,052 03-14-2017, 07:40 PM
Last Post: lleo
  client driver error after upgrade to 4.8.1 batwater 1 2,161 12-31-2015, 11:39 AM
Last Post: Dean Roddey
  Auto-Gen Issue Two finish.06 9 3,590 08-26-2014, 08:08 AM
Last Post: Dean Roddey
  Auto Gen Issue DaveB 6 2,909 08-22-2014, 07:36 AM
Last Post: dgilpin
  Auto-Generated Interface questions DaveB 40 15,683 08-16-2014, 03:29 PM
Last Post: DaveB
  Auto generation Error dpass 6 3,409 06-15-2014, 01:22 PM
Last Post: pbohannon
  Auto-gen error finish.06 6 3,139 06-10-2014, 02:32 AM
Last Post: finish.06
  Unknown Error pjgregory 2 2,220 05-16-2014, 06:08 AM
Last Post: Dean Roddey
  Media Repo Item Browser error pinballmark 10 6,185 09-03-2013, 05:00 PM
Last Post: pinballmark

Forum Jump:


Users browsing this thread: 1 Guest(s)