Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
918 AutoGen Issue
#11
I got it. I'll take a look at it today.
Dean Roddey
Explorans limites defectum
Reply
#12
OK, I see what's happening. The login popup is getting generated whethere security is enabled or not. It references the security panel, which of course never got set if security isn't enabled. The validation is correctly checking things, it's the generation code that's wrong.

In the last couple drops I added stuff to the security drivers that allows the auto-gen to ask it info about how the driver does arm/disarm commands, what it's arm modes are, etc... So now it's trying to access the security panel driver in that login popup generation, where before it wasn't.

Sorry about that.
Dean Roddey
Explorans limites defectum
Reply
#13
Dean Roddey Wrote:OK, I see what's happening. The login popup is getting generated whethere security is enabled or not. It references the security panel, which of course never got set if security isn't enabled. The validation is correctly checking things, it's the generation code that's wrong.

In the last couple drops I added stuff to the security drivers that allows the auto-gen to ask it info about how the driver does arm/disarm commands, what it's arm modes are, etc... So now it's trying to access the security panel driver in that login popup generation, where before it wasn't.

Sorry about that.

Nice to know I provided a service to the community! Wink

During my software writing days with fortran, it always took a complete novice hack to find the logic errors....As I'm really starting from scratch with my templates, I am now the hack ....

Bugman
Reply
#14
OK, give 4.2.920 a try.
Dean Roddey
Explorans limites defectum
Reply
#15
Dean Roddey Wrote:OK, give 4.2.920 a try.

OK. First thing tomorrow. My wife announced her retirement plans, so the wine is flowing......
Reply
#16
Dean: Just clicking on the Configure tab generates the following error.

Application: CQCClient
Module/Line: CIDCtrls_BaseListWnd.cpp.1674
CIDLib Error: 2
Kernel Error: 0
Host Error:0

Title: Edit Room Configuration
Title2:
Line #: 2/0/0
Msg: An unhandled CIDLib exception was thrown by GUI code
Msg2: 0 is not a valid index for the TListWndBase object. Count=0
Reply
#17
Wierd. It works fine for me. This is with the same config file you sent me? Just in case, can you delete (or rename) that sys config file and start it from scratch and see what happens? It's possible that, during all this interrim beta stuff that you've gotten the data whacked or something. I'd hate to spend a lot of time on it only to find out that's it.
Dean Roddey
Explorans limites defectum
Reply
#18
Dean Roddey Wrote:Wierd. It works fine for me. This is with the same config file you sent me? Just in case, can you delete (or rename) that sys config file and start it from scratch and see what happens? It's possible that, during all this interrim beta stuff that you've gotten the data whacked or something. I'd hate to spend a lot of time on it only to find out that's it.

Dean: I deleted the file (same one I sent you yesterday) and it still throws an error. Go figure

I'm working on Wuench's templates as my base template, and was just playing around with the autogen stuff, so please don't take this on as an urgent matter. I have a hunch that other crashes going on are somehow related, and will resolve itself with time as you work through the more urgent requests coming in.

Cheers,

Bugman
Reply
#19
:confused:


Dean: The thought of wacked data, got me thinking so I used a config file from a backup in January, and that worked with no errors. Go figure for sure!

Cheers,

Bugman
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  4.5.20 autogen calendar questions... this is just a curiusity thing...no issue per se SomeWhatLost 3 2,438 10-13-2014, 08:00 PM
Last Post: Dean Roddey
  Auto-Gen Issue Two finish.06 9 3,590 08-26-2014, 08:08 AM
Last Post: Dean Roddey
  Auto Gen Issue DaveB 6 2,907 08-22-2014, 07:36 AM
Last Post: dgilpin
  HttpClient issue resolving IP jkish 60 18,919 07-24-2013, 12:48 PM
Last Post: jkish
  916 and 920 calc issue bbrendon 9 3,662 04-07-2013, 09:51 PM
Last Post: Dean Roddey
  Timed field issue karenlee 6 2,845 02-21-2013, 03:47 AM
Last Post: karenlee
  3.3.6 driver issue rm1759 2 2,821 08-16-2010, 11:31 AM
Last Post: rm1759
  LAST issue I've found with Zoomplayer Roscoe62 0 1,751 05-03-2009, 12:31 AM
Last Post: Roscoe62
  2.0.11 IV issue, well maybe... might be something else... SomeWhatLost 11 5,525 01-27-2007, 01:42 PM
Last Post: Dean Roddey
  2.2.7 Theatertek driver issue I am having 0 577 Less than 1 minute ago
Last Post:

Forum Jump:


Users browsing this thread: 1 Guest(s)