Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XBMC Driver
#31
How do you use excel to edit MyMovies data?
Reply
#32
good question.

I can open the datbase in excel, but I have not found the trick to write it back to it.

I was hoping to be able to copy and paste back into SQL Management Studio Express, but I can only do a cell at a time there.

I need to ask the gurus that I work with about this one. THere may be another way to do it.

Using studio express for changes is much faster than using the interface though
Mykel Koblenz
Illawarra Smart Home
Reply
#33
I am having trouble in getting xbmc to play a file.

I am sending the field VideoPlayer_PlayFile
\\server\movies\kids\aladdin\aladdin.avi
I see the working symbol flash up on the screen and then nothing.

Sometimes I get an error message saying it cant play the file.

Is there a chance it is a version issue with xbmc? (pretty sure I installed 10.1)

By the way, have you seen the dedicated remote for xbmc and the media center PC based on the OpenELEC standard. I think this is the solution to CQC and a media center
http://www.pulse-eight.com/store/product...ybrid.aspx
http://www.pulse-eight.com/store/category/54-htpc.aspx

Mick
Mykel Koblenz
Illawarra Smart Home
Reply
#34
Turn up logging or turn on debug mode and see if you can see what the driver is changing that path too. XBMC takes SMB:// paths (and others UPNP:// HTTP://, NFS:// etc.), the driver tries to rewrite the URL to make it compliant. Also check the XBMC log and see what it says.
Wuench
My Home Theater/Automation Website

[THREAD=5957]BlueGlass CQC Config[/THREAD]
[THREAD=10624]Wuench's CQC Drivers[/THREAD]
Reply
#35
Be sure to suppress processing of the expanded path, otherwise those single slashes can create special characters, assuming you are sending that value from an action command.
Dean Roddey
Software Geek Extraordinaire
Reply
#36
Look at my templates, whatever I did there was working. I don't think I had to do any special processing in actions. I was just taking it from my movies and stuffing it into the driver field.
Wuench
My Home Theater/Automation Website

[THREAD=5957]BlueGlass CQC Config[/THREAD]
[THREAD=10624]Wuench's CQC Drivers[/THREAD]
Reply
#37
Thanks

I looked at your templates and you are passing the same thing I am (with assumptions)

I assume that the path from your mymovies databse is in for form of \\server\share\movie\movie.iso as you say you store iso files.

This should produce within CQC (the medialoc rtv) \server\share... with only one \ at the front.

is the driver compensating for this?

I have prepended the \, but that may be my mistake.

What would I type in the field browser for that field?

I have this movie \\server\movies\kids\aladdin\aladdin.avi

what is the syntax to manually start playing this file from the field browser (or command button action)

Mick
Mykel Koblenz
Illawarra Smart Home
Reply
#38
To do it manually from the field browser, enter that literal value as is, since no processing is done to the value you enter.

When you do it as an action command parameter, it's different because of all of the processing that's done to those, to allow you to use replacement tokens and such.
Dean Roddey
Software Geek Extraordinaire
Reply
#39
You need to check the logs to determine what is going on. The driver does do some processing because XBMC expects things to be in the SMB://xx/... format not \\xx\xx format. The XBMC log should tell you what it is getting and why it doesn't like it. The driver converts the slashes and if you don't specify a protocol it assumes SMB.

For example, I have the following in MyMovies:
\\AV-NAS\media\Movies\Iron Man 2\Iron Man 2.bluray.ISO

I pass that with the code I posted at the beginning of the thread, no action processing just pass it from MyMovies to the driver.

The XBMC log shows the following:
smb://av-nas/media/movies/iron man 2/iron man 2.bluray.iso
Wuench
My Home Theater/Automation Website

[THREAD=5957]BlueGlass CQC Config[/THREAD]
[THREAD=10624]Wuench's CQC Drivers[/THREAD]
Reply
#40
If you have \\server\... in mymovies, then why is CQC not removing one of the \ at the start of the string. It does on mine......

But, it is still not working for me!

Here is what was in the logs (set tp medium as you have a heap of logging when on high)

Code:
04/29 18:51:31-zeus.calderwood.net, CQCServer, CIDOrbSrvWorkThread_13
{
    CQCKit, MEng.System.CQC.Runtime.CQCLogger.115, Status/App Status
    StringFldChanged: Field Update for VideoPlayer_PlayFile Value:\\zeus\movies\Adult\Avatar\Avatar.avi
}

04/29 18:51:31-zeus.calderwood.net, CQCServer, CIDOrbSrvWorkThread_13
{
    CQCKit, MEng.System.CQC.Runtime.CQCLogger.115, Status/App Status
    StringFldChanged: Playing Item smb://zeus/movies/adult/avatar/avatar.avi
}

it produced an error on the xbmc screen and the driver lost connection. This does not happen every time, only about one in every five that the error is displayed on the screen.

Where do i find the log file on xbmc?

I would assume that it is not case sensitive.

When i play the file manually from the remote the field video_filename has a value of
http://192.168.0.22:8080/vfs/smb://Zeus/...Avatar.avi

Is this what you are seeing for this field when you play a file. It may have something to do with uPNP as I have that turned on.

What else can I try?

The commands are working OK(transport and direction)

Mick
Mykel Koblenz
Illawarra Smart Home
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Amazon Echo Hue Simulator Driver wuench 109 32,556 08-02-2018, 02:45 PM
Last Post: Dean Roddey
  Sony TV IP driver dogman 10 273 08-01-2018, 03:53 PM
Last Post: znelbok
  Generic Modbus Driver - Serial & IP znelbok 24 10,228 07-20-2018, 01:21 PM
Last Post: znelbok
  Sony Bravia TV Driver znelbok 12 1,126 06-11-2018, 09:19 AM
Last Post: Dean Roddey
  OpenHAB Driver whozeawhat 5 453 05-28-2018, 08:50 AM
Last Post: whozeawhat
  Pushbullet Driver whozeawhat 1 292 05-13-2018, 07:27 AM
Last Post: whozeawhat
  Monoprice Blackbird 4x4 HDMI Switcher - Driver request batwater 14 7,282 02-10-2018, 02:29 PM
Last Post: batwater
  LIFX Driver bobskie708 9 1,075 01-30-2018, 12:34 PM
Last Post: jkmonroe
  SNMP Driver wuench 115 264,587 01-01-2018, 05:18 PM
Last Post: Dean Roddey
  CBUS CGate Driver martinmcc 46 17,337 12-18-2017, 01:19 AM
Last Post: znelbok

Forum Jump:


Users browsing this thread: 1 Guest(s)