Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New install - Need help, Aprilaire 8870 driver not working
#1
Hi all,

I've taken the plunge and started my CQC install. I'm hitting Aprilaire 8870 driver issues (and Centralite Elegance XL connection issues, but I'll save that for a separate thread I guess). Here's the 8870 scoop:

I'm using the stock driver w/ the latest version of CQC.
I have no issue connecting with the 8811 & 8870's via Hyperterminal. Set up for Com2 (Serial port #1 on my Digi Edgeport 8). I have set the max addresses as 3 in the 8870 hardware by the way, and selected the first 3 addresses in the CQC driver.

When I use Hyperterminal I can type in commands and get quick responses. Ie, "SN?" gets me back the list of the 3 thermostats that I have (SN1, SN2, SN3), and "SN1 CR=Normal" comes back with a response & the thermostat name I gave that thermostat. The only reason I even typed "SN1 CR=Normal" was because I saw in the CQC log file that it had tried that & not received a response. Yet it worked for me when I did it in Hyperterminal!

Here's what appears to be the relevant portion of the log. I clipped the end which basically kept repeating the last 3 messages (bad thermo.., failed to reply to cmd.., error initing therm 1..).

Is there any chance "Bad Thermo address" could be related to me having previously given the 8870's custom names (ie, SN1 is tagged with "MasterBedroom", SN2 "Downstairs", etc)?

Thanks

----------------------------------------
{
CQCServer, CQCServer_DriverCtrl.cpp.126, Status/App Status
Reconfigure of driver Aprilaire8870 is completed
}
01/25 12:04:08-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCKit, CQCKit_DriverBase.cpp.2643, Status/App Status
Driver 'Aprilaire8870' is beginning initialization
}
01/25 12:04:08-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCKit, CQCKit_DriverBase.cpp.2789, Status/App Status
Driver 'Aprilaire8870' is trying to get its comm resource
}
01/25 12:04:08-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCKit, CQCKit_DriverBase.cpp.2827, Status/App Status
Driver 'Aprilaire8870' has its comm resource
}
01/25 12:04:08-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCKit, CQCKit_DriverBase.cpp.2845, Status/App Status
Driver 'Aprilaire8870' is trying to connect to its device
}
01/25 12:04:08-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCGenDrvS, MEng.System.CQC.Drivers.Aprilaire.Thermo8870.DriverImpl.343, Status/App Status
Bad Thermo address in incoming message
}
01/25 12:04:12-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCGenDrvS, MEng.System.CQC.Drivers.Aprilaire.Thermo8870.DriverImpl.1153, Status/App Status
Can't determine thermo 1 type. Assuming temp controller
}
01/25 12:04:12-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCGenDrvS, MEng.System.CQC.Drivers.Aprilaire.Thermo8870.DriverImpl.343, Status/App Status
Bad Thermo address in incoming message
}
01/25 12:04:18-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCGenDrvS, MEng.System.CQC.Drivers.Aprilaire.Thermo8870.DriverImpl.813, Status/App Status
Failed to reply to cmd: SN1 CR=NORMAL
}
01/25 12:04:18-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCGenDrvS, MEng.System.CQC.Drivers.Aprilaire.Thermo8870.DriverImpl.896, Status/App Status
Error initing thermo 1, marking it offline. Err=Timed out waiting for a message
}
01/25 12:04:18-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCKit, CQCKit_DriverBase.cpp.2886, Status/App Status
Driver 'Aprilaire8870' has connected to its device
}
01/25 12:04:21-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCGenDrvS, MEng.System.CQC.Drivers.Aprilaire.Thermo8870.DriverImpl.343, Status/App Status
Bad Thermo address in incoming message
}
01/25 12:04:26-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCGenDrvS, MEng.System.CQC.Drivers.Aprilaire.Thermo8870.DriverImpl.813, Status/App Status
Failed to reply to cmd: SN1 CR=NORMAL
}
01/25 12:04:26-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCGenDrvS, MEng.System.CQC.Drivers.Aprilaire.Thermo8870.DriverImpl.896, Status/App Status
Error initing thermo 1, marking it offline. Err=Timed out waiting for a message
}
01/25 12:04:29-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCGenDrvS, MEng.System.CQC.Drivers.Aprilaire.Thermo8870.DriverImpl.343, Status/App Status
Bad Thermo address in incoming message
}
01/25 12:04:34-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCGenDrvS, MEng.System.CQC.Drivers.Aprilaire.Thermo8870.DriverImpl.813, Status/App Status
Failed to reply to cmd: SN1 CR=NORMAL
}
01/25 12:04:34-Server-PC, CQCServer, CQCDrv_Aprilaire8870_Thread3
{
CQCGenDrvS, MEng.System.CQC.Drivers.Aprilaire.Thermo8870.DriverImpl.896, Status/App Status
Error initing thermo 1, marking it offline. Err=Timed out waiting for a message
}
Reply
#2
See this thread: http://www.charmedquark.com/vb_forum/sho...051&page=5

The names sound like the problem.
Reply
#3
jkish Wrote:See this thread: http://www.charmedquark.com/vb_forum/sho...051&page=5

The names sound like the problem.

Thanks! That was the issue. I removed the names and it's working.

Now to figure out how to get the Centralite EleganceXL driver functioning! Similar topline issue in that I have it verified working via Hyperterminal but have no luck operating it via the CQC driver. I'll search the forums a bit more before posting a new thread.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  CQC to PowerView Hub via Serial Driver Deane Johnson 18 734 05-14-2018, 01:11 PM
Last Post: Deane Johnson
  Aprilaire T-Stats Issues avtexan 5 565 04-17-2018, 06:07 PM
Last Post: khill
  HAI Driver Issue avtexan 6 694 04-06-2018, 02:06 PM
Last Post: Dean Roddey
  Echo integration still working for folks? IVB 5 588 01-15-2018, 06:18 PM
Last Post: IVB
  Install Error []dll is missing ControlFreak 2 1,465 11-05-2017, 02:18 PM
Last Post: ControlFreak
  CQC fresh install kfly 12 2,371 10-07-2017, 04:51 PM
Last Post: Dean Roddey
  Anyone try a multi-site HA install using a VPN? IVB 17 4,876 09-06-2017, 01:18 AM
Last Post: NightLight
  Monoprice 8x8 HDMI matrix Driver NightLight 13 2,954 09-04-2017, 09:45 AM
Last Post: Dean Roddey
  ELK V2 Driver - AreaArm field & Triggers? sic0048 4 1,115 08-19-2017, 04:46 PM
Last Post: Dean Roddey
  UPB Driver Issue tcmcgec 6 2,191 01-27-2017, 07:18 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)