Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Client Side Driver Directory Could Not be Cleaned Out"
I installed 5.2.3 in my master server (which runs only CQC and the Upstart configuration when needed), and that part of the install is fine. 

I put 5.2.3 on a new laptop (running Win10 Pro) that replaced an old laptop that I use/will use for most of my event and interface configuration and changes (since the master server is not as convenient).  On the laptop, I enabled only the management function, device control (even thought there are no devices connected to the laptop), the interface viewer, and the tray monitor.  Whenever I try to open the AI, I get a message from "Admin Intf" that "The client side drive could not be cleaned out.  That typically occurs when CQC is not running locally.  You could end up running out of date client side driver interfaces."

I make sure (from the tray monitor) that both the client service and app shell are running before trying to start the AI but I still get the message on my initial attempt to open the AI.  If I click OK, the AI opens, and if I then close the AI, I don't usually get the message on a subsequent opening of the AI.  If I try to open the interface viewer on the new laptop it does not seem to be a problem--it seems to happen just with the AI.  I have virtually every CQC .exe file protected in Windows Defender, and while I also have Bitdefender on the laptop (but not on the master server), it does not seem to be a firewall issue since I can get to the AI if I click OK.

Is this a problem?  What does it mean?  Does it refer to client side driver interfaces on the laptop (none) or client side driver interfaces on my master server (eg Elk)? 

Any thoughts?

It would sort of have to be that the client service's port is being blocked. The reason it happens is that the AI cannot directly do things in the program files area, at least not without having to do a user rights popup. So, for the couple things it needs to do it asks the client service to do them, since it can do that. One of the things it wants to do when it starts is clean up any client side drivers it has downloaded, so that it has to get fresh ones in case they have changed. If it can't talk to the client service, it can't do that.

The AI is the only program that does that. Others talk to to the client service but usually only if media management is involved. The IV only talks to it if you are using media related widgets for instance. So otherwise it wouldn't be bothered by not being able to get to the client service.

The client service's port is 13520, so make sure it's available.

I hope that msg was a paraphrase, else I didn't do a very good job on it. I'll update it to give some better hints as to what might be the issue.
Dean Roddey
Explorans limites defectum
Dean, thanks.

I confirmed that port 13520 is open and listening on the master server, which is not a surprise since I have not had any problems with it in the past.  I also made sure via both the tray monitor and Windows task manager that the the CQC Client Service is running on the master server. 

What is a bit odd is that the error message (and, yes, what I quoted was pretty much verbatim) is intermittent.  I was looking for some kind of consistency in when it appeared (eg first attempt at AI access), but I get it on a seeming random basis when accessing the AI.  I also get the same message on a desktop machine that I loaded 5.3.2 onto.

I did note that whenever the error appears, this appears in the log monitor:  Process:  CQCAdmin, Line: 259, Message Text:  Loading a client driver in test mode, but no resource dir found in environment."  It seem similar to the same issue described in the last few posts of this thread about the ISY994i .

What exactly does "any client side drivers it has downloaded" mean?  I guess I have assumed that the client interface of device drivers is what is at play here, and the AI seems to think it can't access the client interface or that it may not be current.  Is that correct?  The only drivers I have with client interfaces are Elk, HTTP, and a Variable Driver, and I rarely change the actual configuration of them.  But if the AI needs to pull down a current status of something (eg a zone or output status from Elk), do I run the risk of getting out of date info?

The client service runs on all machines, so it needs to be running on the client (and accessible.) It only serves local CQC programs on that machine. So make sure it's good on the client.

The reason this is happening is what I described above. When the AI runs, it wants to be sure it downloads the latest DLLs and resources for any client side driver interfaces. So it wants to empty out that directory where it downloads such things. It can't do that directly (since they are under Program Files) without invoking a security prompt, so it asks the client service to do it. That is happening locally on the client, not on the MS. This is where the AI downloads client side drivers to the local machine (from the MS) when it needs them.

Even if you have no client side drivers in use, the AI doesn't care. It's just asking that anything in the directory be removed. That will insure a download of fresh bits if you do load any that have previously been loaded on that machine.

If it can't clear the directory, the AI will just use what is already there, which could be out of date.
Dean Roddey
Explorans limites defectum
I've checked, and at least according to the tray monitor and to the task manager services listing, the CQCClService is running.  And, as noted, I see the same problem on my "old" laptop and on a trial desktop that I put CQC on in order to try to access the AI.  I get the error message on all three client machines, yet I can confirm on each of the three of them that the client service is running before I attempt to open the AI.

Is the directory on a local machine where the AI wants to download the DLLs and other resources for the client side drivers visible and/or accessible?  I took a peek at all the folders in the CQC directory and didn't see anything that looked out of place, but is there someplace where I can look before trying to open the AI to see what's there?

I ask because I started wondering if something was somehow blocking the AI from either seeing or cleaning out the affected client side directory on the local machine.  If so, I should be able to create an exception for that directory--though I have every CQC .exe program listed excepted.

Thanks again.
The AI isn't doing it, it's trying to ask the client service to do it. But presumably the client service on those machines is being blocked, so the AI can't talk to it. Make sure that the there's nothing on those machines blocking the client service's port, which is 13520.
Dean Roddey
Explorans limites defectum
I don't see anything else on 13520 (using netstat--is there a better way?), and it wasn't a problem before 5.3.2 on any of these machines.

I'm currently testing changing "log on" for the CQCClService from a local account to my specified user account, and so far that SEEMS to work but I've only tried it once and the error has been inconsistently appearing. 

I know you have, in the past, said some things about local account so I was searching the forums for prior wisdom on the issue.
There shouldn't be any need to change from the local account for the client service. One one of the machines where it's not working, open the CQC Command Prompt and do:

cqcnettest > nt.txt

and post the nt.txt file contents.
Dean Roddey
Explorans limites defectum
Dean, thanks again for your help. 

The file is below. 

Two things:  First, I changed back to the normal log on account.  Second, I had a suspicion that possibly Bitdefender was causing the problem, so I uninstalled it completely (with a reboot) before running cqcnettest.  Even so, the error (1006/0/0) appears. 

And when I run TCPView, I get only this for port 13520

CQCClService.exe    12508    TCP    Laptop    13520    Laptop    0    LISTENING                                        
CQCClService.exe    12508    TCPV6    laptop    13520    laptop    0    LISTENING                                        

.txt   nt.txt (Size: 4.15 KB / Downloads: 1)
OK, it definitely isn't able to connect to the client service. The two ports you found are it listening on the IPV4 and IPV6 interfaces, which is as it should be. And it also is registered in the name server, so it's obviously up and running well enough to do that. Is anything showing up in the log server from these guys?

Given that the ports are open, it registered itself, the registered info got us to the right IP address, but even the simple net test client cannot connect, would seem to almost guarantee that the port is blocked for some reason. Normally I would have though that maybe you are getting bitten by the name lookup bug that was introduced in Windows 1803, but the name resolution is working correctly and the laptop name is being resolved to its own IPV6 address.

Note that it is using IPV6, not IPV4, so make sure that the port isn't blocked on the IPV6 interface. Normally you would want it to use IPV6, but you could test whether it's an IPV4/6 thing by adding the laptop's IP4 address to the hosts file on the laptop itself, so that any local resolution its own name will resolve to the IPV4 address. That would force the programs talking to the client service to connect via IPV4.

That might be worth doing just as a test. Restart the laptop after updating the hosts files just to be sure. If that gives a different result, we know it must be something about the IPV6 address. If not, then we know it's not and you can remove the entry. Run the net test after it comes up and let's see what happens (and that will tell us for sure if it resolved to the IPV4 address.)

I'm sort of curious because we get an IPV4 address when we resolve the MS' name. Do you have IPV6 disabled on the MS by any chance?
Dean Roddey
Explorans limites defectum

Possibly Related Threads...
Thread Author Replies Views Last Post
  New Z-Wave driver preview Dean Roddey 152 12,695 07-15-2019, 04:56 PM
Last Post: kfly
  SMS Driver gReatAutomation 12 122 07-14-2019, 07:01 AM
Last Post: gReatAutomation
  Global Cache Driver gReatAutomation 4 124 07-06-2019, 05:08 PM
Last Post: gReatAutomation
  ELK M1 Client Interface question lleo 1 154 06-12-2019, 08:15 AM
Last Post: Dean Roddey
  Somfy RTS Driver jokermac 4 359 05-29-2019, 10:16 AM
Last Post: Dean Roddey
  Problem with B&K Driver / Keypad kblagron 9 888 03-19-2019, 12:00 PM
Last Post: kblagron
  Problem with EventGhost Driver batwater 2 354 03-17-2019, 12:42 PM
Last Post: Dean Roddey
  Zigbee Driver adamalli 12 1,388 01-17-2019, 06:20 AM
Last Post: CouchPotatoe
  why master server needs DHCP client running? lleo 4 648 01-04-2019, 01:13 PM
Last Post: Dean Roddey
  Elk Client Interface Gremlins IVB 9 937 12-23-2018, 08:58 PM
Last Post: IVB

Forum Jump:

Users browsing this thread: 1 Guest(s)