Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Triggered Event Server not triggering
#1
I have made no changes to my triggers and now they do not trigger.  I just upgraded to the most recent version but I think this was occurring before that.  

I have many Is Field Change For triggers and I can't get them to trigger.  I haven't tested them all but the important one (HVAC) are not triggering.  

I set up a test event...Is Field Change For ...my one of my lights.  Set the Trigger in the Devices and made a simple Action to text me and change a variable.  Also clicked Log invocation.  None of those occurred.  

I then used Fld Value Equals for the simple test of a variable in the var driver change with the same actions and Log and it did not fire.

I will say the Timed Events do occur. Once again I haven't checked all my Triggered ones

I have stopped CQC and restarted to no avail.
System: WHS, UPB, Plex, Elk
Drivers: Autopatch, DataLog DB, DTV IP, GC-100, IRA, Logic Server, Variable Driver, Weather Underground
Reply
#2
The first step would be to run the Admin Intf on the master server and go to /System/Monitor and in open the tab to monitor event triggers. Do something that should cause a trigger and see if it shows up there. If it doesn't then the issue has be either on the sending end, or the reception of the sent trigger. If it does, then the issue has to be on the receiving (event server) side. So that's a good divide and conquer strategy to see which direction to look.

For lights in any V2 compliant driver, you don't need to (and shouldn't) use field change type triggers. Light switches send out standard triggers that you can use. Putting a generic field change on light switch fields of that sort is redundant and just a lot of extra system overhead. But, if you have put a regular trigger on them, they should trigger.
Dean Roddey
Software Geek Extraordinaire
Reply
#3
I should have said in the initial post... The triggers were showing up on the event server log...on the client side though, if that matters.

My lighting is UPB... So we established before they don't send out a trigger on their own.
System: WHS, UPB, Plex, Elk
Drivers: Autopatch, DataLog DB, DTV IP, GC-100, IRA, Logic Server, Variable Driver, Weather Underground
Reply
#4
Run the monitor on the master, since that's where the event server lives. It's good to know they show on the client side, since we know then that they are getting sent. So let's see if they are being received on the master as the next step.
Dean Roddey
Software Geek Extraordinaire
Reply
#5
The triggers were showing up on the master server also. I decided to reinstall CQC from scratch and it seems to be working now. Not sure how if failed on the other instsall but all is good again.
System: WHS, UPB, Plex, Elk
Drivers: Autopatch, DataLog DB, DTV IP, GC-100, IRA, Logic Server, Variable Driver, Weather Underground
Reply
#6
Are you sure you upgraded all the systems before?
Dean Roddey
Software Geek Extraordinaire
Reply
#7
Yes...I only have a master and a client. I made no changes to the master...just kept clicking next to upgrade like I always have.
System: WHS, UPB, Plex, Elk
Drivers: Autopatch, DataLog DB, DTV IP, GC-100, IRA, Logic Server, Variable Driver, Weather Underground
Reply
#8
Well...it's back to not working. It happened the other day, rebooted CQC and it started working. Same thing today.

Once again, Event Server is capturing the Field Change but the Action is not kicking off. My HVAC uses this and it's either not turning off or not turning on.

A simple test was Field Change For a variable driver T/F value and action to change another variable driver text value. If I change the T/F field, then the text will change. This does not occur. It works after rebooting.
System: WHS, UPB, Plex, Elk
Drivers: Autopatch, DataLog DB, DTV IP, GC-100, IRA, Logic Server, Variable Driver, Weather Underground
Reply
#9
How do you know it's capturing the field change? Do you have that action set up to log when it is run or something and you see that log msg in the logs?
Dean Roddey
Software Geek Extraordinaire
Reply
#10
From the event trigger log.

I have the variable driver boolean field set to trigger when the value changes. This is being captured in the event log on the master server. I have the trigger event to log invocation, prior to the reboot, this was never logged. After the reboot, it started logging.

The event log sees the field change but the trigger event is not seeing this and therefore not firing any event that requires a field change.
System: WHS, UPB, Plex, Elk
Drivers: Autopatch, DataLog DB, DTV IP, GC-100, IRA, Logic Server, Variable Driver, Weather Underground
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Logic Server bad events rbroders 1 289 10-14-2018, 09:59 PM
Last Post: Dean Roddey
  Logic Server Math kblagron 6 619 09-27-2018, 01:06 PM
Last Post: Dean Roddey
  The server did not reply to the 'rset' request indygreg 3 608 07-26-2018, 11:22 AM
Last Post: Dean Roddey
  Triggered Event Questions RichardU 3 505 07-14-2018, 03:53 PM
Last Post: Dean Roddey
  Logic Server Field Limit zra 6 788 07-10-2018, 12:44 PM
Last Post: zra
  Triggered event w/ multiple triggers lleo 16 1,415 06-06-2018, 06:21 PM
Last Post: lleo
  Security Server could not be contacted Shaky 2 464 05-21-2018, 10:29 PM
Last Post: Shaky
  Redid server, issues with Nest and Elk ghurty 6 802 05-16-2018, 05:15 PM
Last Post: Dean Roddey
  Moved my Master Server. Now no External Access RichardU 2 742 04-14-2018, 08:21 PM
Last Post: RichardU
  CQC Server network issues znelbok 1 610 03-20-2018, 12:36 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)