Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Official 5.4 Beta Discussion Thread
#21
Oh, OK, the dual sensor thing. That's why I saw it send one thing, and the we saw it send another after I created the device info file. I wasn't wrong, it was just another sensor. It's apparently using two different msgs one for each, which is so stupid and against the Z-Wave standard. They are supposed to be multi-channel, same with the Aeotec multi-sensors.

OK, so we need to make sure which is which, and that's going to require a special handler since that's a scenario not currently supportable I don't think, with any of the existing handlers and the configuration options they have. It works sort of like the Aeotec multi-sensors, but they wouldn't be compatible with that handler.

So, get me a trace where you first trigger one sensor, and then trigger the other, and make sure we know which one is which. Then I'll have to add a handler for that type of thing.

On the GE unit, maybe I got the ids slightly wrong or something. I'll check it.

I'll try again on the write only switch. I'll have to try to come up with a way to simulate that scenario. I may have an old ACT switch lying around from the old days.
Dean Roddey
Software Geek Extraordinaire
Reply
#22
Which GE unit are we talking about? If it's the 14294 GE/Jasco, I have the ids you reported in the dump. Did we get the wrong one or something? The dump you sent had the id values as 63 4944 3038. If you do a query info on that guy again, do you see those ids?
Dean Roddey
Software Geek Extraordinaire
Reply
#23
It's the 14294. I cannot query the unit with it configured. I get a dialog box with an error stating "The Query process failed... The non-secured classes could not be gotten" How do I "unconfigure" the unit? I cannot rescan so cannot re-enable.

The 1 WADWAZ door sensor I had enabled is now not responding.

Actually the whole driver is now off line, I cannot access any of the devices.
Reply
#24
I tried pausing and re-enabling the driver, some function came back.  GE 14294 is now showing "GetManInfo" but it won't return anything when I do a scan.  Enabled WADWAZ still showing ??? for fields. A long trace attached.


Attached Files
.txt   Trace.Txt (Size: 65.24 KB / Downloads: 0)
Reply
#25
It's just not able to communicate reliably. You should be able to query the info at any time, so it's being assigned a type isn't related to that. The fact that it gets to GetManInfo and gets stuck would also tend to indicate it just can't talk reliably to the unit. If you leave it it may eventually get lucky since it keeps trying for wall powered units. Leave it a bit and see what happens.
Dean Roddey
Software Geek Extraordinaire
Reply
#26
Actually, it would be useful at this point to reset the trace, and let it collect for thirty minutes or so, then stop it and send me the output. Let's see what's going on with the ones that are retrying.
Dean Roddey
Software Geek Extraordinaire
Reply
#27
Dean, I had to stop working on this. Next opportunity is 2 weeks out for me.
Reply
#28
(07-08-2018, 06:20 AM)batwater Wrote: Dean, just installed, this does not address the issue with the ACT light switch, still getting a dialog with "Value couldn't be written to the field, see logs for more detail" error

OK. My fix was correct in the last drop, but I missed one example, and of course it was the one you hit. So that should be happy next time.
Dean Roddey
Software Geek Extraordinaire
Reply
#29
Great, thanks Dean. On the road so not urgent, still have control via the v1 driver.
Reply
#30
I also wrote yesterday a new unit handler class for 'dual binary sensor' type units of the non-multi-channel kind. I can't actually test that currently. I might have to order one of those waz thingies in order to test it.
Dean Roddey
Software Geek Extraordinaire
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Official 5.4 Release Thread Dean Roddey 0 45 07-05-2018, 12:45 PM
Last Post: Dean Roddey
  Official 5.3 Beta Discussion Thread Dean Roddey 815 47,606 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.3 Release Thread Dean Roddey 27 2,757 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.2 Beta Discussion Thread Dean Roddey 244 49,765 10-14-2017, 07:57 PM
Last Post: Dean Roddey
  Official 5.2 Beta Release Thread Dean Roddey 13 5,164 10-09-2017, 06:49 PM
Last Post: Dean Roddey
  Official 5.1 Beta Discussion Thread Dean Roddey 453 118,944 05-16-2017, 03:45 PM
Last Post: Dean Roddey
  Official 5.1 Beta Release Thread Dean Roddey 28 12,396 05-12-2017, 05:44 PM
Last Post: Dean Roddey
  Official 5.0 Beta Discussions Dean Roddey 2,019 309,476 11-09-2016, 04:34 PM
Last Post: Dean Roddey
  Official 5.0 Beta Release Thread Dean Roddey 15 10,042 11-01-2016, 10:32 AM
Last Post: Dean Roddey
  How to obtain Beta versions? willsauter 3 2,381 07-15-2016, 04:57 PM
Last Post: willsauter

Forum Jump:


Users browsing this thread: 1 Guest(s)