Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RCS V2 Driver
#1
Dean,

You had mentioned on a previous post about being interested in my inability to connect using the RCS V2 driver.  I have posted the logs in high verbosity, but not sure if it is going to tell you much.  The driver connects, but no RCS data is populated to it, and then it will lose connection after a few minutes, then reconnect with the same results.

I am using V 1.9 driver from Kirk Kanak, and it works fine.  I did make one slight change to that driver because it was giving 5-6 bad messages per minute when I initially used it.  Maybe that is the problem.   I am comfortable using the other driver, so there is no need to do anything based on my input.

I have two RCS units, and two serial drivers installed:

RCS ZCV4 - Version V01.06.02  - Controls two zones with damper, although able to control 4, if needed
RCS  TR80 - (No Version Shown) - Controls one zone

Code:
06/07 00:50:33-CQCSERVER, CQCServer, CIDOrbSrvWorkThread_1
{
   CQCServer, CQCServer_DriverCtrl.cpp.202, Status/App Status
   A request to resume driver HVACTest was received, starting operation
}
06/07 00:50:34-CQCSERVER, CQCServer, CQCDrv_HVACTestThread8860
{
   CQCKit, CQCDriver_DriverBase.cpp.3298, Status/App Status
   Driver 'HVACTest' is beginning initialization
}
06/07 00:50:34-CQCSERVER, CQCServer, CQCDrv_HVACTestThread8860
{
   CQCGenDrvS, MEng.System.CQC.Drivers.RCS.SerialRS485V2.DriverImpl.849, Status/App Status
   Could not parse the source names prompt value
}
06/07 00:50:34-CQCSERVER, CQCServer, CQCDrv_HVACTestThread8860
{
   CQCKit, CQCDriver_DriverBase.cpp.3445, Status/App Status
   Driver 'HVACTest' is trying to get its comm resource
}
06/07 00:50:34-CQCSERVER, CQCServer, CQCDrv_HVACTestThread8860
{
   CQCKit, CQCDriver_DriverBase.cpp.3484, Status/App Status
   Driver 'HVACTest' has its comm resource
}
06/07 00:50:34-CQCSERVER, CQCServer, CQCDrv_HVACTestThread8860
{
   CQCKit, CQCDriver_DriverBase.cpp.3502, Status/App Status
   Driver 'HVACTest' is trying to connect to its device
}
06/07 00:50:40-CQCSERVER, CQCServer, CQCDrv_HVACTestThread8860
{
   CQCKit, CQCDriver_DriverBase.cpp.3544, Status/App Status
   Driver 'HVACTest' has connected to its device
}
06/07 00:51:45-CQCSERVER, CQCServer, CIDOrbSrvWorkThread_3
{
   CQCServer, CQCServer_DriverCtrl.cpp.202, Status/App Status
   A request to pause driver HVAC2 was received, starting operation
}
06/07 00:52:26-CQCSERVER, CQCServer, CQCDrv_HVACTestThread8860
{
   CQCKit, CQCDriver_DriverBase.cpp.7255, Status/Lost Connection
   Driver 'HVACTest' has lost connection to it's device
}
06/07 00:52:29-CQCSERVER, CQCServer, CQCDrv_HVACTestThread8860
{
   CQCKit, CQCDriver_DriverBase.cpp.3502, Status/App Status
   Driver 'HVACTest' is trying to connect to its device
}
06/07 00:52:35-CQCSERVER, CQCServer, CQCDrv_HVACTestThread8860
{
   CQCKit, CQCDriver_DriverBase.cpp.3544, Status/App Status
   Driver 'HVACTest' has connected to its device
}
06/07 00:52:49-CQCSERVER, CQCServer, CIDOrbSrvWorkThread_4
{
   CQCServer, CQCServer_DriverCtrl.cpp.147, Status/App Status
   Remote client forcing load of driver. Moniker=HVACTest2. M/M/V=RCS/TR16/TR40-V2/1.0
}
06/07 00:52:49-CQCSERVER, CQCServer, CQCDrv_HVACTest2Thread8866
{
   CQCGenDrvS, MEng.System.CQC.Drivers.RCS.SerialRS485V2.DriverImpl.849, Status/App Status
   Could not parse the source names prompt value
}
06/07 00:53:40-CQCSERVER, CQCServer, CQCDrv_HVACTestThread8860
{
   CQCKit, CQCDriver_DriverBase.cpp.7255, Status/Lost Connection
   Driver 'HVACTest' has lost connection to it's device
}
06/07 00:53:43-CQCSERVER, CQCServer, CQCDrv_HVACTestThread8860
{
   CQCKit, CQCDriver_DriverBase.cpp.3502, Status/App Status
   Driver 'HVACTest' is trying to connect to its device
}
06/07 00:53:49-CQCSERVER, CQCServer, CQCDrv_HVACTestThread8860
{
   CQCKit, CQCDriver_DriverBase.cpp.3544, Status/App Status
   Driver 'HVACTest' has connected to its device
}
06/07 00:54:43-CQCSERVER, CQCServer, CQCDrv_HVACTest2Thread8866
{
   CQCKit, CQCDriver_DriverBase.cpp.7255, Status/Lost Connection
   Driver 'HVACTest2' has lost connection to it's device
}
06/07 00:54:46-CQCSERVER, CQCServer, CQCDrv_HVACTest2Thread8866
{
   CQCKit, CQCDriver_DriverBase.cpp.3502, Status/App Status
   Driver 'HVACTest2' is trying to connect to its device
}
06/07 00:54:51-CQCSERVER, CQCServer, CQCDrv_HVACTest2Thread8866
{
   CQCKit, CQCDriver_DriverBase.cpp.3544, Status/App Status
   Driver 'HVACTest2' has connected to its device
}
06/07 00:55:15-CQCSERVER, CQCServer, CIDOrbSrvWorkThread_3
{
   CQCKit, CQCDriver_DriverBase.cpp.1443, Failed/Not Ready, Error: 906/0/0
   Driver 'HVAC1' is not currently connected to its device
     <CQCServer> CIDOrb_ThisFacility.cpp - 536
     <CQCServer> CQCKit_CQCSrvAdminClientProxy.cpp - 586

}
06/07 00:55:19-CQCSERVER, CQCServer, CQCDrv_HVACTest2Thread8866
{
   CQCKit, CQCDriver_DriverBase.cpp.7255, Status/Lost Connection
   Driver 'HVACTest2' has lost connection to it's device
}
06/07 00:55:22-CQCSERVER, CQCServer, CQCDrv_HVACTest2Thread8866
{
   CQCKit, CQCDriver_DriverBase.cpp.3502, Status/App Status
   Driver 'HVACTest2' is trying to connect to its device
}
06/07 00:55:27-CQCSERVER, CQCServer, CQCDrv_HVACTest2Thread8866
{
   CQCKit, CQCDriver_DriverBase.cpp.3544, Status/App Status
   Driver 'HVACTest2' has connected to its device
}
Reply
#2
It looks like it's not happy with something in the manifest. That's something I can test without having to connect to yours probably, so let me take a look at that.
Dean Roddey
Software Geek Extraordinaire
Reply
#3
OK, this should be happy in 5.2.918.
Dean Roddey
Software Geek Extraordinaire
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  New Z-Wave driver preview Dean Roddey 13 1,034 05-17-2018, 01:02 PM
Last Post: Dean Roddey
  Sonos Driver with Sonos Connect Amp zra 5 278 05-05-2018, 09:43 AM
Last Post: Dean Roddey
  Radio RA driver issue dogman 7 383 04-22-2018, 08:33 AM
Last Post: Dean Roddey
  Elk Driver fails Ron Haley 11 707 03-08-2018, 07:28 PM
Last Post: Ron Haley
  Nest driver disconnecting and reconnecting dogman 59 5,375 03-08-2018, 05:23 PM
Last Post: dogman
  Aeotec USB stick, existing zWave (v3) driver? IVB 3 316 03-05-2018, 08:57 PM
Last Post: znelbok
  Problem with Jetstream Driver RichardU 16 1,076 02-27-2018, 03:05 PM
Last Post: batwater
  Problem with fooBarV2 driver pjgregory 2 369 02-21-2018, 01:01 PM
Last Post: Dean Roddey
  Does GC-100 Driver Support Tri-Port Cable? Jnetto 18 1,742 01-29-2018, 08:16 AM
Last Post: RichardU
  SSL certificate for HTTP trigger driver RichardU 7 640 01-16-2018, 09:50 AM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)