Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Jandy Pool Control
#11
It's not seeming to have any issues communicating. But the actual loss of connection wasn't captured, so I'm not sure what went on. Try it again. Make sure it's up, flush the logs, then put it into high verbosity and wait for it to fail. Try to catch it pretty soon after that, and let's see if I can catch the failure.

But, when it connects, it sends a bunch of messages and all that goes fine. So it doesn't seem to be anything basic. Somewhere down the line something else must be happening once in a while.
Dean Roddey
Software Geek Extraordinaire
Reply
#12
My experience has been this.  I could never get the 2.2 driver to connect, and the shipped 1.3  driver didn't stay connected long and would cycle. I now use the 1.2 driver and it has always worked great.  My model no. Is 6521.

Edit - the 2.2 driver was actually posted as 2.8 in the thread listed before at the end, but I think the manifest wasn't updated, so it shows 2.2

Edit 2 - The driver I use that works for me with the 6521 panel is this: 

 http://www.charmedquark.com/vb_forum/sho...hp?tid=257

I am not sure what the difference is between the shipped version (1.3) and this one, but something causes 1.3 to disconnect with my panel.

I wanted to use the 2.8 version, but never had any success getting it to work, although others like AVTexan did - I just figured it was because I had a 10 year old panel.
Reply
#13
(05-27-2018, 07:11 PM)kblagron Wrote: My experience has been this.  I could never get the 2.2 driver to connect, and the shipped 1.3  driver didn't stay connected long and would cycle. I now use the 1.2 driver and it has always worked great.  My model no. Is 6521.

I stand corrected - now all 3 drivers work fine - I decided to check them just to make sure I had all the info correct on the previous post.  The only reason I can think this is working now is because I changed out the Master Server with a different computer because the comm port quit working, and I had assumed it was affected by a lightning strike.  I have a Digilite 16 port comm server and also the 1 comm port on the CQC server.  None of these were working well or at all, and once I switched the server CPU, everything started working.
Reply
#14
Attached is updated logs.  I let them run for a couple of cycles.

Thanks!!!

EDIT: I tried to import the 1.2 driver and I got this error: The package is too old to import into this CQC system.


Attached Files
.docx   Jandy Logs II.docx (Size: 12.54 KB / Downloads: 0)
Reply
#15
I saw the error: Jandy2.8 ProcessData: Can't convert '714 LOW' to a MEng.Float8 binary form

So I changed the battery in my equipment and it seems stable so far.

Thoughts?
Reply
#16
Oh, maybe the reply includes extra data that the driver didn't know was going to be there. It doesn't remove that since it doesn't know it's there, and that causes it to fail because it tries to convert the whole thing to a number. I assume the LOW must be a low battery warning. Maybe it appends that onto all or some messages or something and the driver doesn't know that since whoever wrote it never had a low battery while testing it.

Keep an eye on it. If it continues to work, we can try to figure out where that info may show up and get rid of it.
Dean Roddey
Software Geek Extraordinaire
Reply
#17
My panel has a place for a battery but apparently the installer never installed it.  Anyway, glad to see you got it working, and also glad to see that the shipped driver and the updated one also work on my system.  I will definitely go to the shipped driver, and then figure out if the later one that was written provides any useful fields.

Regards,
Blake
Reply
#18
OK the driver has been running fine since I changed the battery on 5/28.

Stats:
Lost Conn: 0
Timeouts: 39
Unknown Messages: 1,984

Does the driver need an update to receive that message?
Not sure what the unknown messages are or the timeouts.

Also when it shows the battery volts it carries to 5 decimal places (8.92000).
Can that be shortened?

Can I shorten that in CQC when I show the field?
Reply
#19
The driver would have to be updated. We'd have to know on what messages it actually appends that value. Is is all of them, or just that one? Unknown messages are presumably just things that the device sends that it doesn't handle. It probably shouldn't really count ones that it knows it doesn't handle, but that might be more effort than it's worth.

To display floating point values and control them use a Numerical Text widget instead of a basic Field Text widget. That gives you control over the numeric format.
Dean Roddey
Software Geek Extraordinaire
Reply
#20
I had mentioned in an earlier post that the shipped version and the latest development driver were working, and they do, but drop connections every few minutes and then reconnect - my guess is, they probably are getting some messages they don't like either. I am happy with the 1.2 version, which was the last before the shipped version. It seems to work fine with my panel firmware.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Use single On/Off/Slider to control group jkmonroe 3 965 08-06-2016, 09:28 AM
Last Post: pinballmark
  Help figuring out projector serial control! Deane Johnson 19 2,471 07-30-2016, 11:08 AM
Last Post: Deane Johnson
  Harmony Hub Device Control jkmonroe 6 1,666 07-03-2016, 02:36 PM
Last Post: potts.mike
  how deep is your (echo voice control) love? IVB 197 13,956 05-23-2016, 08:47 AM
Last Post: Dean Roddey
  Problems with App Control in 4.8.3 update MikeA 2 1,001 04-07-2016, 07:29 AM
Last Post: MikeA
  Control surface - am I heading down a rat hole? kjaerligkatt 3 1,275 02-06-2016, 10:52 AM
Last Post: Dean Roddey
  Tivo control question MikeA 21 5,152 12-26-2015, 06:29 PM
Last Post: dogman
  Volume Control greyjeep 3 1,121 11-21-2015, 10:56 AM
Last Post: Dean Roddey
  Adding Christmas Light control to CQC with Lutron HW8 avtexan 10 2,428 11-18-2015, 12:35 PM
Last Post: avtexan
  Roku as media player with CQC media control bryanb 11 3,613 01-11-2015, 05:17 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)