Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New Z-Wave driver preview
#21
Am I the only one trying to make the new ZWAVE driver work with a SmartThings hub as a primary controller? Wired devices work fine and show up properly, battery operated Yale locks works just fine. All other battery devices I have will not add into CQC. CQC knows that they are there but I cannot get them to talk properly.

I'm testing with a Linear WADWAZ-1. According to the device documentation I should simply have to open the case to wake it up, tried that. Also tried pulling the battery and re-inserting. Still won't get picked up. Tried forcing the configuration to the correct MFG, Unit type, no dice.

Why is it that the Yale locks will work, even though they are battery but other battery devices won't? That's a puzzler. The fact that they do work indicates that any battery device in theory should work. The only difference perhaps is that they are using the secured zwave protocol but why should that matter?
Reply
#22
Locks are not really battery powered. They are 'frequent listeners' so they can be talked to at any time. Real battery powered units are a different deal.

What state are those units in? That will tell us more about what is going on.

If you swap the batteries and that doesn't work, that may mean that it's a not so helpful unit that doesn't send out a node information frame in that case. Though, you may also need to wait 30 seconds or so to make sure any capacitors bleed that might keep it alive for a short period of time.

If that doesn't work, then enable the trace (or flush it if currently on) and do the battery, then close the trace and post the file. If it's broadcasting the node info frame we should be able to see it.

As to setting it manually, what do you mean no dice? That should always work. When you do that, does it go to WaitApprove? If you then approve it, does it go to ready state?
Dean Roddey
Software Geek Extraordinaire
Reply
#23
I mean that it goes to WaitApprove, goes online ready, and then nothing shows up in the data fields for the device, they remain ???
Reply
#24
That's to be expected, at least for a period of time. We can't talk to them to get the value. They only send out a value when triggered. Or in some cases on a schedule. If you trigger the door on one of them, does the value show up?
Dean Roddey
Software Geek Extraordinaire
Reply
#25
No the value does not show up, it never shows up. Master controller reflects the state change immediately.

On a different note, if I have any of the battery devices enabled (whether "configured" or not) then none of the wired devices respond properly.

Lastly, I have 1 wired device that is not responding either even though it was identified correctly and approved. It's the ACT LRM-AS, client side driver indicates that the device is "Ready". There is nothing in the ZWAVE trace file. CQC Log entry below when I try to write to toggle the light switch:

07/06 09:55:00-NCC1701-D, CQCServer, CQCDrv_zwaveThread23
{
CQCKit, CQCDriver_DriverBase.cpp.7204, Failed/Not Ready, Error: 2017/0/0
Field 'MBR_Foyer_Switch' is currently in error state
<CQCServer> CQCDriver_DriverBase.cpp - 8696
<CQCServer> CIDOrb_ThisFacility.cpp - 536
<CQCAdmin> CQCKit_CQCSrvAdminClientProxy.cpp - 1945
<CQCAdmin> CQCAdmin_DrvMonTab.cpp - 1325

}
Reply
#26
There aren't any ACT units supported. So it must be a re-branded version of something else. What does it show up as in the client side interface when it gets id'd?
Dean Roddey
Software Geek Extraordinaire
Reply
#27
ACT. I sent you the device file this morning, same info I provided you several months ago that allowed it to be recognized. Emailed a screen shot
Reply
#28
OK, it's actually an Evolve LRM-AS, which I guess ACT rebrands? Not sure why I indicated ACT in the device info file. That guy doesn't support associations so it can't report its state. We don't poll anything, so it would be a write only unit. The driver should show Write access on for it.
Dean Roddey
Software Geek Extraordinaire
Reply
#29
It does but it errors out if I try to write to it from the new driver, works just fine from the old driver, just now re-verified this.
Reply
#30
Flush the CQC logs, and the driver trace, put the driver into verbose, do the field write, then go back to normal and send me both log outputs. Let's see what is going on.
Dean Roddey
Software Geek Extraordinaire
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  CML Driver IDE [copy/paste] does not work lleo 2 94 11-25-2018, 10:01 AM
Last Post: lleo
  How to update the new zwave stick/driver? ghurty 5 146 11-22-2018, 06:56 PM
Last Post: Dean Roddey
  "Client Side Driver Directory Could Not be Cleaned Out" TurboSam 15 967 09-27-2018, 01:43 PM
Last Post: TurboSam
  CML Driver IDE docs - where? rbroders 1 283 09-18-2018, 05:41 PM
Last Post: Dean Roddey
  Timer Driver Question kblagron 5 459 09-14-2018, 02:43 AM
Last Post: znelbok
  reset driver statistics? rbroders 9 861 09-11-2018, 07:50 PM
Last Post: Dean Roddey
  Driver Configuration w/8 prompts rbroders 1 461 09-03-2018, 09:28 PM
Last Post: Dean Roddey
  Driver info/stats rbroders 6 750 09-02-2018, 08:34 PM
Last Post: Dean Roddey
  Sonos Driver zra 3 505 09-01-2018, 03:09 PM
Last Post: Dean Roddey
  HTTP Get driver not working znelbok 10 1,072 08-28-2018, 10:10 AM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)