Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CQC WebRiva not pulling up
#11
I may just get rid of the logo if I can't find a way to insure it can reliably display.
Dean Roddey
Software Geek Extraordinaire
Reply
#12
(01-12-2018, 10:41 AM)Dean Roddey Wrote: It looks like the inability to draw the logo, which used to be semi-benign, now causes an exception that keeps it from starting up. I've attached a zip file. It contains the main app file. Drop the contained file into:

[cqc]\CQCData\HTMLRoot\CQSL\WebRIVA\Src

overwriting the existing file there and see if this fixes it?

sorry, forgot to do this until just now.

Yup, that fixed it.
------------------------------------
Devices I'm phasing out: ISY, NuVo
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
Reply
#13
OK, they must have changed something. Probably decided there was some potential exploit if they didn't treat it as a bad error or something. That change will be in the next drop.
Dean Roddey
Software Geek Extraordinaire
Reply
#14
For me it comes up but leaves a broken icon thingy where the logo graphic would go
Reply
#15
Yeh, I think it's some change in the latest browser updates or something. It used to do that for everyone. That it suddenly, for both me and Vivek, became deadly seems an unlikely coincidence. So I guess something must have changed in the browser. The RIVA code hasn't changed for a month or more.
Dean Roddey
Software Geek Extraordinaire
Reply
#16
I finally decided to get WebRiva going. Having the same problem as first explain by IVB. Stuck at "Connecting" in chrome and the debug menu in IE.
I did DL the file you posted but that didn't help. Is this still a problem or am I missing something else.

I'm on 5.2.10
Thanks
George M
Reply
#17
that's all i had to do.
------------------------------------
Devices I'm phasing out: ISY, NuVo
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
Reply
#18
If you are on 5.2.10, don't use that file. The fix is already there and things have changed from that, so you'd be making things worse. Just take the 5.2.10 content as is.

The usual things are:

1. Make sure you have a default template assigned to the user
2. Make sure the user/password are the correct case
3. Make sure that you are licensed for WebRIVA. It's new stuff so your license may not have it enabled because either you haven't gotten a new license since then, or I failed to notice it wasn't enabled last time. If so, just e-mail me and I can send you a new one. Go to the /System section and there's a license info option in there. See if it's in the list of enabled options.
Dean Roddey
Software Geek Extraordinaire
Reply
#19
(01-19-2018, 09:38 AM)Dean Roddey Wrote: If you are on 5.2.10, don't use that file. The fix is already there and things have changed from that, so you'd be making things worse. Just take the 5.2.10 content as is.

The usual things are:

1. Make sure you have a default template assigned to the user
2. Make sure the user/password are the correct case
3. Make sure that you are licensed for WebRIVA. It's new stuff so your license may not have it enabled because either you haven't gotten a new license since then, or I failed to notice it wasn't enabled last time. If so, just e-mail me and I can send you a new one. Go to the /System section and there's a license info option in there. See if it's in the list of enabled options.

Since I had already overwritten the file I did a new install of 5.2.10

1. Have template assigned
2. Checked on user / password
3. It is licensed.

The logo starts to come up, but imediately goes to the "Connecting ..."
Thanks
George M
Reply
#20
Update.

Rebooted again and now it comes up.
Now to learn about scaling.
Thanks
George M
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Certficates and WebRIVA kblagron 5 243 03-07-2018, 06:02 PM
Last Post: Dean Roddey
  A proposal for implementing RIVACmd on WebRIVA Dean Roddey 7 377 02-22-2018, 08:18 PM
Last Post: znelbok
  WebRiva, scaling? IVB 17 777 02-06-2018, 11:25 AM
Last Post: znelbok
  WebRiva Chrome Resetting to Default Template Jnetto 1 200 01-04-2018, 09:40 PM
Last Post: Dean Roddey
  cqc server access and webriva zane 29 1,481 12-25-2017, 04:06 PM
Last Post: zane
  Pushing vs. pulling fields and events Jonathan 18 3,280 04-04-2009, 11:50 PM
Last Post: bjkiller

Forum Jump:


Users browsing this thread: 1 Guest(s)