Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CQC WebRiva not pulling up
#1
Not sure where the docs are for WebRIVA, couldn't find them on Help.

When I hit the Webriva URL via 
http://localhost:(my-port)/CQSL/WebRiva/index.html?user=Web?pw=Welcome

it just sits at "Connecting to CQC".

I know the Web Server works fine as I can hit my other CQC web pages (have had one all text based on with various fields for read-only). 

Not sure what i'm doing wrong, although if you point me to the help docs I can look that up.
------------------------------------
Devices I'm phasing out: ISY, NuVo
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
Reply
#2
Hmm. Chrome doesn't work, but Internet Explorer shows this. Not my default template though.


Client Debug Options:


Log Graphics Cmds


Log Image Processing


Log Miscellaneous Events


Log Mouse/Touch Input


Log Websock Events


Server Debug Options:


Log Msgs Received at Server


Log Server Faux GUI Events


Disable Template Caching


Display Options:


Full Screen Mode

Close
------------------------------------
Devices I'm phasing out: ISY, NuVo
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
Reply
#3
URL is wrong
http://localhost:(my-port)/CQSL/WebRiva/index.html?user=Web?pw=Welcome

the last ? should be an &

http://localhost:(my-port)/CQSL/WebRiva/index.html?user=Web&pw=Welcome
Mykel Koblenz
Illawarra Smart Home
Reply
#4
Also not sure which IE version you are using, but older versions do not support HTML templates. If charmedquark.com works than should be OK.
Reply
#5
Oy. It worked exactly once replacing the question with ampersand. I upgraded to the latest beta, and now it's back to returning the above screen on both IE & Chrome (latest versions)
------------------------------------
Devices I'm phasing out: ISY, NuVo
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
Reply
#6
(01-11-2018, 10:32 PM)IVB Wrote: Oy. It worked exactly once replacing the question with ampersand. I upgraded to the latest beta, and now it's back to returning the above screen on both IE & Chrome (latest versions)


What is your URL now? Assume you have checked that the username you are using default template is valid.


This is my working URL on port 8181
"http://192.168.2.118:8181/cqsl/webriva/index.html?user=ipad&pw=xxxx"
_______________
Denon 3808ci, 2112ci , SONOS, Russound CAA66,Z-Wave(Lights,Locks), Hue, SmartThings,
iPads,Tivo,Hikvision,Elk-M1,iTunes,TED5000,Somfy RTS blinds, Amazon Echo, Google Home, Polk XRT12,
Honeywell Wi-Fi 9000 & Caleo Wi-Fi Thermostats, Rainmachine
Reply
#7
Hmmm... It doesn't seem to be working for me in 5.2.9 either. Let me poke around a bit. Maybe I messed something up. Though something has changed in Chrome as well. It seems to be trying to force a secure connection, even just for a local connection.
Dean Roddey
Software Geek Extraordinaire
Reply
#8
Chrome IS forcing a secure connection, or it's a bug they just introduced. I do this:

http://cqsl-vm-host/CQSL/WebRIVA/index.html?user=Kiosk&pw=Welcome

Chrome (initially) gives some dire warning screen that the target has no certificate, which of course it shouldn't have to since I'm not making a secure connection. It gives me two options one is to continue unsecure. I do that, and it displays the URL with a crossed out https, see image.


.jpg   ChromeConn.jpg (Size: 12.62 KB / Downloads: 6)

When the URL gets to the web server it clearly has an https prefix on it, so of course WebRIVA tries to make a secure websocket connection, which doesn't work because I don't have my development web server set up for that.
Dean Roddey
Software Geek Extraordinaire
Reply
#9
Oh well, it stopped again. I guess it must be a bug where even if you say go on non-secure it still does secure, until you close that tab and go back and enter the non-secure URL explicitly again or something.
Dean Roddey
Software Geek Extraordinaire
Reply
#10
It looks like the inability to draw the logo, which used to be semi-benign, now causes an exception that keeps it from starting up. I've attached a zip file. It contains the main app file. Drop the contained file into:

[cqc]\CQCData\HTMLRoot\CQSL\WebRIVA\Src

overwriting the existing file there and see if this fixes it?


Attached Files
.zip   App.js.Zip (Size: 8.32 KB / Downloads: 6)
Dean Roddey
Software Geek Extraordinaire
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  WebRiva and vpscale=? kblagron 1 117 08-28-2018, 08:12 AM
Last Post: Dean Roddey
  Is it possible to direct link with webriva? ghurty 1 206 07-24-2018, 05:04 PM
Last Post: Dean Roddey
  WebRiva on Android George M 20 1,064 07-22-2018, 09:07 AM
Last Post: Dean Roddey
  WebRiva, Android, scaling issue IVB 2 276 07-15-2018, 01:47 PM
Last Post: IVB
  HTML5 and Webriva and the Interface Veiwer ghurty 1 228 07-11-2018, 10:50 PM
Last Post: Dean Roddey
  How to tell WebRiva to rebuild itself ghurty 3 358 05-24-2018, 09:50 PM
Last Post: Dean Roddey
  Does anyone have a nice interface set up using the new webRiva system? ghurty 0 192 05-15-2018, 03:13 PM
Last Post: ghurty
  WebRIVA disconnect issue dlmorgan999 11 996 05-09-2018, 09:38 AM
Last Post: Dean Roddey
  Certficates and WebRIVA kblagron 5 751 03-07-2018, 06:02 PM
Last Post: Dean Roddey
  A proposal for implementing RIVACmd on WebRIVA Dean Roddey 7 951 02-22-2018, 08:18 PM
Last Post: znelbok

Forum Jump:


Users browsing this thread: 1 Guest(s)