Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sonos Drivers
#11
Did you restart it or something after you changed the verbosity, since it's not logging any verbose info. Flush the logs, put it into high verbosity, let it run for a minute, then take it back out and get a dump.
Dean Roddey
Software Geek Extraordinaire
Reply
#12
I flushed the logs, set to high verbosity and then reconfigured the driver. Does that reset the verbosity? The driver still shows high verbosity.

I restarted the Sonos now, so will need to wait for it to disconnect again.
Reply
#13
I am having issues with both Sonos drivers disconnecting now.  If I reconfig the drivers, they find the UPnp but will not connect.  

If I reboot the Sonos Connect, I can get them to connect, but for only about 30 minutes, and they go offline.  Same setup as before - I wonder if this is related to OP?  Maybe a new version of Sonos doing something it didn't before.
Reply
#14
ok, after 5 days of the the Sonos driver working perfectly, it is now failing to connect again. In fact it has failed to connect after installing the latest patch. 

Attached is a log, that seems to show nothing specific.  The driver has been in high verbosity since 20:28:00


Attached Files
.txt   dump.txt (Size: 13.08 KB / Downloads: 4)
Reply
#15
I am on 8.2.2 and everything is working fine. Is there an update beyond that?

Ignore me - I am only using the ZonePlayer driver and noticed you're using the Renderer.
do the needful ...
Hue | Sonos | Harmony | Elk M1G // Netatmo / Brultech
Reply
#16
Yes, the ZonePlayer continues to connect and work whilst the Renderer is in this state.
Reply
#17
There's nothing there. If this happens, can you do a reconfigure on the driver and find the Sonos again and it starts connecting again? Or does that Sonos not show up in the list of available devices?
Dean Roddey
Software Geek Extraordinaire
Reply
#18
When I reconfigure, it shows up in the list when I search for available devices but still wont connect.  See updated log.

To reconnect i have to power cycle the device. The Sonos Zone Player will however connect at this point.


Attached Files
.txt   dump.txt (Size: 13.05 KB / Downloads: 1)
Reply
#19
There just isn't anything useful in there. I'm not sure why it's not logging more info if in verbose mode. I'll look at it.
Dean Roddey
Software Geek Extraordinaire
Reply
#20
Finally had a chance to look at this more.  Here is what I found.

I was having problems connecting to both drivers, and on my system, I run both drivers Sonos Media Renderer and ZonePlayer, and keep track of which driver is in control through a variable.  This has worked fine for at least a year.

I noticed they had disconnected (about 3-4 days ago), reset the Sonos, and they were up and running, but they went offline within the hour.  Tonight I couldn't get them running, even with the Sonos reset, so I rebooted the CQC Server, and both came online.

I then went into my IV where I access the two drivers, and the ZonePlayer works fine, as before.  The Sonos Media Renderer does not show any tracks from the Music Repository, even though the driver is up.

I am rebuilding the Music Repo now, and will let you know what happens, but something has changed with Sonos recently.  I may have upgraded the box, but don't remember doing so.

I am on 8.2.2 with Sonos, and 5.2.1 with CQC.

Update - As I was typing this out, the MusicRepo finished, and both drivers went offline, which is what I have seen in the past with reboots.  I have attached the log files.  I have not changed anything to my CQC system, and on the Sonos, I may have updated it, as I recently integrated Sonos to the Echo in order for me to play Amazon music via Sonos through voice commands.


Attached Files
.txt   CQCSnaptoFile.txt (Size: 33.73 KB / Downloads: 3)
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Sonos stops after CQC restart batwater 1 79 05-18-2018, 10:12 AM
Last Post: Dean Roddey
  Sonos Driver with Sonos Connect Amp zra 5 277 05-05-2018, 09:43 AM
Last Post: Dean Roddey
  Drivers and Hardware List wusupwchu 3 329 02-20-2018, 04:35 PM
Last Post: Dean Roddey
  Updated to V2 media drivers tom 8 839 11-26-2017, 11:10 AM
Last Post: Dean Roddey
  Moving drivers to another machine (or renaming a machine) Dean Roddey 0 417 10-04-2017, 11:57 AM
Last Post: Dean Roddey
  Has anyone done the Sonos Upgrade kblagron 2 1,060 07-16-2017, 10:27 AM
Last Post: Dean Roddey
  Drivers missing zra 29 4,891 07-05-2017, 07:38 PM
Last Post: Dean Roddey
  Which one of the CQC simulator drivers would be the best to simulate sonos? ghurty 1 871 04-02-2017, 07:41 PM
Last Post: Dean Roddey
  Sonos Zone Player V2? karenlee 36 7,748 03-26-2017, 09:38 AM
Last Post: Dean Roddey
Exclamation Sonos API Changes batwater 14 3,568 03-23-2017, 06:36 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 2 Guest(s)